現在オフラインです。再接続するためにインターネットの接続を待っています

お使いのブラウザーはサポートされていません

このサイトを利用するには、ブラウザーを更新する必要があります。

Internet Explorer を最新バージョンに更新する

[INP2003] [HOWTO] Microsoft Office InfoPath 2003 フォームの既定のビューをスクリプトで変更する方法

Office 2003 のサポートは終了しました

マイクロソフトでは、2014 年 4 月 8 日に Office 2003 のサポートを終了しました。この変更は、ソフトウェアの更新プログラムおよびセキュリティ オプションに影響しています。 この変更の意味および保護された状態を維持する方法について説明します。

概要
Microsoft Office InfoPath フォームでは複数のビューがサポートされており、その 1 つが既定のビューに設定されています。InfoPath でフォームを開くと、そのフォームは既定のビューで開きます。この資料では、InfoPath フォームで使用される既定のビューをスクリプトで変更する方法について説明します。

先頭に戻る

新しいフォームを作成する

  1. InfoPath 2003 を起動します。
  2. [ファイル] メニューの [フォームのデザイン] をクリックします。
  3. [フォームのデザイン] 作業ウィンドウの [新しい空白のフォーム] をクリックします。
先頭に戻る

ビュー 1 を作成する

  1. 空白のフォームで、最初の行にこれはビュー 1 ですと入力し、2 行目にフォームを開いたときビュー 2 で表示するには、次のチェック ボックスをオンにしますと入力します。
  2. 作業ウィンドウ右上の下向き矢印をクリックし、一覧の [コントロール] をクリックします。
  3. [コントロール] 作業ウィンドウで [チェック ボックス] をクリックします。
  4. [チェック ボックス] の "フィールド 1" をビュー 2 に変更します。
先頭に戻る

ビュー 2 を作成する

  1. 作業ウィンドウ右上の下向き矢印をクリックし、一覧の [ビュー] をクリックします。

    フォームの既定のビューはビュー 1 です。
  2. [ビュー] 作業ウィンドウの [操作] の下にある [新しいビューの追加] をクリックします。
  3. [新しいビュー名] ボックスにビュー 2 と入力し、[OK] をクリックします。
  4. 空のフォームにこれはビュー 2 ですと入力します。
先頭に戻る

スクリプトを追加する

  1. [ツール] メニューの [スクリプト] をポイントし、[Microsoft Script Editor] をクリックします。
  2. コード ウィンドウに次のコードを追加します。
    function XDocument::OnLoad(eventObj){	//Pick the default view based on the value of element DefaultView	var objDefaultView = XDocument.DOM.selectSingleNode("//my:フィールド1");	if ((objDefaultView != null) && (objDefaultView.text != ""))   	{		switch (objDefaultView.text)      		{         		case "false":				    XDocument.ViewInfos("ビュー 1").IsDefault = true;            			break;         		case "true":            			XDocument.ViewInfos("ビュー 2").IsDefault = true;            			break;      		}   	}}
  3. スクリプトを保存して Microsoft Script Editor を閉じます。
  4. フォーム テンプレートを SwitchDefaultView.xsn という名前で保存し、フォーム テンプレートを閉じます。
先頭に戻る

実際に試してみる

  1. [ファイル] メニューの [フォームの入力] をクリックします。

    : ここでは、[フォームのプレビュー] ではなく、[フォームの入力] を使用します。プレビューには、OnLoad イベントに追加された既定のビューのスクリプトによる変更は反映されません。プレビュー モードでは、InfoPath のデザイナで選択されているビューが常に表示されます。
  2. [フォームの入力] 作業ウィンドウの [SwitchDefaultView] をクリックします。

    フォームがビュー 1 (当初の既定のビュー) で開きます。
  3. [ビュー 2] チェック ボックスをオンにします。
  4. フォームを SwitchDefaultViewForm.xml という名前で保存して閉じます。
  5. [ファイル] メニューの [開く] をクリックします。
  6. SwitchDefaultViewForm.xml をクリックし、[開く] をクリックします。

    フォームがビュー 2 で開きます。
先頭に戻る
関連情報
この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 826997 (最終更新日 2003-09-17) を基に作成したものです。

この資料に含まれているサンプル コード/プログラムは英語版を前提に書かれたものをありのままに記述しており、日本語環境での動作は確認されておりません。
プロパティ

文書番号:826997 - 最終更新日: 10/15/2003 18:07:00 - リビジョン: 2.0

  • Microsoft Office InfoPath 2003
  • kbhowto KB826997
フィードバック
cript> >ascript' src='" + (window.location.protocol) + "//c.microsoft.com/ms.js'><\/script>");