Visual Studio 2005 または Visual Studio .NET を使用して、Windows スクリプトを作成する方法

重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。

英語版 KB:827075
概要
この資料では、Microsoft Visual Studio 2005または Microsoft Visual Studio .NET を使用して Microsoft Windows スクリプトを作成する方法について説明します。Windows スクリプトを実行するには、Windows エクスプ ローラーでスクリプト ファイルをダブルクリックします。

Microsoft Windows スクリプト ホスト (WSH) は、Windows スクリプトと互換性のあるスクリプト エンジンの言語に依存しないスクリプティング ホストです。WSH は、スクリプトをホストしている環境を作成します。スタンドアロン スクリプトは、テキスト ファイルを実行します。スクリプトを実行すると、WSH は、オブジェクトとスクリプトのサービスを提供します。WSH を使用すると、Windows のデスクトップにし、コマンド プロンプトでスクリプトを実行します。WSH は Microsoft Windows 98 またはそれ以降にに組み込まれています。

通常、Windows のスクリプトは、Microsoft JScript または Microsoft Visual Basic Scripting Edition (VBScript) のいずれかで書き込まれます。これらのプログラミング言語のスクリプト エンジンは、以降の Windows 98 に含まれています。JScript で記述されているスタンドアロンのスクリプトには、.js ファイル名の拡張子があります。VBScript で記述されているスタンドアロンのスクリプトでは、.vbs ファイル名の拡張子があります。Windows では、これらのファイル名拡張子が登録されています。

Perl、REXX、Python などの他の言語で Windows のスクリプトを記述することも可能性があります。ただし、Windows でこれらのプログラミング言語のスクリプト エンジンを登録する必要があります。登録済みの Windows スクリプトを実行すると、Windows は、WSH を起動します。WSH では、関連付けられたスクリプト エンジンを解釈して、スクリプトを実行するアクティブにします。

Visual Studio 2005 または Visual Studio .NET を使用して、JScript と VBScript でスクリプトを開発することができます。Visual Studio 2005 または Visual Studio .NET を使用して、WSH ファイルを展開することもできます。WSH ファイルのファイル名拡張子は .wsf です。WSH ファイルは、スクリプトの一部として他のスクリプト ファイルを含めることができます。そのため、複数の WSH ファイルが、1 つの場所に作成および格納されている便利な関数のライブラリを参照することがあります。また、1 つの WSH ファイル内で JScript と VBScript を組み合わせることができます。

Visual Studio 2005 または Visual Studio .NET を使用して、スクリプトをデバッグすることもできます。ただし、Visual Studio 2005 または Visual Studio .NET をインストールすると、Visual Studio 2005 または Visual Studio .NET のデバッガーがスクリプトの既定のデバッガーとして自動的にインストールされます。そのため、Visual Studio 2005 または Visual Studio .NET のデバッガーは、Internet Explorer などのアプリケーションの Windows スクリプト デバッガーと置き換えられます。

先頭に戻る

要件

推奨されるハードウェア、ソフトウェア、ネットワーク インフラストラクチャ、および必要な service pack は次をとおり。
  • Microsoft Windows 2000、Microsoft Windows XP または Server 2003 のコントロール
  • Microsoft Visual Studio 2005年または Microsoft Visual studio.net
この資料では、次のトピックに精通するいると仮定しています。
  • Microsoft Windows スクリプト テクノロジを作成します。
先頭に戻る

単純な JScript ファイル (JScript1.js) を作成します。

  1. エクスプローラーを起動します。
  2. 任意の場所には、namedMyFolder フォルダーを作成します。
  3. Visual Studio 2005 または Visual Studio .NET を起動します。
  4. [ファイル] メニューで、新規作成] をポイントし、[ファイル] をクリックします。NewFile ] ダイアログ ボックスが表示されます。
  5. [カテゴリ] で、[スクリプト] をクリックします。
  6. [テンプレート] [ JScriptFileを] をクリックします。
  7. [開く] をクリックします。既定では、JScript1、探しているファイルが作成されます。
  8. JScript1 ファイルでは、次のコードを見つけます。
    // JScript source code
  9. Instep 8 が配置されているコードの後に、次のコードを貼り付けます。
    // Display a message.WScript.Echo("Simple JScript File");
  10. [ファイル] メニューには、 SaveJScript1 としてをクリックします。[ファイルに名前を付けて保存] ダイアログ ボックスが表示されます。
  11. ファイルに名前を付けて保存] ダイアログ ボックスのでをクリックしてステップ 2 で作成したMyFolderフォルダーを探します。
  12. [保存] をクリックします。MyFolder で JScript1.js ファイルが生成されます。
  13. [ファイル] メニューの [閉じる] をクリックします。
先頭に戻る

単純な VBScript ファイル (VBScript1.vbs) を作成します。

  1. Visual Studio 2005年または Visual Studio .NET では、[ファイル] メニューの [新規] をポイントし、ファイルをクリックします。新しいファイルダイアログ ボックスが表示されます。
  2. [カテゴリ] で、[スクリプト] をクリックします。
  3. [テンプレート] [ VBScriptFileを] をクリックします。
  4. [開く] をクリックします。既定では、名前を付けて VBScript1 探しているファイルが作成されます。
  5. 名前を付けて VBScript1 ファイルでは、次のコードを見つけます。
    ' VBScript source code
  6. Instep 5 が配置されているコードの後に、次のコードを貼り付けます。
    ' Display a message.WScript.Echo "Simple VBScript File"
  7. [ファイル] メニューには、 SaveVBScript1 としてをクリックします。[ファイルに名前を付けて保存] ダイアログ ボックスが表示されます。
  8. ファイルに名前を付けて保存] ダイアログ ボックスでフォルダーに移動しクリックMyFolderのステップ 2 で作成した、「単純な JScript の File(JScript1.js) を作成します。"この資料の「。
  9. [保存] をクリックします。MyFolder で VBScript1.vbs ファイルが生成されます。
  10. [ファイル] メニューの [閉じる] をクリックします。
先頭に戻る

関数を含む JScript ファイル (JScript2.js) を作成します。

  1. Visual Studio 2005年または Visual Studio .NET では、[ファイル] メニューの [新規] をポイントし、ファイルをクリックします。新しいファイルダイアログ ボックスが表示されます。
  2. [カテゴリ] で、[スクリプト] をクリックします。
  3. [テンプレート] [ JScriptFileを] をクリックします。
  4. [開く] をクリックします。既定では、JScript2、探しているファイルが作成されます。
  5. JScript2 ファイルでは、次のコードを見つけます。
    // JScript source code
  6. Instep 5 が配置されているコードの後に、次のコードを貼り付けます。
    // MyFunction is a function that returns "MyFunction".function MyFunction(){   return "MyFunction";}
  7. [ファイル] メニューには、 SaveJScript2 としてをクリックします。[ファイルに名前を付けて保存] ダイアログ ボックスが表示されます。
  8. ファイルに名前を付けて保存] ダイアログ ボックスでフォルダーに移動しクリックMyFolderのステップ 2 で作成した、「単純な JScript の File(JScript1.js) を作成します。"この資料の「。
  9. [保存] をクリックします。MyFolder で JScript2.js ファイルが生成されます。
  10. [ファイル] メニューの [閉じる] をクリックします。
先頭に戻る

Windows スクリプト ホスト ファイル (WindowsScript1.wsf) を作成します。

  1. Visual Studio 2005年または Visual Studio .NET では、[ファイル] メニューの [新規] をポイントし、ファイルをクリックします。新しいファイルダイアログ ボックスが表示されます。
  2. [カテゴリ] で、[スクリプト] をクリックします。
  3. [テンプレート] には、 WindowsScript ホストをクリックします。
  4. [開く] をクリックします。既定で、WindowsScript1file が作成されます。
先頭に戻る

Windows スクリプト ホスト ファイル内の JScript2.js ファイルを含める

  1. Orin Visual Studio .NET の Visual Studio 2005年で [表示] メニューのHTML ソース] をクリックし、WindowsScript1 ファイルに次のコードを検索します。
    <script language="JScript">
    Visual Studio .NET 2002 では、theWindowsScript1 ファイルに次のコードを見つけます。
    <script language="JScript">
  2. 次のコードには、手順 1 で見つけたコードを置き換えます。
    <script language="JScript" src="JScript2.js">
  3. WindowsScript1 ファイルでは、次のコードを見つけます。
    WScript.Echo "VBScript"
  4. Instep 3 が配置されているコードの後に、次のコードを貼り付けます。
    ' Retrieve the return value of the MyFunction function _' into the retVal variable.retVal = MyFunction()' Display the retrieved return value.WScript.Echo retVal
  5. [ファイル] メニューには、 SaveWindowsScript1 としてをクリックします。[ファイルに名前を付けて保存] ダイアログ ボックスが表示されます。
  6. ファイルに名前を付けて保存] ダイアログ ボックスでフォルダーに移動しクリックMyFolderのステップ 2 で作成した、「単純な JScript の File(JScript1.js) を作成します。"この資料の「。
  7. [保存] をクリックします。MyFolder で WindowsScript1.wsf ファイルが生成されます。
  8. [ファイル] メニューの [閉じる] をクリックします。
先頭に戻る

スクリプトを実行します。

  1. Windows エクスプ ローラーに切り替えてください。
  2. 見つけて、 MyFolderフォルダーに含まれるは、手順 2 で作成したをクリックします"作成簡単な JScript ファイル (JScript1.js)"この資料のセクションです。
  3. JScript1.jsファイルをダブルクリックします。Windows スクリプト ホストのメッセージ ボックスには、次のテキストを含むが表示されます。
    単純な JScript ファイル
  4. このメッセージ ボックスを閉じます[ok]をクリックします。
  5. VBScript1.vbsファイルをダブルクリックします。Windows スクリプト ホストのメッセージ ボックスには、次のテキストを含むが表示されます。
    単純な VBScriptFile
  6. このメッセージ ボックスを閉じます[ok]をクリックします。
  7. WindowsScript1.wsfファイルをダブルクリックします。Windows スクリプト ホストのメッセージ ボックスには、次のテキストを含むが表示されます。
    JScript
  8. このメッセージ ボックスを閉じます[ok]をクリックします。Windows スクリプト ホストのメッセージ ボックスには、次のテキストを含むが表示されます。
    VBScript
  9. このメッセージ ボックスを閉じます[ok]をクリックします。Windows スクリプト ホストのメッセージ ボックスには、次のテキストを含むが表示されます。
    MyFunction
  10. このメッセージ ボックスを閉じます[ok]をクリックします。
先頭に戻る
関連情報
詳細については、次の Microsoft Developer Network (MSDN) Web サイトを参照してください。先頭に戻る

警告: この記事は自動翻訳されています

プロパティ

文書番号:827075 - 最終更新日: 07/03/2016 14:10:00 - リビジョン: 6.0

Microsoft Visual Studio 2005 Standard Edition, Microsoft Visual Studio 2005 Professional Edition, Microsoft Visual Studio .NET 2003 Enterprise Architect, Microsoft Visual Studio .NET 2003 Enterprise Developer, Microsoft Visual Studio .NET 2003 Academic Edition, Microsoft Visual Studio .NET 2002 Professional Edition, Microsoft Visual Studio .NET 2002 Enterprise Architect, Microsoft Visual Studio .NET 2002 Enterprise Developer, Microsoft Visual Studio .NET 2002 Academic Edition

  • kbvs2005swept kbvs2005applies kbdebug kbsample kbcode kbscript kbprogramming kbhowtomaster kbmt KB827075 KbMtja
フィードバック