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Windows XP から割り当てられたネットワーク共有に保存されているファイルが破損しています。

Windows XP のサポートは終了しました

マイクロソフトでは、2014 年 4 月 8 日に Windows XP のサポートを終了しました。この変更は、ソフトウェアの更新プログラムおよびセキュリティ オプションに影響しています。 この変更の意味および保護された状態を維持する方法について説明します。

重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。

英語版 KB:885936
現象
Microsoft Windows XP ベースのコンピューターから Windows ベースのサーバー上のネットワーク共有にファイルを保存しようとすると、保存したファイルが壊れています。通常、保存されたファイルに、予期されるデータではなく、ファイルの末尾にゼロが含まれます。
原因
メモリは、書き込みキャッシュのフラグが設定されていないファイルをマップするプログラムを使用すると、この問題が発生し、設定ファイルの終わりが、プログラムから受信します。この問題は、次の条件のいずれかが true の場合は、クライアント コンピューターを使用してファイルを保存するために発生します。
  • マイクロソフトの Windows XP Service Pack 2 がインストールされています。
  • 次のマイクロソフト サポート技術情報の資料に記載されている修正プログラムがインストールされます。
    811169 ネットワーク リダイレクターのパフォーマンスを向上させる更新プログラム
このシナリオでは、ファイルのビューは、マップが解除される前に、キャッシュはフラッシュされません。
回避策
この問題を回避するには、ファイルの保存先のサーバー上で便宜的ロックを無効にします。これには、次のレジストリ サブキーに、これらのレジストリ値を「0」を設定します。
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
これを行うには、次の手順を実行します。
  1. [スタート] ボタン、実行をクリックして型 regedit、し、ENTER キーを押します。
  2. 次のレジストリ サブキーを見つけてクリックします。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
  3. これらの値が右側のウィンドウで存在しない場合は、作成する必要があります。これを行うには、次の手順を実行します。
    1. 左側のペインで [パラメーター ] を右クリックを新規作成] をポイントし、[ DWORD 値] をクリックします。
    2. タイプ これら 値、名前をし、ENTER キーを押します。
  4. これらを右クリックし、[変更] をクリックします。
  5. [値のデータ] ボックスで、次のように入力します。 0、し、ENTER キーを押します。
  6. レジストリ エディターを終了します。
解決方法

修正プログラムの情報

サポートされている修正プログラムをマイクロソフトから入手することができます。ただし、この修正プログラムはこの資料に記載されている問題のみを修正するものです。この修正プログラムはこの問題が発生しているシステムにのみ適用して下さい。この修正プログラムには、さらに追加テストが行われる可能性があります。したがって、この問題により深刻な影響を受けていない場合は、この修正プログラムを含む次のソフトウェア更新プログラムのリリースを待つことをお勧めします。

修正プログラムがダウンロード可能な場合は、この記事の上部に「修正プログラムのダウンロード」セクションが表示されます。このセクションが表示されない場合は、マイクロソフト カスタマー サービス & サポートへお問い合わせいただき、修正プログラムを入手してください。

注: その他の問題が発生した場合、またはトラブルシューティングが必要な場合は、別のサービス リクエストを作成する必要があります。追加の質問およびこの特定の修正プログラムの対象とならない問題については、通常のサポート料金が適用されます。マイクロソフト カスタマー サービス & サポートの電話番号の一覧または別のサービス リクエストを作成するには、次のマイクロソフト Web サイトを参照してください。 注: 「修正プログラムのダウンロード」フォームには、修正プログラムを利用可能な言語が表示されます。お使いの言語が見つからない場合は、修正プログラムがその言語で利用可能ではありません。

ファイル情報

この修正プログラムの英語版のファイル属性 (またはそれ以降のファイル属性) を、次の表に一覧表示します。これらのファイルの日付と時刻は世界協定時刻 (UTC) で表示されます。ファイル情報を表示する際に、ローカル時刻に変換されます。UTC とローカル時刻との時差を確認するには、コントロール パネルの日付と時刻ツールの [タイム ゾーン] タブを使用します。
   Date         Time    Version          Size      File name   ------------------------------------------------------------   23-Nov-2004  23:33   5.1.2600.2569    174,592   Rdbss.sys  
状況
マイクロソフトでは、この問題をこの資料の「対象製品」として記載されているマイクロソフト製品の問題として認識しています。
詳細
詳細については、以下の資料番号をクリックしてマイクロソフト サポート技術資料を参照してください。
824684 マイクロソフト ソフトウェア更新プログラムの説明で使用される一般的な用語の説明

警告: この記事は自動翻訳されています

プロパティ

文書番号:885936 - 最終更新日: 02/08/2014 20:08:00 - リビジョン: 7.0

Microsoft Windows XP Professional, Microsoft Windows XP Home Edition

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