現在オフラインです。再接続するためにインターネットの接続を待っています

Access 2003 または Access 2007 のデータベースで共通ダイアログ API を使用する方法

Office 2003 のサポートは終了しました

マイクロソフトでは、2014 年 4 月 8 日に Office 2003 のサポートを終了しました。この変更は、ソフトウェアの更新プログラムおよびセキュリティ オプションに影響しています。 この変更の意味および保護された状態を維持する方法について説明します。

はじめに
この資料では、Microsoft Office Access 2003 または Microsoft Office Access 2007 で共通ダイアログ API を、Microsoft Office 2000 Developer Edition または Microsoft Office XP Developer Edition のみに含まれている共通ダイアログ ボックス機能の代わりに使用する方法について説明します。
詳細
マイクロソフトは、この情報をプログラミング言語の使用方法の一例として提供するだけであり、市場性および特定目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。この資料は、例示されているプログラミング言語やプロシージャの作成およびデバッグに使用するツールについて理解されているユーザーを対象としています。Microsoft Support 担当者は、特定のプロシージャの機能についての問い合わせにはお答えできますが、ユーザー固有の目的に合わせた機能の追加、プロシージャの作成などの内容変更は行っておりません。

共通ダイアログ機能を置き換える手順

Microsoft Office Access 2003

  1. Access で、Northwind.mdb というファイル名のサンプル データベースを開きます。

    : Access 2003 の Northwind.mdb データベースは、通常、C:\Program Files\Microsoft Office\OFFICE11\Samples フォルダにあります。
  2. Northwind データベースの [オブジェクト] の下の [フォーム] をクリックします。
  3. [データベース] ウィンドウのツール バーで、[新規作成] をクリックします。
  4. [新しいフォーム] ダイアログ ボックスに表示される一覧で、[デザイン ビュー] をクリックし、[OK] をクリックします。
  5. [フォーム1] にテキスト ボックスを追加します。テキスト ボックスを右クリックし、[プロパティ] をクリックします。
  6. [すべて] タブをクリックし、[名前] をクリックして Text1 と入力します。次に、[テキスト ボックス] ダイアログ ボックスを閉じます。
  7. [Text1] ボックスに関連付けられているラベル コントロールを右クリックし、[プロパティ] をクリックします。次に、[すべて] タブをクリックします。
  8. [標題] をクリックし、Text1 と入力します。次に、[ラベル] ダイアログ ボックスを閉じます。
  9. [フォーム1] にコマンド ボタンを追加します。コマンド ボタンを右クリックし、[プロパティ] をクリックします。[名前] をクリックし、Command1 と入力します。[標題] をクリックし、Command1 と入力します。
  10. [イベント] タブをクリックし、[クリック時] ボックスの一覧で [イベント プロシージャ] をクリックします。次に、省略記号ボタン (...) をクリックして、Microsoft Visual Basic Editor を起動します。
  11. Command1_Click プロシージャのコードを、次のように変更します。
    Private Sub Command1_Click()    Me!Text1 = LaunchCD(Me)End Sub
  12. [挿入] メニューの [標準モジュール] をクリックし、次のコードを Module1 に挿入します。
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _"GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As LongPrivate Type OPENFILENAME    lStructSize As Long    hwndOwner As Long    hInstance As Long    lpstrFilter As String    lpstrCustomFilter As String    nMaxCustFilter As Long    nFilterIndex As Long    lpstrFile As String    nMaxFile As Long    lpstrFileTitle As String    nMaxFileTitle As Long    lpstrInitialDir As String    lpstrTitle As String    flags As Long    nFileOffset As Integer    nFileExtension As Integer    lpstrDefExt As String    lCustData As Long    lpfnHook As Long    lpTemplateName As StringEnd TypeFunction LaunchCD(strform As Form) As String    Dim OpenFile As OPENFILENAME    Dim lReturn As Long    Dim sFilter As String    OpenFile.lStructSize = Len(OpenFile)    OpenFile.hwndOwner = strform.hwnd    sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _      "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)    OpenFile.lpstrFilter = sFilter    OpenFile.nFilterIndex = 1    OpenFile.lpstrFile = String(257, 0)    OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1    OpenFile.lpstrFileTitle = OpenFile.lpstrFile    OpenFile.nMaxFileTitle = OpenFile.nMaxFile    OpenFile.lpstrInitialDir = "C:\"    OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"    OpenFile.flags = 0    lReturn = GetOpenFileName(OpenFile)        If lReturn = 0 Then            MsgBox "A file was not selected!", vbInformation, _               "Select a file using the Common Dialog DLL"         Else            LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1))          End IfEnd Function
  13. [デバッグ] メニューの [Northwind のコンパイル] をクリックし、次に、Visual Basic Editor を閉じます。
  14. [表示] メニューの [フォーム ビュー] をクリックします。
  15. [Command1] をクリックし、表示されるウィンドウで、開くファイルをクリックします。

    ファイルのパスが、[Text1] ボックスに表示されます。

Microsoft Office Access 2007

  1. Access 2007 で、ノースウィンド 2007.accdb という名前のサンプル データベースを開きます。
  2. [作成] タブの [フォーム] にある [フォーム] をクリックします。
  3. [書式設定] タブで [表示] の下の下矢印をクリックし、[デザイン ビュー] をクリックします。
  4. [フォーム1] にテキスト ボックスを追加します。テキスト ボックスを右クリックし、[プロパティ] をクリックします。
  5. [すべて] タブをクリックし、[名前] をクリックして Text1 と入力します。
  6. [Text1] ボックスに関連付けられているラベル コントロールを右クリックし、[プロパティ] をクリックします。次に、[すべて] タブをクリックします。
  7. [標題] をクリックし、Text1 と入力します。
  8. [フォーム1] にコマンド ボタンを追加します。コマンド ボタンを右クリックし、[プロパティ] をクリックします。[名前] をクリックし、Command1 と入力します。[標題] をクリックし、Command1 と入力します。
  9. [イベント] タブをクリックし、[クリック時] ボックスの一覧で [イベント プロシージャ] をクリックします。次に、省略記号ボタン (...) をクリックして、Microsoft Visual Basic Editor を起動します。
  10. 次のコード サンプルのように、Command1_Click プロシージャのコードを変更します。
    Private Sub Command1_Click()    Me!Text1 = LaunchCD(Me)End Sub
  11. [挿入] メニューの [標準モジュール] をクリックし、次のコード サンプルを使用環境に合わせて修正して Module1 に挿入します。
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _"GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As LongPrivate Type OPENFILENAME    lStructSize As Long    hwndOwner As Long    hInstance As Long    lpstrFilter As String    lpstrCustomFilter As String    nMaxCustFilter As Long    nFilterIndex As Long    lpstrFile As String    nMaxFile As Long    lpstrFileTitle As String    nMaxFileTitle As Long    lpstrInitialDir As String    lpstrTitle As String    flags As Long    nFileOffset As Integer    nFileExtension As Integer    lpstrDefExt As String    lCustData As Long    lpfnHook As Long    lpTemplateName As StringEnd TypeFunction LaunchCD(strform As Form) As String    Dim OpenFile As OPENFILENAME    Dim lReturn As Long    Dim sFilter As String    OpenFile.lStructSize = Len(OpenFile)    OpenFile.hwndOwner = strform.hwnd    sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _      "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)    OpenFile.lpstrFilter = sFilter    OpenFile.nFilterIndex = 1    OpenFile.lpstrFile = String(257, 0)    OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1    OpenFile.lpstrFileTitle = OpenFile.lpstrFile    OpenFile.nMaxFileTitle = OpenFile.nMaxFile    OpenFile.lpstrInitialDir = "C:\"    OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"    OpenFile.flags = 0    lReturn = GetOpenFileName(OpenFile)        If lReturn = 0 Then            MsgBox "A file was not selected!", vbInformation, _               "Select a file using the Common Dialog DLL"         Else            LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1))          End IfEnd Function
  12. [デバッグ] メニューの [ノースウィンド 2007 のコンパイル] をクリックしてから、Visual Basic Editor を閉じます。
  13. [書式設定] タブで [表示] の下の下矢印をクリックし、[フォーム ビュー] をクリックします。
  14. [Command1] をクリックし、表示されるウィンドウで、開くファイルをクリックします。

    ファイルのパスが、[Text1] ボックスに表示されます。
ACC2003 ACC2007
プロパティ

文書番号:888695 - 最終更新日: 05/23/2007 01:47:33 - リビジョン: 4.1

Microsoft Office Access 2007, Microsoft Office Access 2003

  • kbsampledatabase kbprogramming kbautomation kbexpertiseinter kbhowto KB888695
フィードバック
;did=1&t=">