現在オフラインです。再接続するためにインターネットの接続を待っています

Windows では、Windows XP Service Pack 2 を実行しているコンピューターの休止状態から再開した後、サウンドを再生しません。

重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。

英語版 KB:892559
現象
Windows を休止状態から再開すると Microsoft Windows XP Service Pack 2 (SP2) を実行しているコンピューターでは、サウンドは再生されません。

コンピューターを再起動すると、期待どおり Windows サウンドを再生します。
原因
この問題は、Portcls.sys ドライバーでの競合状態が存在するために発生します。このドライバーは、Windows オーディオ クラス ドライバーです。競合のシナリオは、次の条件に該当する場合に発生します。
  • Windows は休止状態から再開した後、Portcls.sys ドライバーは、 IRP_MJ_DEVICE_CONTROLのリクエストを受信します。
  • Portcls.sys ドライバーが PowerDeviceD0 をまだ返していない (D0) 電源の状態。

    高度な構成および電源インターフェイス (ACPI) 準拠のデバイスには 4 つの電源状態があります。D0 状態作業の電源の状態を表します。D1 D3 電源状態を介してスリープの電源状態を表しています。
このシナリオでは、Portcls.sys ドライバー制御 I/O 要求パケット (IRP) STATUS_PENDINGとしてマークされます。ただし、IRP が完了しません。IRP が完了するまで待つオーディオ スタック内上位のコンポーネント、その他のすべてのオーディオ要求をブロックします。そのため、Windows を休止状態から再開するとオーディオ ファイルは再生されません。
解決方法

修正プログラムの情報

サポートされている修正プログラムをマイクロソフトから入手することができます。ただし、この修正プログラムはこの資料に記載されている問題のみを修正するものです。この修正プログラムは、この特定の問題が発生しているシステムにのみ適用されます。この修正プログラムは、今後さらにテストがあります。したがって、この問題のために深刻な影響を受けていない場合は、この修正プログラムを含む次のソフトウェア更新プログラムのリリースを待つことをお勧めします。

修正プログラムがダウンロード可能な場合は、この記事の上部に「修正プログラムのダウンロード」セクションが表示されます。このセクションが表示されない場合は、マイクロソフト カスタマー サービス & サポートへお問い合わせいただき、修正プログラムを入手してください。

その他の問題が発生した場合、またはトラブルシューティングが必要な場合は、別のサービス リクエストを作成する必要があります。追加の質問およびこの特定の修正プログラムの対象とならない問題については、通常のサポート料金が適用されます。一覧マイクロソフト カスタマー サービス & サポートの電話番号のまたは別のサービス リクエストを作成するには、次のマイクロソフト Web サイトを参照してください。 「修正プログラムのダウンロード」フォームには、利用可能な言語の修正プログラムが表示されます。お使いの言語の修正プログラムが存在しない場合、表示されません。

この修正プログラムの英語版のファイル属性 (またはそれ以降のファイル属性) を、次の表に一覧表示します。日付と時刻これらのファイルを世界協定時刻 (UTC) が表示されます。ファイルの情報を表示すると、ローカル時刻に変換します。UTC とローカル時刻との時差を確認するを使用して、 タイム ゾーン タブ コントロール パネルの日付と時刻ツールでします。
   Date         Time   Version            Size    File name   --------------------------------------------------------------   22-Mar-2005  03:43  5.1.2600.2637     145,920  Portcls.sys   25-Feb-2005  03:53  6.1.22.4          371,936  Updspapi.dll 
状況
マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。
詳細
詳細については、「サポート技術情報」資料を参照するには、次の資料番号をクリックしてください。
824684マイクロソフトのソフトウェア更新プログラムの説明に使用される一般的な用語の説明

関連情報:

トラブルシューティング: なしオーディオ ウィンドウ

音楽やサウンドを Windows 7 ヘルプします。

警告: この記事は自動翻訳されています

プロパティ

文書番号:892559 - 最終更新日: 09/12/2012 06:55:00 - リビジョン: 6.0

  • kbautohotfix kbqfe kbhotfixserver kbmt KB892559 KbMtja
フィードバック
>html>