TAPI プログラムの実行は、Windows Server 2003 ベースのコンピューターに接続するリモート クライアント コンピューターに、カスタム WAVE ドライバーがアンロードされます。

Support for Windows Server 2003 ended on July 14, 2015

Microsoft ended support for Windows Server 2003 on July 14, 2015. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。

英語版 KB:928046
この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
重要です この資料では、レジストリを変更する方法について説明します。 変更する前にレジストリをバックアップすることを確認します。 問題が発生した場合はレジストリを復元する方法を知っているを確認します。 バックアップ、復元、およびレジストリを変更する方法の詳細についてはをクリックして以下「サポート技術情報」(Microsoft Knowledge Base) 資料を参照。
256986Description of the Microsoft Windows Registry JP256986 Microsoft Windows レジストリの説明
現象
テレフォニー API (TAPI) プログラムを実行している、Microsoft Windows Server 2003 ベースのコンピューターを次の現象発生する可能性があります。
  • カスタム WAVE ドライバーが、コンピューターからアンロードされ、リモート デスクトップ プロトコル (RDP) オーディオ ドライバーがコンピューターに読み込まれます。
  • すべての呼び出しのオーディオ ストリームは切断されます。 これには進行中のすべての呼び出しと接続されている呼び出しが含まれます。
  • WAVE ドライバーは、TAPI サービス プロバイダー (TSP) と通信できません。
原因
次の条件に該当する場合これらの現象に発生します。
  • TAPI プログラムを実行している、Windows Server 2003 ベースのコンピューターがあり、このプログラムは、テレフォニー構内交換 (機 PBX) スイッチとは通信。
  • PBX スイッチは、カスタム TSP とは、コンピューターにインストールされているカスタム ウェーブ ドライバーがあります。
  • 管理ユーザー権利を持つユーザー セッションに接続、コンソール コンピューターのリモート デスクトップ接続ツール (Mstsc.exe) を使用して、 コンソール/ スイッチと共にします。
  • 既定では、 このコンピューターに持っていく物 ] オプションのリモート デスクトップ セッションの リモート コンピューターのサウンド リストで選択が。
解決方法

Service Pack 情報

この問題を解決するには、Windows Server 2003 の最新の Service Pack を入手します。 関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください:
889100Windows Server 2003 の最新の Service Pack を入手する方法

修正プログラムについて

サポートされている修正プログラムが Microsoft から提供されています。 ただし、ことを目的としたこの修正プログラムものですこの資料に記載されている問題のみを修正します。 この修正プログラムのみシステムに適用この特定の問題が発生しています。 この修正プログラム テストを受ける可能性があります。 そのため場合この問題で深刻な影響を受けていないお勧めしますこの修正プログラムを含む、次回ソフトウェアの更新されるまで待つことです。

修正プログラムをダウンロードできる場合はこの資料の先頭に「修正プログラムのダウンロード」セクションです。 このセクションが表示されていない場合、は、マイクロソフト カスタマーサービス & サポート修正プログラムを入手するを問い合わせてください。

メモ 追加問題が発生する場合は、個別のサービス要求を作成した任意のトラブルシューティングが必要な場合。 通常のサポート料金が追加の質問およびこの特定の修正プログラムの対象とならない問題について適用されます。 一覧については、完了マイクロソフト カスタマーサービス & サポートの電話番号のまたは個別のサービス要求を作成する、次のマイクロソフト Web サイトを参照してください。 メモ 「修正プログラムのダウンロード」フォームには、修正プログラムが利用する言語が表示されます。 お使いの言語が表示されない場合、修正プログラムがその言語に対応しないのでは。

前提条件

コンピューターには Windows Server 2003 Service Pack 1 (SP1) この修正プログラムをインストールするが実行している必要があります。

再起動の要件

この修正プログラムの適用後、コンピュータを再起動する必要があります。 さらに、DontUnloadConsoleAudio レジストリ エントリを追加する必要があります。

修正プログラム置き換えに関する情報

修正この修正プログラムはプログラム置き換えられることもほかありません。

ファイル情報

この修正プログラムの英語版にファイルの属性 (またはそれ以降のファイル属性) 次の表は、されている可能性もします。 日付およびこれらのファイルの時間で世界協定時刻 (UTC) と記載します。 各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。 UTC と現地時刻の差を検索するには、コントロール パネルの [日付と時刻 タイム ゾーン タブを使用します。
Windows Server 2003、Itanium ベースのバージョン
ファイル名ファイルのバージョンファイルのサイズ日付時間プラットフォーム
Termsrv.dll5.2.3790.2832696,3202006 年 11 月 14 日01: 0764
Windows Server 2003 の x64 ベース バージョン x、
ファイル名ファイルのバージョンファイルのサイズ日付時間プラットフォーム
Termsrv.dll5.2.3790.2832363,5202006 年 11 月 14 日01: 05x64
Windows Server 2003 の x86 ベースのバージョン x、
ファイル名ファイルのバージョンファイルのサイズ日付時間プラットフォーム
Termsrv.dll5.2.3790.2832245,2482006 年 11 月 14 日14: 15x86

レジストリについて

警告 深刻な問題が変更した場合、レジストリが誤ってをレジストリ エディターを使用するかをもう 1 つの方法を使用が発生します。 これらの問題のオペレーティング システムの再インストールすることが必要に可能性があります。 Microsoft できません、これらの問題責任を負わないこととします。 ユーザー自身の責任においてレジストリを変更します。

修正プログラムをインストールしたしたら、DontUnloadConsoleAudio レジストリ エントリを作成する必要があります。 これを行うには、次の手順を実行します。
  1. 開始 ] をクリックして 実行 ] をクリックして、 regedit と入力して [OK] をクリックします。
  2. 検索し、次のレジストリ サブキーを右クリックします。
    HKEY_Local_Machine\System\CurrentControlSet\Control\Terminal サーバー
  3. 新規作成 ] をポイントして [ DWORD 値 ] をクリックします。
  4. DontUnloadConsoleAudio を入力して Enter を押します。
  5. DontUnloadConsoleAudio ] を右クリックし、 変更 を実行します。
  6. DWORD 値の編集 ] ダイアログ [ 10 進 ] をクリックし、 値のデータ ] 1 を入力して [ OK] をクリックします。
  7. レジストリ エディターを終了します。
回避策
この問題を回避する、するには、リモート コンピューターにのみサウンド ファイルを再生するクライアント コンピューターを構成します。 これを行うには、次の手順を実行します。
  1. [スタート ] をクリックして のプログラム ] または [ すべてのプログラム [アクセサリ] をポイントし、 通信 ] をポイント]、[ リモート デスクトップ接続 ] をクリックします。
  2. ローカル リソース ] タブ でリモート コンピューターからの脱退 には、 リモート コンピューターのサウンド の一覧から [ 接続 ] をクリックします。

    メモ [ 接続 ] をクリックすると、この設定がすべてのリモート デスクトップ接続の既定の設定とが Default.rdp ファイルに保存されます。
状況
マイクロソフトとして認識していますこの問題を記載されているいるマイクロソフト製品の問題。 この問題は、まず Windows Server 2003 Service Pack 2 で修正されました。
詳細
マイクロソフトのソフトウェアの更新に使用される標準的な用語の説明の詳細についてをクリックして次資料「サポート技術情報」(Microsoft Knowledge Base) 資料を参照。
824684マイクロソフトのソフトウェアの更新で使用される一般的な用語の説明

プロパティ

文書番号:928046 - 最終更新日: 12/09/2015 08:12:39 - リビジョン: 2.5

Microsoft Windows Server 2003, Web Edition, Microsoft Windows Server 2003, Standard Edition (32-bit x86), Microsoft Windows Server 2003, Enterprise Edition (32-bit x86), Microsoft Windows Server 2003, Enterprise x64 Edition

  • kbnosurvey kbarchive kbbug kbfix kbqfe kbpubtypekc kbhotfixserver kbwinserv2003sp2fix kbautohotfix kbmt KB928046 KbMtja
フィードバック