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Windows Vista または Windows 7 ベースの新しいクライアント コンピューターをネットワークに追加しても、KMS の現在の数が増加しない

現象
キー マネージメント サーバー (KMS) コンピューターで Slmgr.vbs スクリプトを実行すると、Windows ベースの新しいクライアント コンピューターをネットワークに追加しても、クライアント コンピューター数が増加していないことがわかります。また、キー管理サービスのイベント ログでも、新しくネットワークに追加された Windows ベースの各クライアント コンピューターに関して以下のイベントが表示される場合があります。


ログの名前: キー管理サービス
ソース: Microsoft-Windows-Security-Licensing-SLC
イベント ID: 12290
レベル: 情報
説明: ライセンス認証要求が処理されました。

-dli 引数を使用して Slmgr.vbs スクリプトを実行しても、クライアント コンピューター数の情報は期待どおりに増加しません。キー管理サービスのイベント ログに記録された以下のイベントでは、現在の数は同じままです。


名前: Windows(TM) Vista, Enterprise edition
説明: Windows Operating System - Vista, VOLUME_KMS channel
プロダクト キーの一部: XXXXX
ライセンスの状態: ライセンス済み

キー管理サービスはこのコンピューターで有効です
現在の数: 1
リッスン先のポート: 1688
DNS 発行: 有効
KMS プライオリティ: 通常

原因
この問題は、ネットワークに追加した Windows ベースのクライアント コンピューターに重複する KMS クライアント コンピューター ID (CMID) が割り当てられている場合に発生します。クライアント コンピューターの CMID が異なる場合は、KMS コンピューター上の現在の数の値は増加します。以下のいずれかの状況では、2 台以上のコンピューターに同じ CMID が割り当てられる可能性があります。
  • システム準備ツール (Sysprep.exe) の実行時に /generalize オプションが指定されていないにもかかわらず、クライアント コンピューターのインストールに使用されるカスタム Windows イメージが生成されている。
  • カスタム Windows イメージは /generalize オプションを使用して生成されているが、Unattended.xml ファイルで <SkipRearm> 設定を指定している。
クライアント コンピューターの CMID が重複していることを確認するには、次の手順を実行します。
  1. 1 台の Windows ベースのクライアント コンピューターで、[スタート] ボタンをクリックし、[すべてのプログラム]、[アクセサリ] の順にクリックします。[コマンド プロンプト] を右クリックし、[管理者として実行] をクリックします。

    ユーザー アカウント制御の許可管理者のパスワードを要求するダイアログ ボックスが表示された場合はパスワードを入力するか、[許可] クリックします。
  2. コマンド プロンプトで以下のコマンドを入力し、Enter キーを押します。
    cscript c:\windows\system32\slmgr.vbs –dli
  3. 以下の結果を確認して、CMID をメモします。

    名前: Windows(TM) Vista, Enterprise edition
    説明: Windows Operating System - Vista, VOLUME_KMSCLIENT channel
    プロダクト キーの一部: XXXXX
    ライセンスの状態: ライセンス済み
    ボリューム ライセンス認証の有効期限: 250467 分 (173 日)

    キー管理サービス クライアント情報
    クライアント コンピューター ID (CMID): e5a0da51-8882-4bd7-a248-c1b794a7a671
    DNS の KMS コンピューター名: kms-machine.domain.com:1688
    ライセンス認証の間隔: 120 分
    更新間隔: 90 分

  4. 2 台目の Windows ベースのクライアント コンピューターについても、手順 1. ~ 4. を実行します。2 台目のクライアント コンピューターの CMID が、1 台目のコンピューターの CMID と重複していることを確認します。
解決方法
クライアント コンピューターの CMID が重複していることを確認したら、当該のコンピューターの展開に使用したベース イメージをすぐに再構築することをお勧めします。
回避策
回避策は、Windows ベース クライアントのインストールに使用されたイメージで /generalize オプションが指定されていた場合にのみ有効です。このオプションは、複数のイメージを展開する場合に必要です。そのイメージで /generalize オプションが使用されていたかどうかを確認するには、次の手順を実行します。
  1. 対象のコンピューターのうちの 1 台で、[スタート] ボタンをクリックし、「C:\Windows\System32\sysprep\Panther\setupact.log」と入力します。
  2. ログ ファイルで "SYSPRP ParseCommands:Found" という行を確認します。以下に、ログ ファイルのサンプルを示します。
    Info       [0x0f004e] SYSPRP Initialized SysPrep log at C:\Windows\System32\sysprep\PantherInfo       [0x0f0054] SYSPRP ValidateUser:User has required privileges to sysprep machine Info       [0x0f0056] SYSPRP ValidateVersion:OS version is okay Info       [0x0f005c] SYSPRP ScreenSaver:Successfully disabled screen saver for sysprep Info       [0x0f007e] SYSPRP FCreateTagFile:Tag file C:\Windows\System32\sysprep\Sysprep_succeeded.tag does not already exist, no need to delete anything Info       [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'UNATTEND' Info       [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'OOBE' Info       [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'SHUTDOWN' Info       [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'GENERALIZE'
  3. /generalize オプションが表示されている場合は、ベース イメージを作成したコンピューターでこのオプションが使用されています。
  4. /generalize オプションが使用されていて、コンピューターの CMID が重複している場合は、次の手順を実行して、該当するコンピューターで rearm オプションを指定してベース イメージを再構築します。<SkipRearm> 設定は使用しないようにしてください。
    1. 1 台の Windows ベースのクライアント コンピューターで、[スタート] ボタンをクリックし、[すべてのプログラム]、[アクセサリ] の順にクリックします。[コマンド プロンプト] を右クリックし、[管理者として実行] をクリックします。

      ユーザー アカウント制御の許可管理者のパスワードを要求するダイアログ ボックスが表示された場合はパスワードを入力するか、[許可] をクリックします。
    2. コマンド プロンプトで以下のコマンドを入力し、Enter キーを押します。
      cscript c:\windows\system32\slmgr.vbs –rearm
    3. コンピューターを再起動します。
    ベース イメージの生成時に /generalize オプションを指定せずに Sysprep を使用していた場合は、ベース イメージを再構築してから、Windows をクライアントに再インストールする必要があります。ベース イメージを再構築する際に Unattended.xml ファイルを使用する場合は、<SkipRearm> 設定は使用しないようにしてください。<SkipRearm> 設定の詳細については、Windows 自動インストール キット (AIK) のドキュメントを参照してください。
詳細
ライセンス認証のタイマーをリセットし、一意の CMID を設定するには、対象のコンピューターで Rearm プロセスを実行する必要があります。このプロセスは、ライセンス認証の状態をリセットするために使用されます。Windows では、以下の 2 つのいずれかの方法を使用して Rearm プロセスを実行できます。
  • カスタムの Windows イメージの構築に使用するコンピューターで、/generalize オプションを指定して Sysprep を実行します。
  • 管理者として実行しているコマンド プロンプト ウィンドウから、Slmgr.vbs スクリプトを実行して、Rearm プロセスを強制的に起動します。入力の例を以下に示します。
    cscript c:\windows\system32\slmgr.vbs –rearm
Sysprep が /generalize オプションを指定して実行されたか、Unattended.xml ファイルで <SkipRearm>1</SkipRearm> 設定が使用されていたことが原因で、Rearm プロセスが実行されなかった場合は、クライアント コンピューターの CMID が重複する可能性があります。その場合、コンピューター数の増加情報は予期したとおりに表示されません。/generalize オプションは、複数のイメージを展開する場合に必要になります。また、運用環境でコンピューターを展開するときには Unattended ファイルで <SkipRearm> 設定を使用することはできません。そのため、これらの場合には、ベース イメージを再構築することをお勧めします。
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プロパティ

文書番号:929829 - 最終更新日: 01/31/2012 11:56:00 - リビジョン: 3.0

Windows Vista Enterprise, Windows Vista Business, Windows 7 Enterprise, Windows 7 Professional

  • kbtshoot kbprb KB929829
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