The Microsoft Dynamics CRM menu still exists on the Outlook menu bar after you uninstall the Microsoft Dynamics CRM 3.0 client for Outlook

この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
現象
Symptom 1

After you uninstall the Microsoft Dynamics CRM 3.0 client for Microsoft Office Outlook, the Microsoft Dynamics CRM 3.0 menu still exists on the Outlook menu bar.

Or, after you uninstall the Microsoft Dynamics CRM 3.0 client for Outlook, and you try to install the Microsoft Dynamics CRM 4.0 client for Outlook, the Microsoft Dynamics CRM 4.0 client installation tries to perform an upgrade.

Symptom 2

When you open the Microsoft Dynamics CRM 4.0 client for Outlook, you receive the following error message:
An error occurred loading Microsoft Dynamics CRM functionality. Try restarting Microsoft Outlook. Contact your system administrator if error persists.
If you click OK in the error message, the CRM toolbar is listed two times in the Outlook menu bar.
原因
This problem occurs because the Microsoft Dynamics CRM 3.0 client is not completely uninstalled.
解決方法
Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve this problem, follow these steps:
  1. Close Outlook. In Task Manager, verify that the Outlook.exe process and the Microsoft.crm.application.hoster.exe process are not running.
  2. In Add or Remove Programs, uninstall the Microsoft Dynamics CRM 4.0 client for Outlook, or uninstall the Microsoft Dynamics CRM 3.0 client for Outlook.
  3. If the following directories exist on the client computer, delete the directories:
    • drive:\Program Files\Microsoft Dynamics CRM directory
    • drive: \Program Files\Microsoft CRM
  4. Click Start, click Run, type regedit, and then click OK.
  5. Open the following registry key:
    HKEY_Current_User\SOFTWARE\Microsoft
  6. Delete the MSCRMClient hive if it exists.
  7. In Control Panel, double-click Mail, and then click E-mail Accounts.
  8. Click the Address Books tab, select the Microsoft Dynamics CRM address book, and then click Remove.
  9. Click the Data Files tab, select the Microsoft Dynamics CRM data file if it exists, and then click Remove.
  10. Click Start, click Run, type regedit, and then click OK.
  11. Open the following registry key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates
  12. Delete the Microsoft Dynamics CRM 3.0 registry hive if it exists.
  13. Rename the Outcmd.dat file to Outcmd.dat.old.

    Note By default, the Outcmd.dat file is in the following folder:
    C:\Document and Settings\User\Application Data\Microsoft\Outlook
    Note Outlook re-creates the Outcmd.dat file. However, all the custom menus that you created on the Outlook menu bar are removed.
  14. Verify the Microsoft Dynamics CRM Outlook addin is removed. To do this, follow these steps:

    For Outlook 2003
    1. Open Outlook, click Tools, click Options, click the Other tab, click Advanced, and then click COM Addins.
    2. Select Microsoft Dynamics CRM, click Remove, then click OK.
    3. Click Tools, and then click Customize.
    4. Select Microsoft Dynamics CRM, and then click Delete.
    5. Click Reset, and then click Close.
    6. Close Outlook.
    7. Click Start, click All Programs, click Microsoft Dynamics CRM 4.0, and then click Diagnostics.
    8. Click Run Diagnostics.
    9. Open Outlook.
    For Outlook 2007
    1. Open Outlook, click Tools, click Trust Centre, click Add-ins, and then click Go.
    2. Select Microsoft Dynamics CRM, click Remove, and then click OK.
    3. Click Tools, and then click Customize.
    4. Select Microsoft Dynamics CRM, and then click Delete.
    5. Click Reset, and then click Close.
    6. Close Outlook.
    7. Click Start, click All Programs, click Microsoft Dynamics CRM 4.0, and then click Diagnostics.
    8. Open Outlook.
関連情報
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
948312 Error message when you try to install, upgrade or configure a Microsoft Dynamics CRM client for Outlook computer
注意 : これは、マイクロソフトのサポート組織内で直接作成された "緊急公開" の資料です。 この資料には、確認中の問題に関する現状ベースの情報が記載されています。 情報提供のスピードを優先するため、資料には誤植が含まれる可能性があり、予告なしに随時改定される場合があります。 その他の考慮事項については、使用条件を参照してください。
プロパティ

文書番号:949087 - 最終更新日: 01/16/2015 02:21:34 - リビジョン: 1.0

  • Microsoft Dynamics CRM 4.0
  • Microsoft CRM client for Microsoft Office Outlook
  • kbnosurvey kbarchive kbexpertisebeginner kbtshoot kbmbsmigrate kbprb kbexpertiseinter KB949087
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