現在オフラインです。再接続するためにインターネットの接続を待っています

Active Directory 内のユーザー名を変更すると、Windows Vista または Windows XP を実行しているコンピューターで、フォルダー リダイレクト プロセスの失敗します。

重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。

英語版 KB:953529
現象
管理者は、Active Directory ディレクトリ サービス内のユーザーのユーザー名を変更します。これを行うと、そのユーザーのフォルダー リダイレクト プロセス Windows Vista または Windows XP を実行しているコンピューター上で失敗します。

ただし、フォルダー リダイレクト プロセスはユーザーは、名前の変更する前にログオンしていないコンピューター上で動作します。

メモ フォルダー リダイレクトは、ユーザーが初めてコンピューターにログオンするときに実装されています。

次の条件に該当する場合この問題が発生します。
  • フォルダー リダイレクトのパスにユーザー名が含まれています。たとえば、次のようなリダイレクトされたフォルダーのパスを使用します。
    \\サーバー名\共有名\%ユーザー名%\
  • 名前の変更後、最初をユーザーは、名前の変更前にログオンする Windows XP と Windows Vista を実行しているコンピューターにログオンします。
さらに、次のイベントがアプリケーション ログに記録されます。

イベント ID: 107
ユーザー: ドメイン\New_user_name
説明:[マイ ドキュメント] フォルダーのリダイレクト操作に失敗しました。リダイレクトされるフォルダーを構成します。 \\Server_Name\Share_Name\User_Name\My_Documents するには \\Server_Name\Share_Name\New_User_Name\My_Documents.次のエラーが発生しました。ファイルが既に存在する場合は、ファイルを作成できません。

原因
この問題をユーザー前にログオンしていないコンピューターで、新しいユーザー名を使用して、最初に、ユーザー ログオンすると、新しいフォルダーが作成されるために発生します。

したがって、ユーザーの彼または彼女以前に名前の変更する前にログオンするコンピューターにログオンすると、ユーザー プロファイル用の既存のフォルダーは、新しいユーザー名を変更できません。このような状況で失敗するのには、フォルダー リダイレクト プロセスが発生します。
解決方法
この問題を解決するのには、影響を受けるユーザーのプロファイルをユーザー名の変更する前にログオンする、コンピューターを削除してください。これを行うには、次の方法のいずれかを使用します。

重要です ユーザー プロファイルには、ユーザー固有の設定、データ、およびデジタル証明書が含まれます。それを削除する前に、ユーザー プロファイルのバックアップ コピーを作成することをお勧めします。ユーザー証明書をエクスポートする方法の詳細については、次のマイクロソフト Web サイトを参照してください。

方法 1: プロファイルを手動で削除します。

Windows Vista

  1. 管理者としてコンピューターにログオンします。
  2. クリックしてください。 開始 [スタート] ボタン を右クリックして コンピューター、し プロパティ.

     ユーザー アカウント制御の許可 管理者のパスワードまたは確認を求められたら、パスワードを入力またはをクリックしてください 続行.
  3. ナビゲーション ウィンドウをクリックします。 [システムの詳細設定.
  4. 下にあります。 ユーザー プロファイルをクリックして 設定.
  5. 対象となるユーザーをクリックし、 削除、し [はい].
  6. クリックしてください。 [OK] ダイアログ ボックスを閉じますを 2 回します。

Windows XP

  1. 管理者としてコンピューターにログオンします。
  2. クリックしてください。 開始を右クリックして マイ コンピューター、し プロパティ.
  3. で、 高度な タブで、クリックしてください 設定 下にあります。 ユーザー プロファイル.
  4. 対象となるユーザーをクリックし、 削除、し [はい].
  5. クリックしてください。 [OK] ダイアログ ボックスを閉じますを 2 回します。

方法 2: は、Delprof.exe ユーティリティを使用して、プロファイルを削除する.

ローカルまたはリモートでのプロファイルを削除するのには、Delprof.exe ユーティリティを使用できます。

これを行う方法の詳細については、Knowledge Base の資料を参照するのには、次の資料番号をクリックしてください。
315411Windows 2000 では、ユーザー プロファイルの削除のユーティリティ (Delprof.exe) を使用してユーザー プロファイルを削除する方法

警告: この記事は自動翻訳されています

プロパティ

文書番号:953529 - 最終更新日: 08/11/2011 10:39:00 - リビジョン: 3.0

  • kbtshoot kblogin kbprb kbexpertiseadvanced kbuserprofile kbmt KB953529 KbMtja
フィードバック