Windows 7 ベースのコンピューターでバックアップおよび復元ウィザードを使用してファイルをバックアップしようとすると、エラー コード 0x81000031が発生します

この記事では、Windows 7 のバックアップおよび復元ウィザードを使用してファイルを外部ハード ディスク ドライブにバックアップするときに発生する問題について説明します。

適用対象: Windows 7 Service Pack 1
元の KB 番号: 975692

現象

以下のシナリオについて検討します。

シナリオ 1: カスタム ライブラリが使用できない

  • Windows 7 を実行しているコンピューターがあります。
  • リムーバブル ドライブまたはネットワーク ドライブ上にあるカスタム ライブラリを追加します。
  • 1 つ以上のカスタム ライブラリが使用できない場合は、バックアップを実行しようとします。

このシナリオでは、Windows バックアップおよび復元ウィザードを使用してファイルをバックアップしようとすると、次のようなエラー メッセージが表示されます。

エラー コード: 0x81000031

シナリオ 2: BitLocker ドライブ暗号化が有効になっている

  • Windows 7 を実行しているコンピューターがあります。
  • 外付けハード ディスク ドライブをコンピューターに接続します。
  • システム ドライブで Windows BitLocker ドライブ暗号化を有効にします。

このシナリオでは、Windows バックアップおよび復元ウィザードを使用してファイルを外部ドライブにバックアップしようとすると、次のようなエラー メッセージが表示されます。

重要な BitLocker システム ファイルが見つからないか破損しているため、BitLocker ドライブ暗号化を使用できません。

エラー コード: 0x81000031

原因

シナリオ 1: カスタム ライブラリが使用できない

この問題は、Windows バックアップ ウィザードを使用してバックアップを実行するときにアクセスできないカスタム ライブラリを追加した場合に発生する可能性があります。 これらのライブラリが使用できないネットワーク ドライブ上にある場合、またはそれらのライブラリがリムーバブル メディア上にある場合、カスタム ライブラリは使用できなくなります。

シナリオ 2: BitLocker ドライブ暗号化が有効になっている

この問題は、BitLocker ウィザードによって Windows Recovery Environment (Windows RE) がシステム ドライブから外部ハード ディスク ドライブに移動されるために発生します。 これにより、外部ハード ディスクにバックアップを作成できなくなります。

回避策

この問題を回避するには、シナリオに適した手順に従います。

シナリオ 1: カスタム ライブラリが使用できない

ライブラリを既定のライブラリ (ドキュメント、音楽、画像、ビデオ) にリセットするには、次の手順に従います。

  1. [スタート] をクリックし、[ コンピューター] をクリックします。

  2. エクスプローラー ウィンドウの左側にあるナビゲーション ウィンドウで [ライブラリ] を右クリックし、[既定のライブラリの復元] をクリックします。

    注:

    この操作により、ライブラリの場所にあるカスタム ライブラリが削除されます。 ライブラリの場所が再び使用可能になったときに、これらのライブラリを復元できます。

  3. バックアップと復元ウィザードを起動して、ファイルとデータをバックアップします。

シナリオ 2: BitLocker ドライブ暗号化が有効になっている

BitLocker ドライブ暗号化を無効にして再度有効にするには、次の手順に従います。

  1. 外付けハード ディスク ドライブをコンピューターに接続します。 外付けハード ディスク ドライブの電源がオンになっていることを確認します。

  2. Windows 7 システム修復ディスクを作成します。これを行うには、次の手順に従います。

    1. [ スタート] をクリックし、[ 検索の開始 ] ボックスに「システム 修復ディスクの作成」と入力します。
    2. [ プログラム ] の一覧で、[ システム修復ディスクの作成] をクリックします。
    3. 画面の指示に従ってディスクを作成します。

    注:

    システム修復ディスクを作成するには、CD または DVD バーナーが必要です。

  3. 管理者特権のコマンド プロンプトを開始します。 これを行うには、次の手順を実行します。

    1. [ スタート] をクリックし、[ 検索の開始 ] ボックスに「コマンド プロンプト」と入力します。
    2. [ プログラム ] の一覧で、[ コマンド プロンプト] を右クリックし、[ 管理者として実行] をクリックします。
  4. 管理者特権のコマンド プロンプトで、次のコマンドを入力し、Enter キーを押します。

    C:\Windows\System32\REAgentC.exe /disable
    
  5. 外付けハード ディスク ドライブを取り外します。

  6. 管理者特権のコマンド プロンプトで、次のコマンドを入力し、Enter キーを押します。

    C:\Windows\System32\REAgentC.exe /enable
    

    注:

    この操作は失敗する可能性があります。 この場合は、回復ツールにアクセスする必要がある場合は、手順 2 で作成した Windows 7 システム修復ディスクを使用します。

  7. 外付けハード ディスク ドライブをコンピューターに再接続します。

  8. バックアップと復元ウィザードを起動して、ファイルとデータを外部ハード ディスク ドライブにバックアップします。

詳細

システム修復ディスクを作成して使用する方法の詳細については、次の Microsoft Web サイトを参照してください。

システム修復ディスクを作成する

状態

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。