現在オフラインです。再接続するためにインターネットの接続を待っています

[MS10-022] Visual Basic Scripting (VBScript) 5.6 セキュリティ更新プログラム (2010 年 4 月 13 日) について

Windows XP のサポートは終了しました

マイクロソフトでは、2014 年 4 月 8 日に Windows XP のサポートを終了しました。この変更は、ソフトウェアの更新プログラムおよびセキュリティ オプションに影響しています。 この変更の意味および保護された状態を維持する方法について説明します。

Windows Server 2003 のサポートは 2015 年 7 月 14 日で終了しています

Windows Server 2003 のサポートは 2015 年 7 月 14 日で終了しています。この変更は、ソフトウェアの更新プログラムおよびセキュリティ オプションに影響しています。 この変更の意味および保護された状態を維持する方法について説明します。

はじめに
マイクロソフトはセキュリティ情報 MS10-022 を公開しました。セキュリティ情報の詳細を参照するには、次のいずれかのマイクロソフト Web サイトにアクセスしてください。

このセキュリティ更新プログラムに関するヘルプとサポートを受ける方法:

ホーム ユーザーの場合、無料サポートが提供されています。米国およびカナダのユーザーは電話で 1-866-PCSAFETY にお問い合わせください。セキュリティ更新プログラムのサポートに関する各地域の支社の問い合わせ先については、マイクロソフトの世界のサポート Web サイトを参照してください。 北米のお客様は、次のマイクロソフト Web サイトにアクセスして、無制限の無料電子メール サポートまたは無制限の個別チャット サポートを受けることもできます。 企業ユーザーの場合、セキュリティ更新プログラムに対するサポートは、通常のサポート窓口を通じて提供されます。
詳細

このセキュリティ更新プログラムの関連情報

既知の問題

以下の条件がすべて該当する限定された範囲のコンピューターに影響する問題が判明しています。
  • Windows XP Service Pack 3 がインストールされている。
  • 古いバージョンの Windows Script Host 5.6 が手動でインストールされていた。
: 既定では、Windows XP Service Pack 3 により Windows Script Host 5.7 がインストールされます。この問題は、ユーザーが行う必要がないにもかかわらず、古いバージョンの Windows Script Host が手動でインストールされていたコンピューターに限定されます。

この既知の問題の影響を受けるコンピューター上では、想定されていないバージョンの Vbscript.dll が存在するため、このセキュリティ更新プログラムはインストールできません。Windows XP Service Pack 3 でこのセキュリティ更新プログラムをインストールするには、Vbscript.dll ファイルのバージョンは少なくとも 5.7 である必要があります。

Windows XP Service Pack 3 を実行していて、Vbscript.dll ファイルのバージョンが Version 5.6 であるコンピューター上でこの既知の問題を解決するには、コンピューターにインストールされている Windows Internet Explorer のバージョンに応じて、次のいずれかの方法を使用します。

Internet Explorer 6 の場合
  1. Vbscript.dll を想定されるファイル バージョンに復元します。

    Vbscript.dll を Version 5.7 に復元するには、以下のいずれかの操作を実行します。
    • Windows XP 用のスクリプト エンジンの更新プログラム (KB951978) をダウンロードしてインストールします。
      951978 Windows Vista Service Pack 1、Windows Server 2008、または Windows XP Service Pack 3 で VBScript または JScript スクリプトを実行すると、スクリプト出力が正しく表示されない
      : 自動更新を有効にしている場合、この更新プログラムは自動的に提供されます。
    • Internet Explorer 8 へアップグレードします。Internet Explorer 8 の入手方法の詳細については、次のマイクロソフト Web サイトを参照してください。: 自動更新を有効にしている場合、この更新プログラムは自動的に提供されます。
    • Internet Explorer 7 へアップグレードします。Internet Explorer 7 の入手方法の詳細については、次のマイクロソフト Web サイトを参照してください。
  2. セキュリティ更新プログラムをインストールします。

    この資料に記載されている想定されたバージョンに Vbscript.dll を正しく復元した後、セキュリティ情報 MS10-022 に記載されている Windows XP Service Pack 3 用の VBScript 5.7 セキュリティ更新プログラム (KB981349) をインストールします。

    : Vbscript.dll のバージョンが 5.7.0.0 以上である場合、このセキュリティ更新プログラムは自動更新を通じて提供されます。
Internet Explorer 7 の場合
  1. Vbscript.dll を想定されるファイル バージョンに復元します。

    Vbscript.dll を Version 5.7 に復元するには、以下のいずれかの操作を実行します。
    • Windows XP 用のスクリプト エンジンの更新プログラム (KB951978) をダウンロードしてインストールします。
      951978 Windows Vista Service Pack 1、Windows Server 2008、または Windows XP Service Pack 3 で VBScript または JScript スクリプトを実行すると、スクリプト出力が正しく表示されない
      : 自動更新を有効にしている場合、この更新プログラムは自動的に提供されます。
    • Internet Explorer 8 へアップグレードします。Internet Explorer 8 の入手方法の詳細については、次のマイクロソフト Web サイトを参照してください。: 自動更新を有効にしている場合、この更新プログラムは自動的に提供されます。
    • Internet Explorer 7 をアンインストールしてから Internet Explorer 7 を再インストールします。
  2. セキュリティ更新プログラムをインストールします。

    この資料に記載されている想定されたバージョンに Vbscript.dll を正しく復元した後、セキュリティ情報 MS10-022 に記載されている Windows XP Service Pack 3 用の VBScript 5.7 セキュリティ更新プログラム (KB981349) をインストールします。

    : 自動更新を有効にしている場合、この更新プログラムは自動的に提供されます。
Internet Explorer 8 の場合

Internet Explorer 8 をインストールしていて、自動更新を有効にしている場合、正しい更新プログラムが自動的に提供されるため、他に作業を行う必要はありません。このセキュリティ更新プログラムを手動でインストールする必要がある場合は、セキュリティ情報 MS10-022 に記載されている Windows XP Service Pack 3 用の VBScript 5.8 セキュリティ更新プログラム (KB981349) をダウンロードしてインストールします。

このセキュリティ更新プログラムを適用するための必要条件

このセキュリティ更新プログラムをインストールするには、コンピューター上に Microsoft Visual Basic Scripting Edition (VBScript) 5.6 がインストールされている必要があります。

VBScript 5.6 は、以下の製品によりインストールされます。
  • Microsoft Internet Explorer 6
  • Windows Server 2003 (含まれるバージョンは x86 ベース SP2、x64 ベース SP2、および Itanium ベース SP2)
  • Windows XP (含まれるバージョンは x86 ベース SP2 および x64 ベース SP2)
  • Windows Script Host 5.6
コンピューターにインストールされている VBScript のバージョンを調べるには、以下の手順を実行します。
  1. Windows エクスプローラーを起動します。
  2. 次のディレクトリに移動します。
    %systemroot%\system32
  3. Vbscript.dll ファイルを右クリックし、 [プロパティ] をクリックします。
  4. [詳細] タブをクリックし、 "ファイル バージョン" フィールドを表示します。
ファイル バージョンが 5.6 から始まる場合 (たとえば 5.6.0.8825)、VBScript 5.6 がコンピューターにインストールされています。

アンインストール情報

このセキュリティ更新プログラムを削除するには、次のいずれかの操作を実行します。
  • コントロール パネルの [プログラムの追加と削除] を使用します。
  • 以下のフォルダーにある Spuninst.exe ユーティリティを使用します。
    %Windir%\$NTUninstallKB981350$\Spuninst

再起動に関する情報

このセキュリティ更新プログラムの適用後、コンピューターの再起動が必要になる場合があります。
ファイル情報
セキュリティ更新プログラム (日本語版) のファイル属性は、セキュリティ情報 MS10-022 の「ファイル情報」セクションをご覧ください。
update security_patch security_update security bug flaw vulnerability malicious attacker exploit registry unauthenticated buffer overrun overflow specially-formed scope specially-crafted denial of service dos
プロパティ

文書番号:981350 - 最終更新日: 04/15/2010 08:24:16 - リビジョン: 1.1

  • Microsoft Internet Explorer 6.0
  • Microsoft Windows Server 2003 Service Pack 2
  • Microsoft Windows XP Service Pack 2
  • Microsoft Windows 2000 Service Pack 4
  • kbsurveynew kbfix kbbug kbsecvulnerability kbsecbulletin kbsecurity kbqfe kbexpertiseinter KB981350
フィードバック