カタログ データの差し込みを作成する

Publisher では、データベース、スプレッドシート、テキスト ファイルなどのデータ ソースに接続し、データを使用して製品やサービスのカタログを簡単に作成できます。 カタログ の結合を使用して、ディレクトリ、フォト アルバム、または各ページに 1 つ以上のアイテムを表示するその他の種類の文書を作成することもできます。

カタログ の差し込みのしくみ

カタログ の差し込み印刷は、差し込み印刷に似ています。 カタログ データの差し込み印刷を使用する場合は、カタログ データの差し込み印刷テンプレート文書を作成し、そのテンプレートをデータ ソースの情報と組み合わせて、差し込み印刷ページを生成します。

データ ソースと差し込みテンプレートが組み合わされ、カタログ ページが生成される

1 項目の名前や説明などのレコード情報を含むデータ ソース。

2 カタログ データの差し込み印刷テンプレート文書と、レコード情報のプレースホルダーである差し込みフィールド。

3 ページごとに複数のレコードを表示する結果のマージされたページ。

カタログ データの差し込み印刷を新しい文書として保存するか、既存の文書の末尾に追加することができます。 また、データ ソースの情報を更新するたびに、カタログ データ の差し込みテンプレートを保存して、再び使用して、差し込み印刷ページの追加セットを作成することもできます。

準備

次のヒントは、カタログ データの差し込み印刷を成功にするのに役立ちます。

  • 新しい文書でカタログ データの差し込み印刷を開始します。

  • 表紙、目次、注文フォームなどのページに加えて、差し込み印刷フィールドに 1 ページを入力します。差し込み印刷文書を作成すると、カタログを通じて複数のページが作成される可能性があります。

  • 最終的な差し込み印刷ページに必要なページのサイズを使用して、カタログ データの差し込みテンプレートを設定します。

  • 作成した差し込み印刷ページを既存の文書の末尾に追加する場合は、カタログ カタログの差し込み印刷テンプレートが既存の文書と次の方法で一致する必要があります。

    • ページ サイズ (高さと幅)

    • ページ ビュー (1 ページまたは見開き 2 ページ)

    • 文書の種類 (Web または印刷)

    • ページの順序 (左から右、または右から左)

ページの先頭へ

カタログを計画する

カタログ の差し込み印刷を開始する前に、最終的な差し込み印刷ページに一覧表示する情報の種類を考え出します。

  • アイテムの名前と価格を一覧表示しますか?

  • 各アイテムの説明を含める必要がありますか?

  • 各アイテムの画像を含める必要がありますか?

データ ソースを計画する

カタログに含める情報の種類を決めたら、カタログ の差し込み印刷に使用するデータ ソースを作成できます。 既にデータ ソースがある場合は、差し込み印刷に含めるすべての情報が含まれているか確認できます。

Publisher のカタログ 差し込み印刷では、さまざまなデータ ソース形式を使用できます。 差し込み印刷に使用するデータ ソースをまだ持ってない場合は、Publisher で生成できます。 データ ソースは、Excel ワークシートまたは Word Microsoft Office表Microsoft Office作成することもできます。

データ ソースに含めるデータ フィールドは、カタログ データの差し込みテンプレートに挿入する差し込みフィールドに対応します。

データ ソースを設定するときに、アイテム名、株価番号、価格など、各種類の情報の列を作成します。 各行 (レコード) は、1 つのアイテムの情報に対応します。

大事な  結合する情報の種類ごとに、データ ソースにデータ フィールドまたは列が含まれる必要があります。 データ ソースの種類によっては、Publisher で接続した後にデータを変更できる場合がありますが、開始する前に情報を最終処理する方が良いです。

写真をカタログ ページに差し込む場合は、使用する各画像ファイルの パス 列を含める必要があります。 データ ソースには実際の図または画像を含めないでください。

Publisher でデータ ソースを作成する予定がある場合は、テンプレート文書を作成した後で作成できます。

ページの先頭へ

テンプレート文書を作成する

これで、差し込み印刷テンプレート文書を作成して、最終的な差し込み印刷ページのレイアウトをデザインできます。 差し込み印刷が完了したら、このカタログ データの差し込みテンプレートを使用して差し込み印刷ページを生成し、新しい文書として保存したり、既存の文書の末尾に追加することができます。

カタログ の差し込み印刷テンプレートのレイアウト (ページ サイズと向き) は、最終的な差し込み印刷ページと同じになります。 また、背景画像や会社の名前と電話番号など、最終的な文書の各ページに表示するテキストやグラフィックも含まれている必要があります。 これは、差し込み印刷テンプレートのこれらの要素にマスター ページを使用して行うのが最適です。

差し込み印刷ページを既存の文書の末尾に追加する場合は、カタログ データの差し込み印刷テンプレートが次の方法で既存の文書と一致する必要があります。

  • ページ サイズ (高さと幅)

  • ページ ビュー (1 ページまたは見開き 2 ページ)

  • 文書の種類 (Web または印刷)

  • ページの順序 (左から右、または右から左)

カタログ データの差し込み印刷テンプレートを作成する

  1. カタログに適した文書テンプレートを選択します。

  2. [挿入] タブの [カタログ ページ] をクリックします。
    カタログ ページの差し込み印刷を開始する

  3. カタログ ページは既定のカタログ の差し込み領域で作成され、[カタログ ツール] タブがリボンに表示されます。 この時点で、カタログ の差し込み領域をページ上で目的の位置に配置し、カタログのすべてのページに表示するテキストまたは画像 を追加できます。 差し込み印刷領域が小さい場合は、ページに差し込むカタログ アイテムが多くなります。 たとえば、2"x2" の差し込み領域は、4"x4" の差し込み領域よりも繰り返し回数が多い場合があります。 いつでもこれらのアイテムに戻って編集できるので、正確に取得する方法について心配する必要はありません。

    ヒント  現時点では、カタログの差し込み領域を構成しない。差し込みフィールドを挿入し、レイアウト ギャラリーからあらかじめ作成されたデザインの 1 つを使用するまで待ちます。

ページの先頭へ

データ ソースに接続する

カタログ データの差し込み印刷テンプレート ページの書式を設定した後、次の手順は、データ ソースを作成または検索して、データ ソースに接続することです。 次に選択するオプションは、データ ソースが既にあるかどうか、または Publisher で新しいリストを作成するかどうかによって異なります。

  1. [カタログ ツール] タブで[リストの追加] をクリックし、次のいずれかの操作を行います。

    • 差し込み印刷のデータ ソースを作成する必要がある場合は、[新しいリストを入力する] を選択します。

    • 使用するデータ ソースが既にある場合は、[既存のリストを使用する] をクリックします。

    • 連絡先のディレクトリを作成する場合は、[Outlook の連絡先から選択] をクリックします。

新しいリストを入力する

  1. [新しい製品一覧] ダイアログ ボックスで、カタログに含める最初の項目 (レコード) の情報を入力します。

    列を追加または削除する場合 (たとえば、図が含されていない場合) は、[列のカスタマイズ] をクリックし、必要な変更を加えます。

  2. 最初のレコードのすべての情報を入力したら、[新しいエントリ] をクリックし、次のレコードの情報を入力します。 含めるすべてのレコードの情報を入力するまで続行します。

  3. 新しいリストが完成したら、[OK] をクリックします。

  4. [アドレス帳の保存] ダイアログ ボックスで新しいリストの名前を入力し、[保存] をクリックします。

既存のリストを使用する

  1. [データ ソースの選択] ダイアログ ボックスで、目的のデータ ソースを見つけてクリックします。

    既定では、Publisher はデータ ソースを [マイ データ ソース] フォルダーに保存します。 データ ソースを見つけるには、[マイ データ ソース] フォルダーを参照する必要がある場合があります。

  2. [開く] をクリックします。

    選択したデータ ソースの種類によっては、特定の情報を要求する他のダイアログ ボックスが表示される場合があります。 たとえば、データ ソースが複数のタブに関する情報を含む Excel ワークシートの場合、必要な情報を含むタブを選択し、[OK] をクリックする必要があります。

Outlook の連絡先から選択

  1. 次の操作のいずれかを行います。

    • [連絡先の選択] ダイアログ ボックスで、使用する連絡先の一覧をクリックします。

    • [プロファイルの選択] ダイアログ ボックスで、使用する連絡先の適切なプロファイルを選択します。

  2. [OK] をクリックします。

リストを追加する

カタログ データの差し込み印刷で複数のリストを使用する場合は、リストを追加できます。

  1. [リストの編集] をクリックし、[カタログ 差し込み製品リスト] の [製品リストに追加] で、[既存のリストの選択]、または [Outlook の連絡先から選択]、または [新しいリストを入力] をクリックします。
    Publisher では、[製品リストに追加] ダイアログ ボックスを開いて、さまざまなソース リストのフィールド間の不一致を修正するように求めるメッセージが表示されます。

  2. [製品リストに追加] ダイアログ ボックスで、[対応する] 列でチェックされていないフィールドを選択し、対応するフィールド リストの [製品] フィールドで対応するフィールドを選択し、[一致] をクリックします。

  3. [フィールドの対応] ダイアログ ボックスで、選択したフィールドが [製品一覧に一致] フィールドの下に表示されるのを確認するか、別のフィールドを選び、[OK] をクリックします。

  4. 新しいフィールドを宛先リストに追加して対応付ける必要がある場合、新しいリスト ([宛先リストに追加] ダイアログ ボックスの左のリスト) に追加するフィールドを選択し、[追加] をクリックし、[OK] をクリックします。
    [宛先リストに追加する新しいフィールド] の下に追加されたフィールドが表示される

含めるレコードを選択します。

  1. [一覧の編集] をクリックします。

  2. [カタログ 差し込み印刷製品リスト] ダイアログ ボックスで、次のいずれかの操作を行います。

    • 含めるレコードの横にあるチェック ボックスをオンにし、除外するレコードの横にあるチェック ボックスをオフにします。

      ヒント  一覧に含めるレコードの数が少ない場合は、[すべてクリア] をクリックし、目的のレコードを選択します。

    • フィルター処理するアイテムの列見出しの横にある矢印をクリックし、フィルターとして使用する値をクリックして、特定の条件でリストをフィルター処理します。

      • (空白) 対応するフィールドが空白のすべてのレコードが表示されます。

      • [(データあり)] をクリックすると、対応するフィールドに情報が含まれるレコードがすべて表示されます。

        メモ  同じ情報を共有するレコードがデータ ソース内に複数含まれており、列の固有の値が 10 個以下である場合には、特定の情報でフィルター処理できます。 たとえば、データ ソースが販売用プロパティの一覧で、Buffalo を都市/場所として一覧表示する複数のプロパティ レコードがある場合は、Buffalo でフィルター処理できます。

        [カタログ 差し込み印刷製品リスト] ダイアログ ボックスには、指定されたレコードだけが表示されます。 すべてのレコードを再表示するには、[(すべて)] をクリックします。

    • 並べ替えのキーとして使用するアイテムの列見出しをクリックして、リスト内のアイテムを並べ替える。 たとえば、市区町名/場所のアルファベット順にリストを表示する場合は、[市区町名/場所] 列見出しをクリックします。

  3. [OK] をクリックします。

ページの先頭へ

差し込みフィールドを挿入する

次に、文書に表示する情報を配置します。 ページをレイアウトするには、差し込み印刷フィールドをカタログ の差し込み印刷領域に追加します。 各差し込みフィールドはデータ ソースの列を表し、カタログ の差し込み領域には 1 つのレコードの情報の表示方法が表示されます。

カタログ データの差し込み領域を希望の方法で配置し、各ページで差し込み印刷領域を繰り返す回数を指定します。 たとえば、各ページに 4 つのアイテムを表示できます。 各アイテムは、カタログ の差し込み領域の配置方法に基づいて、同じ方法で表示されます。 各アイテムのサイズを調整し、カタログ の差し込み領域のサイズを変更できます。

大事な   差し込み印刷フィールドをカタログ データの差し込み領域の外側に挿入した場合、差し込み印刷が完了すると、フィールドは繰り返し表示されます。

差し込み印刷領域のレイアウトを選択する

  1. [レイアウト] グループで、次のいずれかの操作を行います。

    • あらかじめ作成されたデザイン ギャラリーの 1 つから選択します。
      [カタログ データの差し込みのレイアウト] オプション

    • [行と列] ドロップダウンで、各ページの行と列の数を選択します。
      カタログ ページ レイアウトの行と列

差し込み印刷フィールドをカタログ データの差し込み領域に挿入する

  1. [テキスト フィールド] ボタンをクリックし、挿入する最初の差し込みフィールドをクリックします。
    カタログ データの差し込み印刷で、テキスト フィールドを挿入する

  2. カタログ の差し込み領域で差し込みフィールドを選択し、次の操作を行って差し込みフィールドを移動およびサイズ変更します。

    • 差し込みフィールドを移動するには、マウス ポインターが [移動] ポインター 移動ポインター に変わるまで差し込みフィールドの上に置き、差し込みフィールドを新しい位置にドラッグします。

    • 差し込みフィールドのサイズを変更するには、テキスト ボックスまたは図枠のいずれかのサイズ変更ハンドルの上にマウス ポインターを置き、ポインターが [サイズ変更] ポインター ルーラー ポインターを移動する に変わるまでマウスをドラッグし、テキスト ボックスまたは図枠が目的のサイズになるまでマウスをドラッグします。

  3. 差し込みフィールドの外側をクリックすると、選択が終了します。

  4. データ ソースから必要なすべてのフィールドを挿入するまで、手順 1 ~ 3 を繰り返します。

大事な   フィールドは、現在の挿入ポイント (カーソルが点滅するカーソル) に挿入されます。 挿入ポイントがない場合は、新しいテキストボックスが作成され、この新しいテキストボックスに差し込みフィールドが配置されます。

テキストの差し込みフィールドの書式を設定する

差し込み印刷カタログ データの書式を設定するには、カタログ データの差し込み印刷テンプレートで差し込みフィールドを書式設定します。 これらのフィールドは、任意のテキスト ボックスと同様に扱えるので、結合されていないテキストや書式、および結合されたアイテムを含めできます。

  1. カタログ データの差し込み印刷テンプレートで、書式設定する情報を含むフィールド (周囲の差し込みフィールド文字 («« »») を含むフィールドを選択します。

  2. [テキスト ボックス ツール] タブで、目的のオプションを選択します。

差し込み印刷領域に図の差し込みフィールドを挿入する

  1. [図フィールド] ボタンをクリックし、挿入する最初の差し込みフィールドをクリックします。

  2. カタログ の差し込み領域で差し込みフィールドを選択し、次の操作を行って差し込みフィールドを移動およびサイズ変更します。

    • 差し込みフィールドを移動するには、マウス ポインターが [移動] ポインター カーソルを移動する に変わるまで差し込みフィールドの上に置き、差し込みフィールドを新しい位置にドラッグします。

    • 差し込みフィールドのサイズを変更するには、テキスト ボックスまたは図枠のいずれかのハンドルの上にマウス ポインターを置き、ポインターが [サイズ変更] ポインター サイズ変更カーソル に変わるまでマウスをドラッグし、テキスト ボックスまたは図枠が目的のサイズになるまでマウスをドラッグします。

  3. 差し込みフィールドの外側をクリックすると、選択が終了します。

  4. データ ソースから必要なすべてのフィールドを挿入するまで、手順 1 ~ 3 を繰り返します。

大事な   フィールドは、現在の挿入ポイント (カーソルが点滅するカーソル) に挿入されます。 挿入ポイントがない場合は、新しいテキストボックスが作成され、この新しいテキストボックスに差し込みフィールドが配置されます。

カタログ データの差し込み領域を移動またはサイズ変更する

書式設定された差し込みフィールドがカタログ データの差し込み領域に収まらない場合は、サイズを変更できます。

メモ  サイズを大きくする場合は、各ページに収める項目数またはレコード数を少なくする必要がある場合があります。

  1. [カタログ 差し込み印刷] 領域をクリックして選択します。

  2. [カタログ 結合] 領域のハンドルの 1 つ上にマウス ポインターを置き、マウスをドラッグします。

  3. 各ページに表示するアイテムの数を指定するには、[カタログ 差し込み印刷レイアウト] ツール バーで、ページの下とページのアイテムに必要な番号を入力します。

テンプレートを完了してプレビューする

  1. [結果のプレビュー] をクリックします。

  2. 矢印をクリックすると、結合されたデータの各ページが表示されます。
    カタログ プレビュー グループ

    アイテムを含めない場合は、プレビューされたアイテムをクリックし、[プレビュー ページ] グループの [エントリを除外] をクリックします。

ページの先頭へ

カタログ文書を完成、印刷、保存する

差し込み印刷を完了するには、次の 3 つのオプションがあります。

  • 結合された文書を直接印刷できます。

  • 結合されたコンテンツを含む新しい文書を作成して印刷することができます。 Publisher で他の文書を変更するのと同じ方法で、この文書の内容を変更できます。

ヒント  文書に複数のカタログ 差し込み印刷を含める場合は、文書ごとに 1 つのカタログ ページセットしか作成できませんので、差し込み印刷ページ用に新しい文書を作成する必要があります。

  • 既存の文書に結合されたコンテンツを追加できます。

文書に表紙と表紙を追加する場合、または他のページを追加する場合は、新しい文書を作成するか、既存の文書に内容を追加する必要があります。

新しい文書に差し込む

差し込み印刷ページを編集する場合、後で使用するために保存する場合、または後で印刷する場合は、差し込み印刷ページを収集して、差し込みフィールドではなく実際のデータ (製品名や価格など) を含む 1 つの新しい差し込み印刷文書として保存できます。

  1. [差し込み印刷] グループの [新規に差し込み] をクリックします。
    カタログを新しい文書に結合 Publisher
    では、保存および編集できる新しい文書が作成されます。 表紙と表紙を追加することもできます。
    注: カタログを小冊子として印刷する予定がある場合は、総ページ数が 4 の倍数である必要があります。

  2. [カタログ の結合] 作業ウィンドウで、[この文書を保存] をクリックします。

  3. [ファイル名] ボックスに新しい文書の名前を入力し、[保存] をクリックします。

  4. 必要に応じて、カタログ データの差し込みテンプレートに加えた変更も保存します。 データ ソースの情報を更新するたびに、このカタログ 差し込み印刷テンプレートを再び使用して、追加の差し込み印刷ページを作成できます。

既存の文書に追加する

既にカバーを別の文書に設定している場合、または長い文書の最後にカタログを配置する場合は、結合したコンテンツを直接追加できます。

差し込み印刷ページを既存の文書の末尾に追加する前に、カタログ データの差し込み印刷テンプレートが次の方法で既存の文書と一致する必要があります。

  • ページ サイズ (高さと幅)

  • ページ ビュー (1 ページまたは見開き 2 ページ)

  • 文書の種類 (Web または印刷)

  • ページの順序 (左から右、または右から左)

メモ  Publisher では、開いている文書に結合されたページを追加することはできません。 差し込み印刷する文書で作業している場合は、差し込み印刷を完了する前に、文書を保存して閉じてください。

  1. [差し込み印刷] グループで、[既存に追加] をクリックします。
    カタログを既存の文書に結合

  2. [文書を開く] ダイアログ ボックスで、結合されたページを追加する文書を見つけて選択し、[開く] をクリックします。

    Publisher では、既存の文書の末尾に、結合されたページが追加されます。

    ヒント  更新された文書のページを並べ替える場合は、ページ ナビゲーション ウィンドウで移動するページをクリックし、目的の場所にドラッグします。

  3. 既存の文書で、[保存] をクリックして更新を保存します。

  4. 必要に応じて、カタログ データの差し込みテンプレートに加えた変更も保存します。 データ ソースの情報を更新するたびに、このカタログ 差し込み印刷テンプレートを再び使用して、追加の差し込み印刷ページを作成できます。

差し込み印刷文書を印刷する

  • [差し込み印刷] グループで [印刷] をクリックします。
    カタログ データの差し込み印刷

    Publisher では、BackStage ビューで印刷ページが開きます。

ページの先頭へ

ヘルプを表示

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×