スクリーン リーダーを使用して Access テーブルを Excel ブックにエクスポートする

装飾アイコン。 スクリーン リーダーのコンテンツ

この記事は、Office アクセシビリティ コンテンツ セットの一部であり、Office 製品でスクリーン リーダー プログラムを使用する、視覚に障碍のある方を対象としています。 一般的なヘルプについては、「Microsoft サポート ホーム」を参照してください。

キーボード Access スクリーン リーダーを使用して、読み取り可能なファイル形式 Excel エクスポートします。 ナレーター、JAWS および NVDA でテストしていますが、他のスクリーン リーダーでも、一般的なアクセシビリティの標準と技法に準拠していれば、機能する可能性があります。 エクスポート ウィザードを使用して、テーブル、クエリ、フォーム、レポート、または複数レコード ビューで選択したレコード (データシートなど) などのデータを Excel 互換ファイルにエクスポートする方法について学習します。

注: 

この記事の内容

エクスポート用にデータを準備する

データをエクスポートする前に、少し時間を取ってデータを確認し、エクスポート方法を決定します。

  • データにエラー インジケーターやエラー値が含まれているのを確認します。 そうしないと、エクスポート中に問題が発生する可能性があります。また、ワークシートのセルに null Excel 挿入される可能性があります。 トラブルシューティング情報については、「データをデータにエクスポート する」の「不足している値と正しくない値のトラブルシューティング」セクションExcel。

  • 書式設定を使用してテーブルまたはクエリをエクスポートするかどうかを決定します。 この決定は、エクスポートされるデータの量とデータの表示形式に影響します。 書式設定されたデータと書式設定されていないデータをエクスポートする結果の詳細については、「データをエクスポートする」 の「エクスポート操作の準備」セクションを参照Excel。

  • Choose the destination workbook and file format. 書式設定されたテーブル、クエリ、フォーム、またはレポートを既存のブックにエクスポートすると、ブックが上書きされます。

    注: レポートは、古い *.xls ファイル形式でのみエクスポートできます。新しい *.xlsx ファイル形式ではエクスポートできません。

データをエクスポートする

サブフォーム、サブレポート、またはサブデータシートが含まれているフォーム、レポート、またはデータシートをエクスポートすると、メインのフォーム、レポート、またはデータシートのみがエクスポートされます。 エクスポートするサブフォーム、サブレポート、サブデータシートごとに、エクスポート操作を繰り返 Excel。

1 回のエクスポート操作でエクスポートできるのは、1 つのデータベース オブジェクトのみです。 ただし、個々のエクスポート操作を完了した後 Excel 複数のワークシートを結合することができます。

ブックの準備ができていない場合は、エクスポート中に作成されます。 データは常に新しいワークシートに追加されます。

Access マクロまたはモジュールのエクスポートは現在サポート Excel。

  1. ブックの保存先が準備 Excel 場合は、ブックを閉じます。

  2. ソース データベースに移動し、エクスポートするオブジェクトを選択します。

    オブジェクトがテーブル、クエリ、またはフォームで、データの一部のみをエクスポートする場合は、データシート ビューでオブジェクトを開き、目的のレコードを選択します。 手順については、「データシート ビューで オブジェクトを開く」を参照してください

    注: レポートの一部をエクスポートできない。 ただし、レポートの基となるテーブルまたはクエリを選択または開き、そのオブジェクト内のデータの一部をエクスポートすることができます。

  3. エクスポートのエクスポート ウィザードを開始するには、Alt Excel X キーを押します。[エクスポート - スプレッドシートExcel] ダイアログボックスが開きます。

  4. 次のいずれかの操作を行います。

    • エクスポート中に新しいスプレッドシートを作成する場合は、Alt キーを押しながら F キーを押して、フォーカスを [ファイル名 ] テキスト フィールドに 移動します。 Access 、エクスポートされたファイルのファイル名としてソース オブジェクトの名前が提案されます。 名前を変更するには、候補の名前を削除し、新しい名前を入力します。

    • データをエクスポートする既存の Excel ファイルがある場合は、Alt キーを押しながら R キーを押して[ファイルの保存] ダイアログ ボックスを開き、目的のファイルを参照します。 ファイルを開き、Enter キーを押して選択します。 ダイアログ ボックスが閉じ、[エクスポート - スプレッドシート] ダイアログボックスExcelに戻されます。

  5. Alt キーを押しながら T キーを押して、フォーカスを [ファイル形式 ] リストに移動 します。 現在の形式が聞こえ、 目的のファイル形式を選択するには、Space キーを押してリストを展開し、目的の形式が聞こえるまで上方向キーまたは下方向キーを押し、Enter キーを押して選択します。

  6. テーブルまたはクエリをエクスポートし、書式設定されたデータをエクスポートする場合は、Alt キーを押しながら W キーを押してに移動し、[書式設定とレイアウトを使用してデータをエクスポートする] オプション を選択 します。

    注: フォームまたはレポートをエクスポートする場合、このオプションは既定で選択され、選択を解除できない。

  7. エクスポート後にエクスポート先 Excel ブックを自動的に開く場合は、Alt キーを押しながら A キーを押してに移動し、[エクスポート操作の完了後にコピー先ファイルを開く] オプション を選択 します。

  8. ソース オブジェクトが開いている場合に、エクスポートを開始する前にビューで 1 つ以上のレコードを選択し、エクスポートするレコードである場合は、Alt キーを押しながら Sキーを押して移動し、[選択したレコードのみをエクスポートする] オプションを選択します。 ビューに表示されるレコードをすべてエクスポートする場合は、このオプションを選択しない。

    注: レコードが選択されていない場合、このオプションは使用できません。

  9. エクスポートを開始するには 、[OK] ボタンが表示されるまで Tab キーを押し、Enter キーを押します。

  10. エクスポートが成功した場合、 Access ウィザードを使用せずに、エクスポート手順をすばやく繰り返すエクスポート手順を保存するように求めるメッセージが表示されます。 このオプションを選択するには、Alt キーを押しながら V キーを押します。 ファイルに名前を付けするには、Alt キーを押しながら A キーを押し、ファイル名を入力します。 手順ファイルを保存するには、Alt キーを押しながら S キーを押します。

    エラーが原因でエクスポートが失敗した場合、 Access 原因を説明するメッセージが表示されます。

    ブックのコピー先を自動的に開 Excel 選択した場合は、Alt キーを押しながら Tab キーを押し、ブックの名前が読み上がり、その内容を確認します。

データシート ビューでオブジェクトを開く

エクスポートするオブジェクトがテーブル、クエリ、またはフォームで、データの一部のみをエクスポートする場合は、データシート ビューでオブジェクトを開いて目的のレコードを選択する必要があります。

  1. ナビゲーション ツリー内の オブジェクトに移動します。

  2. オブジェクト上で Shift キーを押しながら F10 キーを押し、コンテキスト メニューを開きます。

  3. メニューで、[データシート ビュー] オプションが表示されるまでTab キーを押し、Enter キーを押して選択します。 オブジェクトがデータシート ビュー で開きます

    [ データシート ビュー] オプション を使用できない場合は、オブジェクトのビューを有効にする必要があります。 手順については、「オブジェクトの データシート ビューを有効にする」を参照してください

オブジェクトのデータシート ビューを有効にする

  1. ナビゲーション ツリー内のオブジェクト上で Shift キーを押しながら F10 キーを押してコンテキスト メニューを開きます。

  2. メニューで D キーを押してデザイン ビュー を 開きます

  3. デザイン ビュー で、F4キーを押して [プロパティ シート ] ウィンドウを開 きます。

  4. F6 キーを 1 回押します。 フォーカスが [プロパティ シート] ウィンドウのプロパティ 行に移動 します。 行番号の後にプロパティ セルの内容が読み上されます。

  5. フォーカスを [選択の種類] ドロップダウン リストに移動するには、"フィールド全体" の後に現在の値が続き、"コンボ編集" と聞こえるまで Shift キーを押しながら Tab キーを押します。 現在の値が Formの場合は、次の手順に進みます。 それ以外の場合は、Alt キーを押しながら下方向キーを押してリストを展開し、"フォーム" と聞こえるまで上方向キーまたは下方向キーを押し、Enter キーを押して選択します。

  6. [ プロパティ シート] ウィンドウ で、"データ タブ項目、選択" など、現在選択されているタブ項目が聞こえるまで Tab キーを押します。 現在のタブが [書式] タブの 場合は、次の手順に進みます。 それ以外の場合は、"タブ項目の書式設定" と読み上されるまで左方向キーまたは右方向キーを押します。 [書式] タブ のプロパティ が表示されます。

  7. [書式 ] タブで 、"行 4、いいえ、折りたたみ" と読み上されるまで Tab キーを押します。 フォーカスは [データシート ビュー を許可する] プロパティ にあります。 プロパティを [はい] に設定するには、Alt キーを押しながら下方向キーを押し、上方向キーを 1 回押し、Enter キーを押して新しい値を選択します。

  8. [プロパティ シート] ウィンドウを閉じる には、F4 キーを押します。

  9. データシート ビューで選択したオブジェクトを開く には、Altキーを押しながら J キー、D キー、W キー、H キーの順に押します。

関連項目

Access デスクトップ データベースでスクリーン リーダーを使ってテーブルを作成する

Access デスクトップ データベースでスクリーン リーダーを使ってクエリを作成する

Access デスクトップ データベースでスクリーン リーダーを使用してフォームを作成する

スクリーン リーダーを使用して Access テーブルをテキスト ファイルにエクスポートする

Access のキーボード ショートカット

スクリーン リーダーを使用して Access 内を移動する

障碍のある方向けのテクニカル サポート

Microsoft は、すべてのお客様に最適な操作性を提供することを目指しています。 障碍のある方、およびアクセシビリティに関してご質問がある方が技術サポートをご希望の場合は、Microsoft Disability Answer Desk までご連絡ください。 Disability Answer Desk サポート チームは、一般的なユーザー補助技術を駆使するトレーニングを受けており、英語、スペイン語、フランス語、および米語の手話でサポートを提供することができます。 お住まいの地域での連絡先の詳細については、Microsoft Disability Answer Desk サイトを参照してください。

政府機関、商用、または法人ユーザーの場合は、法人向け Disability Answer Desk までお問い合わせください。

ヘルプを表示

ディスカッションに参加
コミュニティにたずねる
サポートを受ける
お問い合わせ​​

この情報は役に立ちましたか?

翻訳品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?

フィードバックをお送りいただきありがとうございます!

×