Project では、ビューにフィルターをかけて、自分にとって最も重要なタスクやマイルストーン、その他の情報だけを表示することができます。 プロジェクトのタスクまたはリソースをフィルター処理するには、タスクやリソースの特定の側面を表示するための定義済みのフィルターが 3 リソース。 これらのどのフィルターもニーズを満たしていな場合は、新しいフィルターを作成するか、既存のフィルターを変更できます。

  • 定義済みフィルター    これらは、Project に含むフィルターです。 未完了のタスクや割り当て過剰なリソースなど、タスクやリソースをすばやくフィルター処理するために使用されます。

  • カスタム フィルター    これらは、プロジェクトのニーズを満たして設計するフィルターです。

  • オートフィルター    これらをオンにすると、シート ビューの各列の上部に矢印として表示されます。 これらを使用して、列内のアイテムをすばやくフィルター処理します。

この記事の内容

タスクまたはリソースをフィルター処理する

プロジェクト内の特定の種類の情報のみを表示したい場合があります。 たとえば、プロジェクトのマイルストーンのみを表示したり、まだ開始していないタスクを表示したりするとします。 プロジェクトに多くのタスクが含まれる場合、多くのリソースが含まれる場合、フィルターは特定の範囲の情報を表示する場合に非常に役立ちます。 フィルターを使用すると、関心のある情報のみを表示し、残りの情報を非表示にできます。

事前に定義されたプロジェクト フィルターを使用して、タスクまたはリソースのデータをフィルター処理できます。 ニーズを満たすフィルターが見当たらな場合は、新しいフィルターを作成するか、既存のフィルターを変更できます。

フィルターを適用または削除する

  1. [表示 ] タブ の [データ ] グループで、フィルターの一覧からフィルターを選択します。

    [フィルター] コマンド

    一覧に表示されていないフィルターを適用するには、[その他のフィルター] を選択し、次のいずれかの操作を行います。

    • タスク フィルターを選択するには、[タスク]を選択し、[フィルター ] リストでフィルター名を選択し、[適用] を選択します

    • リソース フィルターを選択するには、[リソース] を選択し、[フィルター] リストでフィルター名を 選択 し、[適用] を選択 します

      注: タスク ビューには、タスク フィルターを適用できません。

  2. 対話型フィルターを適用する場合は、要求された値を入力し 、[OK]を選択します。

  3. フィルターをオフにする場合は、フィルターの一 覧で [フィルターなし] を選択します。

強調表示を使用してフィルター処理されたタスクに色を適用する

タスクまたはリソースをフィルター処理する場合は、強調表示を適用できます。 強調表示されたタスクまたはリソースは、フィルター処理されていないタスクと一緒に表示されますが、色は異なります。

  1. [表示] タブの[データ] グループで、フィルターの一覧でフィルターを選択し、[その他のフィルター]を選択します

  2. フィルターの一覧でフィルターを選択し、[蛍光ペン] を選択 します

ヒント:  強調表示されているタスクに別の色を適用するには、別のテキスト スタイルを使用します。 [書式] タブを 選択し、[テキストのスタイル ] を選択します。 [変更する アイテム] リストで 、[強調表示 されたタスク] を選択し、書式設定オプションを選択します。

ユーザー設定フィルターを作成する

  1. [表示] タブの [データ]グループで、[フィルター ] の横にある矢印を選択し、[その他のフィルター ] を選択します

    ユーザー設定フィルターを作成する方法を示す、Project のリボン

  2. [ タスク] または[リソース ] (作成するフィルターの種類に応じて異なる) を選択し、[新規] を 選択します

  3. 新しいフィルターの名前を入力します。 そのフィルターを [データ] グループ リストに含める場合は [メニューに表示する] を選択します。

  4. [かつ/または] 列で [かつ] を選択して、複数のフィルター条件に一致する結果を表示します。 [または] を選択すると、どれか 1 つの条件を満たす行が表示されます。

    フィルターで取得したい結果の種類に応じて [かつ] あるいは [または] を選択する。

  5. [フィールド名] 列で、フィルターをかけるフィールドを選択します。

  6. [テスト] 列で、[フィールド名] 列に選択した内容と次の手順で選択する [] 列をどのように一致させるかを指定します。

  7. [] 列で、使用する値を選択するか、または新しい値を入力します。

    [テスト] 列で [と等しい] または [と等しくない] を選んだ場合は、[] 列に (リストからオプションを選ぶ代わりに) ワイルドカード文字を入力することもできます。 たとえば、疑問符 (?) を入力すると、任意の 1 文字に一致します。 アスタリスク (*) を入力すると、任意の文字数の任意の文字に一致します。 ワイルドカードを使用する場合は、[フィールド名] 列で選んだ内容が、数値 ([期間] など) ではなく文字列 ([名前] など) を含んでいることを確認してください。

  8. フィルターに別の行を追加し (フィルターを適用する別のフィールド名を選択するには)、[行の挿入] を選択します。 空の行を追加することにより、複数の行をグループ化できます。 空の行に [かつ] あるいは [または] を追加して、1 つのグループを別のグループに対してフィルタリングします。

  9. 完了したら、[保存] を選択 します

ヒント: すべてのフィルターをすばやく削除するには、F3 キーを使います。 タスク フィルターはタスク ビューでしか動作せず、リソース フィルターはリソース ビューでしか動作しないので、注意してください。

既存のフィルターを変更する

  1. [表示 ] タブ の [ データ] グループでフィルター リストを選び、[その他のフィルター] を選ぶ

  2. 次のいずれかの操作を行います。

    • タスク フィルターを変更するには、[タスク] を選択し、変更するフィルターを選択して、[編集] を選択 します

    • リソース フィルターを変更するには、[リソース] を選択し、変更するフィルターを選択して、[編集] を選択 します

  3. [フィルター定義] ダイアログ ボックスのコントロールを使用して、フィルター の設定を 変更します。

オートフィルターを使用する

オートフィルターは、任意のシート ビューのフィールドに適用できます。 標準フィルターに加えて、Project にはオートフィルターが用意され、シート ビューの各列の上部に表示されます。

オートフィルターを適用および削除する

  1. [表示] タブの[データ] グループで、フィルターリストの矢印を選択し、[オートフィルターの表示] を選択します
    [フィルター] コマンド

  2. 表示する情報を含む列見出しの横にあるオートフィルター矢印を選択し、テーブルにフィルターを適用する値を選択します。
    オートフィルターの矢印とフィールドの見出しが青になります。

  3. 別の列の値に基づいて追加の条件を適用するには、他の列に対して手順 2 を繰り返します。

  4. 特定の行のフィルター処理を削除するには、そのフィールドのオートフィルター リストで [すべてのフィルターをクリア] を選択します。

  5. オートフィルターをオフにする場合は、[オートフィルター の表示] を再び選択 します。

    注:  ビューの行の 1 つで情報が変更された場合は、矢印を選択し、フィルター値を再選択して、オートフィルターの設定を更新できます。

ユーザー設定のオートフィルターを作成する

  1. オートフィルターを表示する。

  2. オートフィルターの矢印を選択し、[フィルター] をポイントして、[ユーザー設定] を選択 します

  3. 最初のボックスで使用する演算子を選択し、2 番目のボックスに一致する値を入力または選択します。

    たとえば、日付フィールドの特定の日付と一致するには、最初のボックスで等号演算子を選択し、2 番目のボックスで一致する日付を選択します。

  4. オートフィルターに 2 つの条件を適用するには、次のいずれかの操作を行います。

    • 両方の条件を満たす行をビューに表示するには、2 行目のボックスで必要な演算子と値を選択し、[And] を選択 します

    • 1 つの条件または別の条件を満たす行をビューに表示するには、2 行目のボックスで必要な演算子と値を選択し、[または] を選択 します

  5. オートフィルター設定を保存するには、[保存] を選択 します

    ビューに定義済みのフィルターが既に適用されている場合、オートフィルターに設定した条件は、現在のフィルターの追加条件として含まれます。 オートフィルター設定を保存すると、フィルターはファイル内の他のフィルターと一緒に保存され、[その他のフィルター] ダイアログ ボックス でのみ 使用できます。

新しいプロジェクトのオートフィルターを自動的に有効にする

  1. [ファイル] タブで、[オプション] を選択します。

  2. [詳細設定]を選び、[全般] セクションで [新しいプロジェクトにオートフィルターを設定する] チェック ボックスオンにします。

ページの先頭へ

ヘルプを表示

スキルを磨く
トレーニングの探索
新機能を最初に入手
Microsoft Insider に参加する

この情報は役に立ちましたか?

翻訳品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?

フィードバックをお送りいただきありがとうございます!

×