セル

テキスト (.txt または .csv) ファイルのインポートまたはエクスポート

テキスト (.txt または .csv) ファイルのインポートまたはエクスポート

Excel でテキスト ファイルからデータをインポートするには、Excel で開く方法と、Excel ファイルとしてインポートする方法の 2 外部データ範囲。 Excel からテキスト ファイルにデータをエクスポートするには、[名前を付けて保存] コマンドを使用し、ドロップダウン メニューからファイルの種類を変更します。

よく使用されるテキスト ファイル形式には、次の 2 つがあります。

  • 区切り文字付きテキスト ファイル (.txt)。通常、テキストの各フィールドはタブ文字 (ASCII 文字コード 009) によって区切られます。

  • コンマ区切りテキスト ファイル (.csv)。通常、テキストの各フィールドはコンマ文字 (,) によって区切られます。

区切り文字付きテキスト ファイルおよびコンマ区切りテキスト ファイルの両方で、使用する区切り文字を変更できます。 この操作は、インポート操作またはエクスポート操作が意図したとおりに機能するために必要な場合があります。

注: 最大で 1,048,576 行、16,384 列をインポートまたはエクスポートすることができます。

Excel でテキスト ファイルを開いてインポートする

別のプログラムで作成したテキスト ファイルを Excel ブックとして開くには、[開く] コマンドを 使用 します。 Excel でテキスト ファイルを開いた場合、ファイルの形式は変更されません。これは Excel のタイトル バーに表示され、ファイル名にはテキスト ファイル名の拡張子 (.txt や .csv など) が保持されます。

  1. [ファイル] ボックス>き、テキスト ファイルを含む場所を参照します。

  2. [ 開く] ダイアログ ボックスのファイルの種類ドロップダウン リストで [ テキスト ファイル] を 選択します。

  3. 開きたいテキスト ファイルを見つけてダブルクリックします。

    • ファイルがテキスト ファイル (.txt) の場合、Excel はテキスト インポート ウィザードを起動します。 手順が完了したら、[完了] をクリックしてインポート操作を完了します。 区切 り記号と詳細オプションの 詳細については、テキスト インポート ウィザードを参照してください。

    • ファイルが .csv ファイルの場合は、Excel によって自動的にテキスト ファイルが開かれ、新しいブックにデータが表示されます。

      注: Excel で .csv ファイルを開くと、Excel は現在の既定のデータの書式設定を使用して、データの各列をインポートする方法を解釈します。 列を別のデータ形式により柔軟に変換する場合は、テキスト インポート ウィザードを使用することができます。 たとえば、.csv ファイルのデータ列の書式が MDY で、Excel の既定のデータ形式が YMD の場合、または先頭のゼロを含む数値の列をテキストに変換して先頭のゼロを維持できるようにする場合などがあります。 Excel でテキスト インポート ウィザードを強制的に実行するには、ファイル名の拡張子を .csv から .txt に変更してから開くか、テキスト ファイルに接続してインポートします (詳細については、次のセクションを参照してください)。

テキスト ファイルに接続してインポートする (Power Query)

テキスト ファイルから既存のワークシートにデータをインポートできます。

  1. [データ ] タブ の [データの取得 &] グループで、[テキスト/CSV から] をクリックします

  2. [データ のインポート] ダイアログ ボックスで、インポートするテキスト ファイルを見つけてダブルクリックし、[インポート] をクリック します

  3. [プレビュー] ダイアログ ボックスには、次のいくつかのオプションがあります。

    • データを新しい ワークシートに直接読み込む場合は、[読み込み] を選択します。

    • または、テーブル、ピボットテーブル/ピボットグラフ、既存/新規の Excel ワークシートにデータを読み込む場合、または単に接続を作成する場合は、[読み込み] を選択します。 データ モデルにデータを追加するオプション も選択できます

    • Power Query にデータ を読み込む場合は、[データの変換] を選択し、Excel にインポートする前にデータを編集します。

Excel でデータの特定の列が必要な形式に変換されていない場合は、インポート後にデータを変換できます。 詳細については、「文字列として保存されている数値を数値形式に変換する」と「文字列として保存されている日付を日付形式に変換する」を参照してください。

データを保存してテキスト ファイルにエクスポートする

[名前を付けて保存] コマンドを使用して、Excel ワークシートをテキスト ファイルに変換できます。

  1. [ファイル]、[名前を付けて保存] の順に選択します。

  2. [参照] をクリックします。

  3. [名前を 付けて保存 ] ダイアログ ボックスの [ ファイルの種類 ] ボックスで、ワークシートのテキスト ファイル形式を選択します。たとえば、[テキスト] (タブ区切り) または CSV (コンマ区切り) をクリックします

    注: 形式ごとにサポートする機能セットが異なります。 テキスト ファイル形式ごとにサポートされる機能セットの詳細については、「Excel でサポートしているファイル形式」を参照してください。

  4. 新しいテキスト ファイルを保存する場所を参照し、[保存] をクリックします。

  5. ダイアログ ボックスが表示され、現在のワークシートのみが新しいファイルに保存されることを示すメッセージが表示されます。 現在のワークシートがテキスト ファイルとして保存するワークシートであることを確認し、[OK] をクリックします。 各ワークシートで同じ操作を繰り返すことにより、他のワークシートを別々のテキスト ファイルとして保存できます。

    また、CSV 形式でブックを保存すると、一部の機能が失われる可能性があるという警告がリボンの下に表示される場合があります。

テキスト ファイル形式でサポートされない Excel の機能の詳細について知る必要がある場合は、「他のファイル形式でブックを保存する」を参照してください。

テキスト ファイルに接続してインポートする

テキスト ファイルから既存のワークシートにデータをインポートできます。

  1. テキスト ファイルのデータを配置するセルをクリックします。

  2. [データ] タブの [外部データの取り込み] で [テキストから] をクリックします。

  3. [データ のインポート] ダイアログ ボックスで、インポートするテキスト ファイルを見つけてダブルクリックし、[インポート] をクリック します

    テキスト インポート ウィザードの指示 に従います。 ウィザード ボタンの画像 詳細については、テキスト インポート ウィザードの任意のページで [ヘルプ] をクリックします。 ウィザードの手順が完了したら、[完了] をクリックしてインポート操作を完了します。

  4. [データのインポート] ダイアログ ボックスで、次の操作を行います。

    1. [データを返す先を選択してください。] で、次のいずれかの操作を行います。

      • 選択した場所にデータを返すには、[既存のワークシート] をクリックします。

      • 新しいワークシートの左上隅にデータを返すには、[新規ワークシート] をクリックします。

    2. 必要に応じて [プロパティ] をクリックして、インポートしたデータの更新、書式、およびレイアウトのオプションを設定します。

    3. [OK] をクリックします。

      指定した場所に外部データ範囲が配置されます。

Excel でデータの列が目的の形式に変換されない場合、データをインポートしてから変換することができます。 詳細については、「文字列として保存されている数値を数値形式に変換する」と「文字列として保存されている日付を日付形式に変換する」を参照してください。

データを保存してテキスト ファイルにエクスポートする

[名前を付けて保存] コマンドを使用して、Excel ワークシートをテキスト ファイルに変換できます。

  1. [ファイル]、[名前を付けて保存] の順に選択します。

  2. [名前を付けて保存] ダイアログ ボックスが表示されます。

  3. [ファイルの種類] ボックスで、ワークシートのテキスト ファイル形式を選択します。

    • たとえば、[テキスト (タブ区切り)] または [CSV (コンマ区切り)] をクリックします。

    • 注: 形式ごとにサポートする機能セットが異なります。 テキスト ファイル形式ごとにサポートされる機能セットの詳細については、「Excel でサポートしているファイル形式」を参照してください。

  4. 新しいテキスト ファイルを保存する場所を参照し、[保存] をクリックします。

  5. ダイアログ ボックスが表示され、現在のワークシートのみが新しいファイルに保存されることを示すメッセージが表示されます。 現在のワークシートがテキスト ファイルとして保存するワークシートであることを確認し、[OK] をクリックします。 各ワークシートで同じ操作を繰り返すことにより、他のワークシートを別々のテキスト ファイルとして保存できます。

  6. 2 つ目のダイアログ ボックスが表示され、現在のワークシートにはテキスト ファイル形式でサポートされない機能が含まれている可能性があることを示すメッセージが表示されます。 ワークシート データを新しいテキスト ファイルに保存することだけが目的であれば、[はい] をクリックします。 テキスト ファイル形式でサポートされている Excel の機能がわからず、詳しく知りたい場合は、[ヘルプ] をクリックします。

テキスト ファイル形式でサポートされない Excel の機能の詳細について知る必要がある場合は、「他のファイル形式でブックを保存する」を参照してください。

インポート時に区切り記号を変更する方法は、テキストのインポート方法によって異なります。

  • [テキスト/CSVから & データの取得] > を使用する場合は、テキスト ファイルを選択し、[インポート] をクリックした後、[区切り記号] の下の一覧から使用する文字を選択します。 データ プレビューで新しい選択の効果をすぐに確認できます。そのため、続行する前に、必要な選択を確実に行えます。

  • テキスト インポート ウィザードを使用してテキスト ファイルをインポートする場合は、テキスト インポート ウィザードの手順 2 でインポート操作に使用する区切り記号を変更できます。 この手順では、連続する引用符などの連続する区切り記号の処理方法を変更できます。

    区切 り記号と詳細オプションの 詳細については、テキスト インポート ウィザードを参照してください。

.csv として保存するときに既定のリストの区切り文字としてセミコロンを使用する必要があるが、Excel に変更を制限する必要がある場合は、既定の小数点の区切り文字をコンマに変更すると、リストの区切り文字にセミコロンが使用されます。 当然ながら、これにより小数の表示方法も変わるので、混乱を制限するために桁区切り記号を変更することもできます。

  1. [Excel のオプション] をオフ>詳細>編集オプション>を使用する] をクリックします

  2. 小数点の区切り記号をカンマ (,)に設定します。

  3. 桁区切り記号を . (ピリオド) を選択します。

ブックを .csv ファイルとして保存すると、既定の区切り記号 (区切り記号) はコンマです。 Windows の [地域] 設定を使用して、これを別の区切り文字に変更できます。 

注意: Windows の設定を変更すると、コンピューターのグローバルな変更が発生し、すべてのアプリケーションに影響します。 Excel の区切り記号のみを変更するには、「Excel でファイルをテキスト (.csv) として保存する既定の区切り文字 を変更する」を参照してください

  1. Microsoft Windows 10 では、[スタート] ボタンを右クリックし、[設定] をクリックします

  2. [ 時刻&言語] をクリックし、左側のパネル [地域] をクリックします。

  3. メイン パネルの [地域の設定] 、[追加の 日付、時刻、地域の設定] をクリックします

  4. [ 地域] で、[ 日付、時刻、または数値の書式を変更する] をクリックします

  5. [地域 ] ダイアログ ボックス の [書式] タブで 、[その他の設定 ] をクリックします

  6. [書式のカスタマイズ]ダイアログの[数値] タブで、[区切り記号] ボックスに新しい区切り文字として使用する文字を入力します。

  7. [OK] を 2 回クリックします。

  1. Microsoft Windows で、[スタート] ボタンをクリックし、[コントロール パネル] をクリックします。

  2. [時計、言語、および地域] で、[日付、時刻または数値の形式の変更] をクリックします。

  3. [地域 ] ダイアログ ボックス の [書式] タブ 、[その他の設定 ] をクリックします

  4. [書式のカスタマイズ]ダイアログの[数値] タブで、[区切り記号] ボックスに新しい区切り文字として使用する文字を入力します。

  5. [OK] を 2 回クリックします。

注:  コンピューターの区切り記号を変更した後は、すべてのプログラムで新しい文字が区切り記号として使用されます。 同じ操作を行うことにより、変更した文字を既定の文字に戻すことができます。

補足説明

Excel 技術コミュニテでは、いつでも専門家に質問できます。また、Answers コミュニティでは、サポートを受けられます。

関連項目

外部データ ソースからデータをインポートする (Power Query)

ヘルプを表示

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×