ワークシートのデータのアウトラインを作成する

グループ化して集計するデータのリストがある場合は、最大 8 つのレベルのアウトラインを作成できます。 アウトライン記号の中で大きい数字で表される内側の各レベルに、小さい数字で表されるすぐ外側のレベルの詳細データが表示されます。 アウトラインを使うと、集計行や集計列の表示や各グループの詳細データの参照をすばやく行うことができます。 作成できるアウトラインは、行のアウトライン (下の例を参照)、列のアウトライン、行と列の両方のアウトラインです。

1.  レベルに対応する行を表示するには、適切な 1 2 3 アウトライン記号をクリックします。

2.  レベル 1 には、すべての詳細行の売上高の合計が含まれます。

3.  レベル 2 には、各地域の各月の売上高の合計が含まれます。

4. レベル 3 には、詳細行 (この場合は行 17 ~ 20) が含まれます。

5. アウトライン内のデータを展開または折りたたむには、 プラス記号 (+) アウトライン記号と マイナス アウトライン記号をクリックするか 、Alt キーと Shift キーを押しながら = キーを押して展開し 、Alt キーと Shift キーを押しながら - キーを押して折りたたむ必要があります。

  1. アウトラインを作成するデータの各列の 1 行目にラベル (地域など) が含まれており、各列に同様の事実情報が含まれており、アウトラインを作成する範囲に空白の行や列が含まれている必要はありません。

  2. 必要に応じ、グループ化された詳細行に対応する集計行 (小計) を設定できます。 これらを作成するには、次のいずれかの操作を行います。

    • [小計] を使って集計行を挿入する    

      [小計] を使うと、詳細行の各グループのすぐ上またはすぐ下に SUBTOTAL 関数が挿入され、アウトラインが自動的に作成されます。 SUBTOTAL 関数の使用方法の詳細については、「SUBTOTAL 関数」をご覧ください。

    • 独自の集計行を挿入する    

      詳細行の各グループのすぐ上またはすぐ下に数式を設定して、独自の集計行を挿入します。 たとえば、3 月と 4 月の売上データの行の下 (または上) で、SUM 関数を使ってこれらの月の売上の小計を出します。 後の表では、この例を示します。

  3. 既定では、集計の詳細の下に集計行が表示されますが、詳細行の上に集計行を作成できます。 詳細の下に集計行を作成した場合は、次の手順 (手順 4) に進みます。 詳細行の上に集計行を作成した場合は、[データ] タブの[アウトライン] グループでダイアログ ボックス起動ツールをクリックします。

    アウトライン グループでダイアログ ボックス起動ツールをクリックする

    [設定] ダイアログ ボックスが開きます。

    アウトラインの [設定] ダイアログ ボックス

    次に、[設定] ダイアログ ボックスで、[詳細] の下にある [サマリー行] チェック ボックスをオフにし、[OK]をクリックします。

  4. データのアウトラインを作成します。 次のいずれかの操作を行います。

    アウトラインを自動作成する

    1. アウトラインを作成するセル範囲のセルを選択します。

    2. [データ] タブの [アウトライン] で、[グループ] の下の矢印をクリックし、[自動アウトライン] をクリックします。

      [グループ] の下にある矢印をクリックして、[アウトラインの自動作成] をクリックする

    アウトラインを手動で作成する

    重要: アウトライン レベルを手動でグループ化する場合、行のグループ化でのミスを防ぐために、すべてのデータを表示することをお勧めします。

    1. 外側のグループ (レベル 1) のアウトラインを作成するには、外部グループに含まれるすべての行 (つまり、詳細行と追加した場合はサマリー行) を選択します。

      外部グループを作成する準備が整ったデータ選択

      1. 最初の行にはラベルが含まれているが、選択されていない。

      2. これは外側のグループです。小計と詳細を含むすべての行を選択します。

      3. 総計は選びない。

    2. [データ] タブの [アウトライン] にある [グループ] をクリックします。 次に、[グループ] ダイアログ ボックスで [行] を クリック、[OK] をクリックします

      ヒント: セルではなく行全体を選んだ場合、Excel では自動的に行でグループ化されます。[グループ化] ダイアログ ボックスも開かれません。

      [行] をクリックして、[OK] をクリックする

      画面のグループの上または左に、アウトライン記号が表示されます。

    3. 必要に応じて、入れ子になった下位グループ (指定したデータ セクションの詳細行) のアウトラインを作成します。

      注: 内部グループを作成する必要がない場合は、以下の手順 f に進みます。

      入れ子になった下位グループそれぞれについて、集計行に隣接する各詳細行を選択します。

      階層のレベル 2 でグループ化するために選択されたデータ。

      1. 内部レベルごとに複数のグループを作成できます。 ここでは、2 つのセクションが既にレベル 2 にグループ化されています。

      2. このセクションが選択され、グループ化する準備が整います。

      3. グループ化するデータの集計行を選択しない。

    4. [データ] タブの [アウトライン] にある [グループ] をクリックします。

      [データ] タブの [グループ] をクリックする

      次に、[グループ] ダイアログ ボックスで [行] を クリック、[OK] をクリックします。 画面のグループの上または左に、アウトライン記号が表示されます。

      ヒント: セルではなく行全体を選んだ場合、Excel では自動的に行でグループ化されます。[グループ化] ダイアログ ボックスも開かれません。

    5. 下位の行の選択とグループ化を続け、アウトラインに含めるすべてのレベルを作成します。

    6. 行のグループ化を解除するには、行を選択し、[データ] タブの [アウトライン] で [グループ解除] をクリックします。

      レベル全体を削除せずにアウトラインのセクションのグループ化を解除できます。 Shift キーを押しながらグループの プラス記号 (+) ボックス または マイナス記号 (-) ボックス をクリックし、[データ] タブの [アウトライン]グループで [グループ解除] をクリックします

      重要: 詳細データを非表示にしているときにアウトラインのグループ化を解除すると、詳細行が非表示のままになることがあります。 データを表示するには、まず、非表示の行に隣接して表示されている行番号をドラッグして選択します。 次に、[ホーム]タブの[セル]グループで [書式] をクリックし、[非表示] &表示] をポイントし、[行の再表示] をクリックします

  1. アウトラインを作成するデータの各行の最初の列に行見出しがあること、同じ行には同じ種類のデータが入力されていること、範囲内に空白行または空白列が含まれていないことを確認します。

  2. 詳細列の各グループの右または左に、数式を含む独自の集計列を挿入します。 次の手順 4 の表に例を示します。

    注: 列単位でデータのアウトラインを作成するには、グループの各詳細列のセル範囲を参照する数式を集計列に設定します。

  3. 集計列が詳細列の左側にある場合は、[データ] タブの[アウトライン]グループでダイアログ ボックス起動ツールをクリックします。

    アウトライン グループでダイアログ ボックス起動ツールをクリックする

    [設定] ダイアログ ボックスが開きます。

    アウトラインの [設定] ダイアログ ボックス

    次に、[設定] ダイアログ ボックスで、[詳細の右側にある集計列] チェック ボックスをオフにして、[OK]をクリックします。

  4. データのアウトラインを作成するには、次のいずれかの操作を行います。

    アウトラインを自動作成する

    1. 範囲内のセルを選択します。

    2. [データ] タブの [アウトライン] で、[グループ] の下の矢印をクリックし、[自動アウトライン] をクリックします。

    アウトラインを手動で作成する

    重要: アウトライン レベルを手動でグループ化する場合、列のグループ化でのミスを防ぐために、すべてのデータを表示することをお勧めします。

    1. 外部グループ (レベル 1) のアウトラインを作成するには、下位のすべての集計列と、関連する詳細データを選択します。

      グループ化する列に配列されたデータ

      1. 列 A にラベルが含まれている。

      2. すべての詳細列と小計列を選択します。 列全体を選択しない場合は、[グループ] ([アウトライン] グループの[データ]タブ) をクリックすると、[グループ] ダイアログ ボックスが開き、[行] または [列] の選択を求めるメッセージが表示されます。

      3. 総計列は選択しない。

    2. [データ] タブの [アウトライン] にある [グループ] をクリックします。

      [データ] タブの [グループ] をクリックする

      グループの上にアウトライン記号が表示されます。

    3. 入れ子になった詳細列のグループ (レベル 2 以上) のアウトラインを作成するには、集計列を含む列の隣にある詳細列を選択します。

      列でグループ化されたデータ

      1. 内部レベルごとに複数のグループを作成できます。 ここでは、2 つのセクションが既にレベル 2 にグループ化されています。

      2. これらの列が選択され、グループ化する準備が整います。 列全体を選択しない場合は、[グループ] ([アウトライン] グループの[データ]タブ) をクリックすると、[グループ] ダイアログ ボックスが開き、[行] または [列] の選択を求めるメッセージが表示されます。

      3. グループ化するデータの集計列は選択しない。

    4. [データ] タブの [アウトライン] にある [グループ] をクリックします。

      [データ] タブの [グループ] をクリックする

      画面のグループの上または左に、アウトライン記号が表示されます。

  5. 下位の列の選択とグループ化を続け、アウトラインに含めるすべてのレベルを作成します。

  6. 列のグループ化を解除するには、列を選択し、[データ] タブの [アウトライン] で [グループ解除] をクリックします。

[データ] タブで、[グループ解除] をクリックする

レベル全体を削除せずにアウトラインのセクションのグループ化を解除できます。 Shift キーを押しながらグループの プラス記号 (+) ボックス または マイナス記号 (-) ボックス をクリックし、[データ] タブの [アウトライン]グループで [グループ解除] をクリックします

詳細データを非表示にしているときにアウトラインのグループ化を解除すると、詳細列が非表示のままになることがあります。 データを表示するには、まず、非表示の列に隣接して表示されている列見出しをドラッグして選択します。 次に、[ホーム] タブの [セル] で [書式] をクリックし、[非表示/再表示] をポイントして、[列の再表示] をクリックします。

  1. アウトライン記号 1 2 3プラス記号 (+) 、および マイナス が表示できない場合は、[ファイル> オプション>詳細設定]に移動し、[このワークシート] セクションの [表示オプション]で、[アウトラインが適用されている場合にアウトライン記号を表示する] チェック ボックスをオンにして、[OK]をクリックします。

  2. 次の操作のいずれか、または複数の操作を行います。

    • グループの詳細データを表示または非表示にする    

      グループ内の詳細データを表示するには、グループ プラス記号 (+) ボタンをクリックするか、Alt キーと Shift キーを押しながら = キー を押します

    • グループの詳細データを非表示にする場合は、グループ マイナス ボタンをクリックするか、Alt キーと Shift キーを押しながら - キー を押します

    • アウトライン全体の特定のレベルを表示または非表示にする    

      アウトライン記号 1 2 3 、必要なレベルの番号をクリックします。 クリックした記号よりも下位レベルの詳細データは非表示になります。

      たとえば、アウトラインに 4 つのレベルがある場合、 3 をクリックすると、4 番目のレベルを表示せずに、それより上のレベルの詳細データをすべて表示できます。

    • アウトラインの詳細データをすべて表示または非表示にする    

      すべての詳細データを表示するには、 1 2 3 アウトライン記号の一番下のレベルをクリックします。 たとえば、3 つのレベルが設定されている場合は、 3 をクリックします。

    • すべての詳細データを非表示にするには、 1 をクリックします。

アウトラインが作成された行には、RowLevel_1 や RowLevel_2 などのスタイルが使われます。 アウトラインが作成された列には、ColLevel_1 や ColLevel_2 などのスタイルが使われます。 スタイルには、太字、斜体などの文字書式が使われ、他のデータから集計行と集計列が区別されます。 これらの各スタイルの定義を変更し、別のテキストの書式やセルの書式を使ってアウトラインの表示を独自に設定できます。 アウトラインへのスタイルの適用は、アウトラインの作成時または作成後に行うことができます。

次の操作のいずれか、または複数の操作を行います。

新しい集計行または列にスタイルを自動的に適用する    

  1. [データ ] タブ の [アウトライン ] グループで、ダイアログ ボックス起動ツールをクリックします。

    アウトライン グループでダイアログ ボックス起動ツールをクリックする

    [設定] ダイアログ ボックスが開きます。

    アウトラインの [設定] ダイアログ ボックス

  2. [既定のスタイルを使用する] チェック ボックスをオンにします。

既存の集計行または集計列にスタイルを適用する    

  1. スタイルを適用するセルを選択します。

  2. [データ ] タブ の [アウトライン ] グループで、ダイアログ ボックス起動ツールをクリックします。

    アウトライン グループでダイアログ ボックス起動ツールをクリックする

    [設定] ダイアログ ボックスが開きます。

    アウトラインの [設定] ダイアログ ボックス

  3. [自動スタイル ] チェック ボックス をオンにして、[スタイルの適用] をクリックします

    [自動スタイル] が選択された [設定] ダイアログ ボックス

オートフォーマットを使って、アウトラインを作成したデータの書式を設定することもできます。

  1. アウトライン記号 1 2 3プラス記号 (+) 、および マイナス が表示できない場合は、[ファイル> オプション>詳細設定] に移動し、[このワークシート] セクションの [表示オプション]で、[アウトラインが適用されている場合にアウトライン記号を表示する] チェック ボックスをオンにします。

  2. 1 2 3マイナスプラス記号 (+) アウトライン記号を使って、コピーしない詳細データを非表示にします。

    詳細については、「アウトラインの詳細データの表示と非表示を切り替える」を参照してください。

  3. 集計行の範囲を選択します。

  4. [ホーム] タブの [編集] グループで [検索と選択] をクリックし、[ジャンプ] をクリックします。

    [検索と選択] をクリックして、[ジャンプ] をクリックする

  5. [選択オプション] をクリックします。

  6. [可視セル] をクリックします。

  7. [OK] をクリックし、データをコピーします。

注: アウトラインを非表示または削除しても、データは削除されません。

アウトラインを非表示にする

  • [ファイル] >オプション>詳細] に移動し、[このワークシート]セクションの [表示オプション]で、[アウトラインが適用されている場合にアウトライン記号を表示する] チェック ボックスをオフにします。

アウトラインを削除する

  1. シートをクリックします。

  2. [データ] タブの [アウトライン] で、[グループ解除] をクリックし、[アウトラインのクリア] をクリックします。

    [グループ解除] ボタンの [アウトラインのクリア] をクリックする

    重要: 詳細データを非表示にしているときにアウトラインを削除すると、詳細行または詳細列が非表示のままになることがあります。 データを表示するには、まず、非表示の行または列に隣接して表示されている行番号または列見出しをドラッグして選択します。 次に、[ホーム] タブの [セル] で [書式] をクリックし、[非表示/再表示] をポイントして、[行の再表示] または [列の再表示] をクリックします。

合計やその合計のグラフのみを表示する、データの集計レポートを作成するとします。 この場合、一般に次の操作を行います。

  1. サマリー レポートを作成する

    1. データのアウトラインを作成します。

      詳細については、「行のアウトラインを作成する」または「列のアウトラインを作成する」をご覧ください。

    2. 次の行のアウトラインの例に示すように、アウトライン記号 1 2 3プラス記号 (+) 、および マイナス をクリックして、詳細を非表示にし、合計のみを表示します。

      合計行だけが表示されたアウトライン表示のリスト

    3. 詳細については、「アウトラインの詳細データの表示と非表示を切り替える」を参照してください。

  2. サマリー レポートのグラフを作成する

    1. グラフ化する集計データを選択します。

      たとえば、上の例に示すように、総計ではなく、相和と本太の合計のみをグラフ化するには、セル A1 ~ C19 を選ぶ必要があります。

    2. [グラフの挿入>おすすめ>クリックし、[すべてのグラフ] タブをクリックし、グラフの種類を選択します。

      [グラフの挿入] ダイアログ ボックス

      たとえば、[クラスター化された列] オプションを選んだ場合、グラフは次のようになります。

      小計データから作成したグラフ

      アウトライン表示されたデータ リストの詳細データの表示と非表示を切り替えると、対応するグラフに表示されるデータも切り替わります。

行と列をグループ化 (またはアウトライン) して、グループ化 Web 用 Excel。

注: 集計行または集計列は (SUM や SUBTOTAL などの関数を使用して) データに追加することができますが、 Web 用 Excelで集計行や集計列にスタイルを適用したり、位置を設定したりすることはできません。

行または列のアウトラインを作成する

Excel Online の行のアウトライン

Excel Online の列のアウトライン

Excel Online の行のアウトライン

  1. 最初の列にはラベルが含まれている。

  2. 詳細行とサマリー行がアウトラインでグループ化されます。

  3. 総計はアウトラインにグループ化されません。

Excel Online の列のアウトライン

  1. 最初の行にはラベルが含まれている。

  2. 詳細列と集計列はアウトラインでグループ化されます。

  3. 総計はアウトラインにグループ化されません。

  1. アウトラインを作成するデータの各列 (または行) に、最初の行 (または列) にラベルが含まれており、各列 (または行) に同様の事実情報が含まれており、範囲に空白の行または列が含まれている必要はありません。

  2. データ (集計行または集計列を含む) を選択します。

  3. [データ] タブの [アウトライン]グループで、[行またはグループ列>グループ化]クリックします

  4. 必要に応じて、入れ子になった内側のグループのアウトラインを作成する場合は、アウトラインが設定されたデータ範囲内の行または列を選択し、手順 3 を繰り返します。

  5. アウトラインに必要なすべてのレベルが作成されるまで、内側の行または列の選択とグループ化を続ける。

行または列のグループ化を解除する

  • グループ化を解除するには、行または列を選択し、[データ] タブの[アウトライン] グループで [グループ解除] をクリックし、[行のグループ解除] または [列のグループ解除] を選択します。

アウトラインの詳細データの表示と非表示を切り替える

次の操作のいずれか、または複数の操作を行います。

グループの詳細データを表示または非表示にする    

  • グループ内の詳細データを表示するには、グループの プラス記号 (+) をクリックするか、Alt キーと Shift キーを押しながら = キー を押します

  • グループの詳細データを非表示にする場合は、グループの マイナス をクリックするか、Alt キーと Shift キーを押しながら - キー を押します

アウトライン全体の特定のレベルを表示または非表示にする    

  • アウトライン記号 1 2 3 、必要なレベルの番号をクリックします。 クリックした記号よりも下位レベルの詳細データは非表示になります。

  • たとえば、アウトラインに 4 つのレベルがある場合、 3 をクリックすると、4 番目のレベルを表示せずに、それより上のレベルの詳細データをすべて表示できます。

アウトラインの詳細データをすべて表示または非表示にする    

  • すべての詳細データを表示するには、 1 2 3 アウトライン記号の一番下のレベルをクリックします。 たとえば、3 つのレベルが設定されている場合は、 3 をクリックします。

  • すべての詳細データを非表示にするには、 1 をクリックします。

補足説明

Excel Tech Community では、いつでも専門家に質問できます。Microsoft コミュニティでは、サポートを受けられます。また、Excel User Voice では、新機能についての提案や改善案を送信することができます。

関連項目

ピボットテーブルでデータをグループ化またはグループ化解除する

ヘルプを表示

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×