新しいデータベースを作成する

新しいデータベースを作成する

この記事では、Web 上ではなく Access コンピューターで使用されるデータベースの作成を開始し、作成する基本的なプロセスについて説明します。 テンプレートを使用してデスクトップ データベースを作成する方法、および独自のテーブル、フォーム、レポート、その他のデータベース オブジェクトを作成してデータベースを最初から作成する方法について説明します。 また、既存のデータを新しいデータベースに取り込む方法について説明します。

この記事の内容

概要

Access を初めて起動した場合、または Access を閉じずにデータベースを閉じると、Backstage Microsoft Officeが表示されます。

Backstage ビューは、新しいデータベースの作成、既存のデータベースの開き方、 Office.com の主なコンテンツの表示を行う開始点です。Access を使用してデータベース内ではなく、データベース ファイルまたはデータベースの外部に対して実行できるあらゆる操作を行います。

データベースを作成する

Access を開き、Backstage ビューに [新規] タブ が表示 されます。 [ 新規] タブには、新しいデータベースを作成する方法がいくつかあります。

  • 空のデータベース    必要な場合は、最初から開始できます。 これは、非常に具体的な設計要件がある場合や、対応または組み込む必要がある既存のデータがある場合に便利です。

  • Access と一緒にインストールされているテンプレート    新しいプロジェクトを開始する場合は、テンプレートの使用を検討してください。 Access には、既定で複数のテンプレートがインストールされています。

  • テンプレートの Office.com    Access に含むテンプレートに加えて、他にも多くのテンプレート Office.com。 ブラウザーを開く必要もなくても、テンプレートは [新規] タブから 利用 できます。

データベースへの追加

データベースで作業すると、フィールド、テーブル、またはアプリケーション パーツを追加できます。

アプリケーション パーツは、関連する複数のデータベース オブジェクトを 1 つのデータベース オブジェクトと同じ方法で使用できる機能です。 たとえば、アプリケーション パーツがテーブルとテーブルに基づくフォームで構成されている場合があります。 アプリケーション パーツを使用して、テーブルとフォームを同時に追加できます。

また、クエリ、フォーム、レポート、マクロ (作業に使用しているすべてのデータベース オブジェクト) を作成することもできます。

テンプレートを使用してデータベースを作成する

Access には、さまざまなテンプレートが付属しています。このテンプレートは、現在の方法でも、開始点として使用することもできます。 テンプレートは、特定のタスクを実行するために必要なすべてのテーブル、クエリ、フォーム、マクロ、レポートを含む、すぐに使用できるデータベースです。 たとえば、問題の追跡、連絡先の管理、経費の記録に使用できるテンプレートがあります。 一部のテンプレートには、使用例を示すサンプル レコードがいくつか含まれます。

これらのテンプレートの 1 つがニーズに合っている場合は、通常、データベースを使用する最も迅速な方法です。 ただし、Access にインポートする別のプログラムのデータがある場合は、テンプレートを使用せずにデータベースを作成する方が良い場合があります。 テンプレートには既に定義されたデータ構造が含まれており、既存のデータをテンプレートの構造に合わせるには多くの作業が必要になる場合があります。

  1. データベースを開いている場合は、[ファイル]タブの [閉じる] をクリックします。 Backstage ビューに [新規] タブが表示 されます。

  2. いくつかのテンプレート セットが [新規] タブ 表示され、その一部は Access に組み込わっています。 他のテンプレートは、他のテンプレートから Office.com。 詳細については、この記事の次のセクションを参照してください。

  3. 使用するテンプレートを選択します。

  4. Access では、[ファイル名] ボックスにデータベースのファイル名が提案されます。必要に応じ、ファイル名を変更できます。 ファイル名ボックスの下に表示されているフォルダーとは異なるフォルダーにデータベースを保存するには、[ 代替テキスト ] をクリックし、保存するフォルダーを参照して 、[OK]をクリックします。 必要に応じて、データベースを作成して SharePoint サイトにリンクできます。

  5. [作成] をクリックします。

    選択したテンプレートからデータベースが作成され、そのデータベースが開きます。 多くのテンプレートでは、データの入力を開始できるフォームが表示されます。 テンプレートにサンプル データが含まれている場合は、レコード セレクター (レコードの左側にある網掛けボックスまたはバー) をクリックして、次の手順を実行して、各レコードを削除できます。

    [ホーム] タブの [レコード] グループで、[削除] をクリックします。 ボタンの画像

  6. データの入力を開始するには、フォームの最初の空のセルをクリックし、入力を開始します。 このオプション ナビゲーション ウィンドウ 使用して、使用する可能性がある他のフォームまたはレポートを参照します。 一部のテンプレートには、さまざまなデータベース オブジェクト間を移動できるナビゲーション フォームが含まれています。

テンプレートの操作の詳細については、「テンプレートを使用して Access デスクトップ データベースを作成する 」を参照してください

ページの先頭へ

テンプレートを使用せずにデータベースを作成する

テンプレートの使用に関心がない場合は、独自のテーブル、フォーム、レポート、その他のデータベース オブジェクトを作成してデータベースを作成できます。 ほとんどの場合、これには次の 1 つまたは両方が含まれます。

  • 新しいデータベースを作成するときに作成されたテーブルにデータを入力、貼り付け、またはインポートし、[作成] タブの [テーブル] コマンドを使用して作成した新しいテーブルでプロセスを繰り返します。

  • 他のソースからデータをインポートし、プロセスで新しいテーブルを作成します。

空のデータベースを作成する

  1. [ファイル] タブの [新規] を クリックし、[空のデータベース ] をクリックします

  2. [ファイル名] ボックスにファイル 名を入力 します。 ファイルの場所を既定から変更するには、[参照] をクリックしてデータベースを保存する場所 代替テキスト ([ファイル名] ボックスの横) をクリックし、新しい場所を参照し、[OK]をクリックします。

  3. [作成] をクリックします。

    Access は Table1 という名前の空のテーブルでデータベースを作成し、データシート ビューで Table1 を開きます。 カーソルは、[クリックして追加] 列の最初の 空のセルに配置 されます。

  4. 入力を開始してデータを追加するか、別のソースのデータを貼り付けます (「別のソースから Access テーブルにデータをコピーする」セクションの説明に 従います)。

データシート ビューでのデータの入力は、Excel ワークシートでの作業と非常に似たデザインです。 データを入力すると、テーブル構造が作成されます。 データシートに新しい列を追加すると、テーブルに新しいフィールドが定義されます。 入力したデータに基づいて、各フィールドのデータ型が自動的に設定されます。

この時点でテーブル 1 にデータを入力しない場合は、[閉じる] をクリック ボタンの画像 。 テーブルに変更を加えた場合は、変更を保存するように求めるメッセージが表示されます。 [はい] をクリックして変更を保存し、[いいえ]をクリックして破棄するか、[キャンセル] をクリックしてテーブルを開いたままにします。

ヒント:  Access は、[install drive]:\Program Files\Microsoft Office\Templates\1033\Access\ にあるフォルダーで Blank.accdb という名前のファイルを検索します。 Blank.accdb が存在する場合は、すべての新しい空白データベースのテンプレートです。 含まれるすべてのコンテンツは、新しい空白のデータベースすべてから継承されます。 これは、部品番号や会社の免責事項やポリシーなど、既定のコンテンツを配布する場合に便利です。

重要: Table1 を少なくとも 1 回保存せずに閉じると、データを入力した場合でも、テーブル全体が削除されます。

表を追加する

[作成] タブの [テーブル] グループのコマンドを使用して、既存のデータベース に新しい テーブルを 追加 できます。

Access のリボンの画像

データシート ビューからテーブルを作成する    データシート ビューでは、データをすぐに入力して、Access でテーブル構造を構築できます。 フィールド名には数値 (Field1、Field2 など) が割り当て、入力したデータに基づいて各フィールドのデータ型が自動的に設定されます。

  1. [作成] タブの [テーブル] で、[テーブル] をクリックします。 ボタンの画像

    テーブルが作成され、[クリックして追加] 列の最初の 空のセルが選択 されます。

  2. [フィールド ] タブ の [追加& 、追加するフィールドの種類をクリックします。 必要な種類が表示できない場合は、[その他のフィールド] タブ ボタンの画像

  3. 一般的に使用されるフィールドの種類の一覧が表示されます。 必要なフィールドの種類をクリックすると、挿入ポイントでデータシートに新しいフィールドが追加されます。

    フィールドをドラッグして移動できます。 データシート内のフィールドをドラッグすると、フィールドが配置される場所に垂直の挿入バーが表示されます。

  4. データを追加するには、最初の空のセルに入力を開始するか、別のソースのデータを貼り付けます (「Access テーブルに別のソースからデータをコピーする」セクションを 参照してください)。

  5. 列 (フィールド) の名前を変更するには、列見出しをダブルクリックし、新しい名前を入力します。

    各フィールドにわかりやすい名前を付け、フィールド リスト ウィンドウに表示されたフィールドの名前が 分かっている 必要があります。

  6. 列を移動するには、見出しをクリックして列を選択し、目的の場所に列をドラッグします。 連続する複数の列を選び、新しい場所に一度にドラッグすることもできます。 連続する複数の列を選択するには、最初の列の列見出しをクリックし、Shift キーを押しながら最後の列の列見出しをクリックします。

デザイン ビューからテーブルを作成する    デザイン ビューでは、最初にテーブル構造を作成します。 次に、データシート ビューに切り替えてデータを入力するか、貼り付けやインポートなどの他の方法でデータを入力します。

  1. [作成] タブで、[テーブル] グループの [テーブル デザイン] をクリックします。 ボタンの画像

  2. テーブルのフィールドごとに、[フィールド名] 列に名前を入力し、[データ型] リストからデータ型を選択します。

  3. 必要に合った場合は、[説明] 列に各フィールドの説明を 入力 できます。 カーソルがデータシート ビューのそのフィールドにある場合、説明がステータス バーに表示されます。 説明は、[フィールド リスト] ウィンドウからフィールドをドラッグして作成したフォームまたはレポート内のコントロールのステータス バー テキストや、フォーム ウィザードまたはレポート ウィザードを使用するときにそのフィールドに対して作成されるコントロールのステータス バー テキストにも使用されます。

  4. すべてのフィールドを追加した後、テーブルを保存します。

    • [ファイル] タブで [保存] をクリックします。

  5. データシート ビューに切り替え、最初の空のセルをクリックすると、いつでもテーブルにデータの入力を開始できます。 「Access テーブルに別のソースからデータをコピーする」セクションの説明に従って、別のソースのデータ を貼り付けもできます

フィールドのプロパティをデザイン ビューで設定する    テーブルの作成方法に関係なく、フィールド プロパティを調べて設定すると便利です。 データシート ビューでは一部のプロパティを使用できます。一部のプロパティはデザイン ビューでのみ設定できます。 デザイン ビューに切り替える場合は、ナビゲーション ウィンドウでテーブルを右クリックし、[デザイン ビュー] を クリックします。 フィールドのプロパティを表示するには、デザイン グリッドのフィールドをクリックします。 プロパティはデザイン グリッドの下の [フィールド プロパティ] に 表示されます

各フィールド プロパティの説明を表示するには、プロパティをクリックし、[フィールド プロパティ] のプロパティ リストの横にあるボックスの説明を 読み上けます。 [ヘルプ] ボタンをクリックすると、詳細な情報を取得できます。

次の表では、一般的に調整されるフィールド プロパティの一部について説明します。

プロパティ

説明

フィールド サイズ

テキスト フィールドの場合、このプロパティはフィールドに格納できる最大文字数を設定します。 最大値は 255 です。 数値フィールドの場合、このプロパティは格納される数値の種類 (長整数型、倍数型など) を設定します。 最も効率的なデータ ストレージを使用するには、データに必要と思う領域を少なくとも割り当てる必要があります。 ニーズが変わる場合は、後で値を上方向に調整できます。

書式設定

このプロパティは、データの表示方法を設定します。 フィールドに格納されている実際のデータには影響を与えされません。 定義済みの書式を選択するか、ユーザー設定の書式を入力できます。

定型入力

このプロパティを使用して、このフィールドに入力されるすべてのデータのパターンを指定します。 これにより、すべてのデータが正しく入力され、必要な文字数が入力されます。 入力マスクの作成に関するヘルプが必要な場合 [ビルダー] ボタン ボックスの右側にあるフィールドをクリックします。

既定値

このプロパティを使用して、新しいレコードが追加されるごとにこのフィールドに表示される既定値を指定します。 たとえば、レコードが追加された日付を常に記録する日付/時刻フィールドがある場合、既定値として "Date()" (引用符なし) を入力できます。

必須

このプロパティは、このフィールドに値が必要かどうかを設定します。 このプロパティを [はい] に設定した場合、このフィールドに値を入力しない限り、Access では新しいレコードの追加は許可されません。

ページの先頭へ

別のソースから Access テーブルにデータをコピーする

データが現在 Excel などの別のプログラムに保存されている場合は、データをコピーして Access のテーブルに貼り付けます。 一般に、これは、データが Excel ワークシートと同じ列に既に分割されている場合に最適です。 データがワード プロセス プログラム内にある場合は、タブを使用してデータの列を分離するか、またはデータをコピーする前に、ワード プロセス プログラムでデータを表に変換します。 データの編集や操作が必要な場合 (たとえば、フル ネームを名と名に分割する場合)、特に Access に慣れている場合は、データをコピーする前に、この操作を行います。

空のテーブルにデータを貼り付ける場合、各フィールドのデータ型は、検索されるデータの種類に応じて設定されます。 たとえば、貼り付けフィールドに日付値以外の値が含まれている場合、Access はそのフィールドに日付/時刻データ型を適用します。 貼り付けフィールドに "yes" と "no" の単語だけが含まれている場合、フィールドには Yes/No データ型が適用されます。

貼り付けデータの最初の行で見つけた内容に応じて、フィールドに名前が付けされます。 貼り付け先のデータの最初の行が次の行と型が似ている場合、Access は最初の行がデータの一部として判断され、フィールドに汎用名 (F1、F2 など) が割り当てされます。 貼り付けデータの最初の行が、その後の行と類似していない場合は、最初の行がフィールド名で構成されます。 Access では、フィールドに名前が付け、データの最初の行は含まれます。

Access で汎用フィールド名が割り当てらされている場合は、混乱を避けるために、できるだけ早くフィールドの名前を変更する必要があります。 次の手順で行います。

  1. Ctrl キーを押しながら S キーを押して、テーブルを保存します。

  2. データシート ビューで、各列見出しをダブルクリックし、各列のわかりやすいフィールド名を入力します。

  3. もう一度テーブルを保存します。

注: また、デザイン ビューに切り替えて、フィールド名を編集することで、フィールドの名前を変更することもできます。 デザイン ビューに切り替える場合は、ナビゲーション ウィンドウでテーブルを右クリックし、[デザイン ビュー] をクリックします。 データシート ビューに切り替える場合は、ナビゲーション ウィンドウでテーブルをダブルクリックします。

ページの先頭へ

別のソースからデータをインポート、追加、またはリンクする

データが別のプログラムに保存されている場合は、そのデータを新しいテーブルにインポートするか、Access の既存のテーブルに追加します。 または、他のプログラムでデータを保持しているユーザーと一緒に作業し、Access でデータにリンクして作業したい場合があります。 いずれの場合も、Access を使用すると、他のソースからのデータを簡単に操作できます。 Excel ワークシート、別の Access データベースのテーブル、SharePoint リスト、または他のさまざまなソースからデータをインポートできます。 使用するプロセスはソースによって若干異なりますが、次の手順を実行します。

  1. Access の [外部データ] タブの [&リンク] グループで、インポートするファイルの種類のコマンドをクリックします。

    [外部データ] タブの [インポートとリンク] グループ

    たとえば、Excel ワークシートからデータをインポートする場合は、[Excel] をクリック します。 必要なプログラムの種類が表示された場合は、[その他] をクリック します

    注: [& リンクのインポート] グループに正しい形式の種類が見当たらない場合は、データを Access にインポートする前に、最初にデータを作成したプログラムを起動し、そのプログラムを使用して一般的なファイル形式 ( 区切りテキスト ファイルなど) でデータを保存する必要があります。

  2. [外部データの取り込み]ダイアログ ボックスで、[参照] をクリックしてソース データ ファイルを見つけるか、[ファイル名] ボックスにソース データ ファイルの完全なパスを入力します。

  3. [現在のデータベースにデータを格納する方法と場所を指定する] で、必要なオプション (すべてのプログラムでインポートできるオプションと、追加またはリンクできるプログラム) を クリックします。 インポートしたデータを使用する新しいテーブルを作成したり、(一部のプログラムで) 既存のテーブルにデータを追加したり、ソース プログラムのデータへのリンクを保持するリンク テーブルを作成することができます。

  4. ウィザードが起動した場合は、ウィザードの次の数ページの指示に従います。 ウィザードの最後のページで、[完了] をクリックします。

    Access データベースからオブジェクトをインポートするか、テーブルをリンクすると、[オブジェクトのインポート] または [テーブルのリンク] ダイアログ ボックスが表示されます。 必要なアイテムを選び 、[OK]をクリックします。

    正確なプロセスは、データのインポート、追加、またはリンクを選択するかどうかによって異なります。

  5. 完了したインポート操作の詳細を保存するかどうかを確認するメッセージが表示されます。 今後、この同じインポート操作を再度実行すると思う場合は、[インポート手順の保存] をクリックし、詳細を入力します。 その後、[外部データ] タブの [インポートとリンク] グループの [ ボタンの画像 インポート] &をクリックすると、後で操作を簡単に繰り返す可能性があります。 操作の詳細を保存しない場合は、[閉じる] をクリック します

テーブルのインポートを選択した場合は、データが新しいテーブルにインポートされ、ナビゲーション ウィンドウの [テーブル] グループの下にテーブルが表示されます。 既存のテーブルにデータを追加することを選択した場合、そのテーブルにデータが追加されます。 データへのリンクを選んだ場合は、ナビゲーション ウィンドウの [テーブル] グループの下にリンク テーブルが作成されます。

ページの先頭へ

アプリケーション パーツを追加する

アプリケーション パーツを使用して、既存のデータベースに機能を追加できます。 アプリケーション パーツは、1 つのテーブルのようにシンプルにしたり、テーブルやバインドされたフォームなど、複数の関連オブジェクトで構成することもできます。

たとえば、コメント アプリケーションパーツは、オートナンバー ID フィールド、日付フィールド、メモ フィールドを含むテーブルで構成されます。 任意のデータベースに追加して、この方法で、または最小限のカスタマイズで使用できます。

  1. アプリケーション パーツを追加するデータベースを開きます。

  2. [作成] タブをクリックします。

  3. [テンプレート ] グループで 、[アプリケーション パーツ] をクリックします。 使用可能なパーツの一覧が開きます。

  4. 追加するアプリケーション パーツをクリックします。

ページの先頭へ

既存の Access データベースを開く

  1. [ファイル] タブの [開く] をクリックします。

  2. [開 ] ダイアログ ボックスで、開くデータベースを参照します。

  3. 次の操作のいずれかを行います。

    • データベースをダブルクリックして 、[Access のオプション] ダイアログ ボックスで指定された既定のモード、または管理ポリシーによって設定されたモードで開きます。

    • [ 開く ] をクリックして、ユーザーと他のユーザーがデータベースを読み書きできるよう、マルチユーザー環境で共有アクセス用のデータベースを開きます。

    • [開く] ボタンの横にある矢印をクリックし、[読み取り専用で開く] をクリックして、読み取り専用アクセス用にデータベースを開き、表示はできますが編集はできません。 他のユーザーは、引き続きデータベースの読み取りおよび書き込みを行います。

    • [開く] ボタンの横にある矢印をクリックし、[排他で開く] をクリックして排他アクセスを使用してデータベースを開きます。 排他的アクセス権を持つデータベースを開いている場合、そのデータベースを開もうとすると、"ファイルが既に使用されています" というメッセージが表示されます。

    • [開く] ボタンの横にある矢印をクリックし、[排他読み取り専用で開く] をクリックして、読み取り専用アクセス用にデータベースを開きます。 他のユーザーは引き続きデータベースを開くことができますが、読み取り専用モードに制限されています。

注: データ ファイルは、dBASE、Microsoft Exchange、Excel などの外部ファイル形式で直接開きます。 また、任意のファイル ( ODBC データ ソースなど) を直接Microsoft SQL Server。 Access では、データ ファイルと同じフォルダーに新しい Access データベースが自動的に作成され、外部データベースの各テーブルへのリンクが追加されます。

ヒント

  • 最近開いたデータベースのいずれかを開く場合は、[ファイル]タブで [最近使ったファイル] をクリックし、そのデータベースのファイル名をクリックします。 Access では、前回開いたのと同じオプション設定を使用してデータベースが開きます。 最近使用したファイルの一覧が表示されない場合は、[ファイル] タブの [オプション] をクリックします。 [Access の オプション] ダイアログ ボックス で、[クライアント設定] をクリックします。 [ 表示]で、[最近使ったドキュメント] リストに表示するドキュメントの数を入力します (最大 50 件まで)。

    Backstage ビューのナビゲーション バーに最近使用したデータベースを表示して、2 回クリックしてアクセスすることもできます。1) [ファイル] タブ、2) 最近開くデータベース。 [最近使ったファイル] タブの下部で、[最近使用したデータベースのこの数にすばやくアクセスする] チェック ボックスをオンにし、表示するデータベースの数を調整します。

  • [ファイル] タブの [開く] コマンドをクリックしてデータベースを開く場合は、[開く] ダイアログ ボックスで [最近使ったドキュメント] をクリックすると、以前に開いたデータベースへのショートカットの一覧を表示できます。

ページの先頭へ

ヘルプを表示

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×