リバース エンジニアリング ウィザードでは、既存のデータベースまたはブックからデータベース モデルを Excel できます。 データベース モデルはデータベースの構造をグラフィカルに表示し、テーブルやビューなどのデータベース要素が実際のデータを表示せずに互いを関連付ける方法を確認できます。 これにより、新しいデータベースの作成や既存のデータベースの構造の理解が効率化されます。

データベース モデル図テンプレートを使用すると、既存のデータベースからデータベース モデルを作成できます。 このテンプレートは 、Visio プラン 2 または Visio ライセンスをお持ちのお客様の Visio 2019 アプリで使用できます。 ご利用中の Visio のバージョンは、[ファイル]、[アカウント]、[Visio のバージョン情報] の順にクリックすると確認できます。

リバース エンジニアリング ウィザードで抽出されるものを確認する

ウィザードで抽出できるスキーマ定義情報は、データベース管理システム (DBMS) と ODBC ドライバーの機能など、複数の要素の組み合わせによって異なります。 ウィザードには、抽出できるすべての要素が表示され、必要な要素を選択できます。 たとえば、関心があるテーブルは 10 テーブル中 5 つ、ビューは 4 つ中 2 つのみです。

ウィザードの実行中、リバース エンジニアリングしたアイテムを [テーブルとビュー] ウィンドウに一覧表示する以外に、図を自動的に作成するように選択できます。 図を自動作成しない場合、[テーブルとビュー] ウィンドウからアイテムをドラッグし、データベース モデルを手動で組み立てることができます。

ターゲット DBMS から利用できる範囲内で、次のアイテムを抽出できます。

  • テーブル

  • ビュー

  • 主キー

  • 外部キー

  • インデックス

  • トリガー (コードを含む)

  • チェック句 (コードを含む)

  • ストアド プロシージャ (コードを含む)

ウィザードを開始する準備を行う

Excel ブックのリバース エンジニアリングを行う場合は、ウィザードを開始する前にブックを開き、列見出しを含むセルのグループ (または範囲) に名前を付必要があります。 複数のワークシートを使用する場合、各ワークシートの列セルのグループに名前を付けるだけです。 ウィザードでは、この範囲がテーブルとして扱われます。 セル範囲に名前を付ける方法の詳細については、次のヘルプ Excel してください。

最良の結果を得るために、リバース ​​エンジニアリング ウィザードを実行する前にリバース エンジニアリングを行うターゲット データベースに既定のドライバーを設定してください。 これにより、ウィザードでネイティブ データ型が正しくマッピングされ、ウィザードによって抽出されたコードが [コード] ウィンドウに正しく表示されます。

  1. [ファイル] タブをクリックし、[新規作成] をクリックし、[テンプレート] をクリックし、[ソフトウェアとデータベース] をクリックし、[データベース モデル図] をダブルクリックします。

  2. [データベース] タブの [管理] グループで [データベース ドライバー] をクリックします。

  3. [ドライバー ] タブ で、VISIO が提供する DBMS ドライバーを選択します。 たとえば、Access データベースを設計する場合は、Microsoft Access を選ぶとします。

    Excel ワークシートのリバース エンジニアリングを行っている場合は、ODBC 汎用ドライバーを選択します。

  4. [セットアップ] をクリックします。

  5. [ODBC ドライバー]タブで、ベンダーが提供する DBMA ドライバーのチェック ボックスをオンにします。 たとえば、Access データベースを設計する場合は 、Microsoft Access ドライバー (*.mdb、*.accdb) チェック ボックスをオンにします。

  6. 各ダイアログ ボックスで [OK] をクリックします。

ベンダー提供の 32 ビット ODBC ドライバーは、バージョン 2.0 より大きい ODBC データ アクセス パックと ODBC レベル 1 準拠以上である必要があります。 ベンダーが提供する OLE DB プロバイダーは、OLE DB バージョン 1.0 以降の仕様に準拠している必要があります。

既存のデータベースにリバース エンジニアリングを行う

  1. データベース モデル図の [データベース] タブで、[リバース ​​エンジニアリング] をクリックします。

  2. リバース エンジニアリング ウィザードの最初の画面で、次の操作を行います。

    1. ご利用中の DBMS (データベース管理システム) に合わせて Microsoft Visio データベース ドライバーを選択します。 Visio データベース ドライバーを特定の ODBC データ ソースにまだ関連付けていない場合、[セットアップ] をクリックし、関連付けてください。

      Excel ワークシートをリバース エンジニアリングしている場合、ODBC 汎用ドライバーを選択します。

    2. 更新するデータベースのデータ ソースを選択します。 既存のデータベースにデータ ソースをまだ作成していない場合、[新規作成] をクリックし、作成します。

      新しいソースを作成すると、その名前が [データ ソース] リストに追加されます。

    3. 設定に問題がなければ、[次へ] をクリックします。

    4. ドライバー固有のダイアログ ボックスがあれば、その指示に従います。 たとえば、[データ ソースに接続] ダイアログ ボックスにユーザー名とパスワードを入力し、[OK] をクリックします。 データ ソースがパスワード保護されていない場合、[OK] をクリックします。

  3. 抽出する情報の種類を選択し (チェック ボックスにチェックを入れる)、[次へ] をクリックします。

    ウィザードで抽出できる要素はシステムによって異なります。一部のアイテムが淡色表示されている場合があります。

  4. 抽出するテーブル (とビュー) のチェック ボックスを選択するか、すべて抽出する場合は [すべて選択] をクリックし、[次へ] をクリックします。

    Excel ワークシートのリバース エンジニアリングを行う場合に、このリストに何も表示されていない場合は、スプレッドシートの列見出しを含むセル範囲に名前を付けます。

  5. 手順 3で [ストアド プロシージャ] チェック ボックスをオンにした場合は、抽出するプロシージャを選択するか、[すべて選択] をクリックしてすべてのプロシージャを抽出し、[次へ] をクリックします。

  6. リバース エンジニアリングしたアイテムを現在のページに自動追加するかどうか選択します。

    ウィザードでは、リバース エンジニアリングしたアイテムを [テーブルとビュー] ウィンドウに一覧表示する以外に、図を自動的に作成するように選択できます。 図を自動作成しない場合、[テーブルとビュー] ウィンドウからアイテムをドラッグし、データベース モデルを手動で組み立てることができます。

  7. 選択内容を見直し、必要な情報が抽出されることを確認し、[完了] をクリックします。

ODBC 汎用ドライバーを使用すると、リバース エンジニアリングされた情報が不完全である可能性を示すエラーが表示される場合があります。 ほとんどの場合、これは問題ではありません 。[OK] をクリックしてウィザードを続行します。

ウィザードは選択した情報を抽出し、抽出プロセスに関する注意を [出力] ウィンドウに表示します。

データベース モデル図テンプレートを使用すると、既存のデータベースからデータベース モデルを作成できます。 このテンプレートは、Visio plan 2 または Visio ライセンスをお持ちのお客様の Visio 2019 アプリでVisio 2019できます。 ご利用中の Visio のバージョンは、[ファイル]、[アカウント]、[Visio のバージョン情報] の順にクリックすると確認できます。

リバース エンジニアリング ウィザードで抽出されるものを確認する

ウィザードで抽出できるスキーマ定義情報は、データベース管理システム (DBMS) と ODBC ドライバーの機能などの組み合わせによって異なります。 ウィザードには、抽出できるすべての要素が表示され、必要な要素を選択できます。 たとえば、関心があるテーブルは 10 テーブル中 5 つ、ビューは 4 つ中 2 つのみです。

ウィザードの実行中、リバース エンジニアリングしたアイテムを [テーブルとビュー] ウィンドウに一覧表示する以外に、図を自動的に作成するように選択できます。 図を自動作成しない場合、[テーブルとビュー] ウィンドウからアイテムをドラッグし、データベース モデルを手動で組み立てることができます。

ターゲット DBMS から利用できる範囲内で、次のアイテムを抽出できます。

  • テーブル

  • ビュー

  • 主キー

  • 外部キー

  • インデックス

  • トリガー (コードを含む)

  • チェック句 (コードを含む)

  • ストアド プロシージャ (コードを含む)

ウィザードを開始する準備を行う

Excel ブックをリバース エンジニアリングする場合、ウィザードを開始する前に、ブックを開き、列見出しを含むセルのグループ (または範囲) に名前を付ける必要があります。 複数のワークシートを使用する場合、各ワークシートの列セルのグループに名前を付けます。 ウィザードでは、この範囲がテーブルとして扱われます。 セル範囲に名前を付ける方法の詳細については、次のヘルプ Excel してください。

最良の結果を得るために、リバース ​​エンジニアリング ウィザードを実行する前にリバース エンジニアリングを行うターゲット データベースに既定のドライバーを設定してください。 これにより、ウィザードでネイティブ データ型が正しくマッピングされ、ウィザードによって抽出されたコードはすべて [コード] ウィンドウに正しく表示されます。

  1. [ファイル] タブをクリックし、[新規作成] をクリックし、[テンプレート] をクリックし、[ソフトウェアとデータベース] をクリックし、[データベース モデル図] をダブルクリックします。

  2. [データベース] タブの [管理] グループで [データベース ドライバー] をクリックします。

  3. [ドライバー ] タブ で、VISIO が提供する DBMS ドライバーを選択します。 たとえば、Access データベースを設計する場合は、Microsoft Access を選ぶとします。

    Excel ワークシートをリバース エンジニアリングしている場合、ODBC 汎用ドライバーを選択します。

  4. [セットアップ] をクリックします。

  5. [ODBC ドライバー]タブで、ベンダーが提供する DBMA ドライバーのチェック ボックスをオンにします。 たとえば、Access データベースを設計する場合は 、Microsoft Access ドライバー (*.mdb、*.accdb) チェック ボックスをオンにします。

  6. 各ダイアログ ボックスで [OK] をクリックします。

ベンダー提供の 32 ビット ODBC ドライバーは、バージョン 2.0 より大きい ODBC データ アクセス パックと ODBC レベル 1 準拠以上である必要があります。 ベンダーが提供する OLE DB プロバイダーは、OLE DB バージョン 1.0 以降の仕様に準拠している必要があります。

既存のデータベースにリバース エンジニアリングを行う

  1. データベース モデル図の [データベース] タブで、[リバース ​​エンジニアリング] をクリックします。

  2. リバース エンジニアリング ウィザードの最初の画面で、次の操作を行います。

    1. ご利用中の DBMS (データベース管理システム) に合わせて Microsoft Visio データベース ドライバーを選択します。 Visio データベース ドライバーを特定の ODBC データ ソースにまだ関連付けていない場合、[セットアップ] をクリックし、関連付けてください。

      Excel ワークシートをリバース エンジニアリングしている場合、ODBC 汎用ドライバーを選択します。

    2. 更新するデータベースのデータ ソースを選択します。 既存のデータベースにデータ ソースをまだ作成していない場合、[新規作成] をクリックし、作成します。

      新しいソースを作成すると、その名前が [データ ソース] リストに追加されます。

    3. 設定に問題がなければ、[次へ] をクリックします。

    4. ドライバー固有のダイアログ ボックスがあれば、その指示に従います。 たとえば、[データ ソースに接続] ダイアログ ボックスにユーザー名とパスワードを入力し、[OK] をクリックします。 データ ソースがパスワード保護されていない場合、[OK] をクリックします。

  3. 抽出する情報の種類を選択し (チェック ボックスにチェックを入れる)、[次へ] をクリックします。

    ウィザードで抽出できる要素はシステムによって異なります。一部のアイテムが淡色表示されている場合があります。

  4. 抽出するテーブル (とビュー) のチェック ボックスを選択するか、すべて抽出する場合は [すべて選択] をクリックし、[次へ] をクリックします。

    Excel ワークシートをリバース エンジニアリングするとき、この一覧に何も表示されない場合、おそらく、スプレッドシートの列見出しを含むセル範囲に名前を付ける必要があります。

  5. 手順 3で [ストアド プロシージャ] チェック ボックスをオンにした場合は、抽出するプロシージャを選択するか、[すべて選択] をクリックしてすべてのプロシージャを抽出し、[次へ] をクリックします。

  6. リバース エンジニアリングしたアイテムを現在のページに自動追加するかどうか選択します。

    ウィザードでは、リバース エンジニアリングしたアイテムを [テーブルとビュー] ウィンドウに一覧表示する以外に、図を自動的に作成するように選択できます。 図を自動作成しない場合、[テーブルとビュー] ウィンドウからアイテムをドラッグし、データベース モデルを手動で組み立てることができます。

  7. 選択内容を見直し、必要な情報が抽出されることを確認し、[完了] をクリックします。

ODBC 汎用ドライバーを使用すると、リバース エンジニアリングされた情報が不完全である可能性を示すエラーが表示される場合があります。 ほとんどの場合、これは問題ではありません 。[OK] をクリックしてウィザードを続行します。

ウィザードは選択した情報を抽出し、抽出プロセスに関する注意を [出力] ウィンドウに表示します。

Visio 2016 2013 ではリバース エンジニアリング ウィザードがサポートされていません

申し訳ございません。 リバース エンジニアリング ウィザードは、Visio Professional 2016、Visio Standard 2016、Visio Professional 2013、または Visio Standard 2013 では使用できません。 データベース モデリング機能を使用するには、データベース モデリング機能への Visio Plan 2。

新しいバージョンを取得https://www.microsoft.com/microsoft-365/visio/visio-plan-2?ocid=oo_support_mix_marvel_ups_support_smcvisio_inline

この記事の内容

リバース エンジニアリング ウィザードで抽出されるものを確認する

ウィザードで抽出できるスキーマ定義情報は、データベース管理システム (DBMS) と ODBC ドライバーの機能など、複数の要素の組み合わせによって異なります。 ウィザードには、抽出できるすべての要素が表示され、必要な要素を選択できます。 たとえば、関心があるテーブルは 10 テーブル中 5 つ、ビューは 4 つ中 2 つのみです。

ウィザードの実行中、リバース エンジニアリングしたアイテムを [テーブルとビュー] ウィンドウに一覧表示する以外に、図を自動的に作成するように選択できます。 図を自動作成しない場合、[テーブルとビュー] ウィンドウからアイテムをドラッグし、データベース モデルを手動で組み立てることができます。

ターゲット DBMS から利用できる範囲内で、次のアイテムを抽出できます。

  • テーブル

  • ビュー

  • 主キー

  • 外部キー

  • インデックス

  • トリガー (コードを含む)

  • チェック句 (コードを含む)

  • ストアド プロシージャ (コードを含む)

ページの先頭へ

ウィザードを開始する準備を行う

Excel ブックをリバース エンジニアリングする場合、ウィザードを開始する前に、ブックを開き、列見出しを含むセルのグループ (または範囲) に名前を付ける必要があります。 複数のワークシートを使用する場合、各ワークシートの列セルのグループに名前を付けます。 ウィザードでは、この範囲がテーブルとして扱われます。 セル範囲に名前を付ける方法については、Microsoft Office Excel のヘルプをご覧ください。

最良の結果を得るために、リバース ​​エンジニアリング ウィザードを実行する前にリバース エンジニアリングを行うターゲット データベースに既定のドライバーを設定してください。 これにより、ウィザードでネイティブ データ型が正しくマッピングされ、ウィザードによって抽出されたコードはすべて [コード] ウィンドウに正しく表示されます。

  1. [ファイル] タブをクリックし、[新規作成] をクリックし、[ソフトウェアとデータベース] をクリックし、[データベース モデル図] をダブルクリックします。

  2. [データベース] タブの [管理] グループで [データベース ドライバー] をクリックします。

  3. [ドライバー ] タブ で、VISIO が提供する DBMS ドライバーを選択します。 たとえば、Access データベースを設計する場合は、Microsoft Access を選ぶとします。

    Excel ワークシートをリバース エンジニアリングしている場合、ODBC 汎用ドライバーを選択します。

  4. [セットアップ] をクリックします。

  5. [ODBC ドライバー]タブで、ベンダーが提供する DBMA ドライバーのチェック ボックスをオンにします。 たとえば、Access データベースを設計する場合は 、Microsoft Access ドライバー (*.mdb) チェック ボックスをオンにします。

  6. 各ダイアログ ボックスで [OK] をクリックします。

ベンダー提供の 32 ビット ODBC ドライバーは、バージョン 2.0 より大きい ODBC データ アクセス パックと ODBC レベル 1 準拠以上である必要があります。 ベンダーが提供する OLE DB プロバイダーは、OLE DB バージョン 1.0 以降の仕様に準拠している必要があります。

ページの先頭へ

既存のデータベースにリバース エンジニアリングを行う

  1. データベース モデル図の [データベース] タブで、[リバース ​​エンジニアリング] をクリックします。

  2. リバース エンジニアリング ウィザードの最初の画面で、次の操作を行います。

    1. ご利用中の DBMS (データベース管理システム) に合わせて Microsoft Visio データベース ドライバーを選択します。 Visio データベース ドライバーを特定の ODBC データ ソースにまだ関連付けていない場合、[セットアップ] をクリックし、関連付けてください。

      Excel ワークシートをリバース エンジニアリングしている場合、ODBC 汎用ドライバーを選択します。

    2. 更新するデータベースのデータ ソースを選択します。 既存のデータベースにデータ ソースをまだ作成していない場合、[新規作成] をクリックし、作成します。

      新しいソースを作成すると、その名前が [データ ソース] リストに追加されます。

    3. 設定に問題がなければ、[次へ] をクリックします。

    4. ドライバー固有のダイアログ ボックスがあれば、その指示に従います。 たとえば、[データ ソースに接続] ダイアログ ボックスにユーザー名とパスワードを入力し、[OK] をクリックします。 データ ソースがパスワード保護されていない場合、[OK] をクリックします。

  3. 抽出する情報の種類を選択し (チェック ボックスにチェックを入れる)、[次へ] をクリックします。

    ウィザードで抽出できる要素はシステムによって異なります。一部のアイテムが淡色表示されている場合があります。

  4. 抽出するテーブル (とビュー) のチェック ボックスを選択するか、すべて抽出する場合は [すべて選択] をクリックし、[次へ] をクリックします。

    Excel ワークシートをリバース エンジニアリングするとき、この一覧に何も表示されない場合、おそらく、スプレッドシートの列見出しを含むセル範囲に名前を付ける必要があります。

  5. 手順 3で [ストアド プロシージャ] チェック ボックスをオンにした場合は、抽出するプロシージャを選択するか、[すべて選択] をクリックしてすべてのプロシージャを抽出し、[次へ] をクリックします。

  6. リバース エンジニアリングしたアイテムを現在のページに自動追加するかどうか選択します。

    ウィザードでは、リバース エンジニアリングしたアイテムを [テーブルとビュー] ウィンドウに一覧表示する以外に、図を自動的に作成するように選択できます。 図を自動作成しない場合、[テーブルとビュー] ウィンドウからアイテムをドラッグし、データベース モデルを手動で組み立てることができます。

  7. 選択内容を見直し、必要な情報が抽出されることを確認し、[完了] をクリックします。

ODBC 汎用ドライバーを使用すると、リバース エンジニアリングされた情報が不完全である可能性を示すエラーが表示される場合があります。 ほとんどの場合、これは問題ではありません 。[OK] をクリックしてウィザードを続行します。

ウィザードは選択した情報を抽出し、抽出プロセスに関する注意を [出力] ウィンドウに表示します。

ページの先頭へ

ヘルプを表示

スキルを磨く
トレーニングの探索
新機能を最初に入手
Microsoft Insider に参加する

この情報は役に立ちましたか?

翻訳品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?

フィードバックをお送りいただきありがとうございます!

×