オートコンプリート リストは、入力を開始すると、名前とメール アドレスの候補を表示する機能です。 これらの候補は、送信したメール メッセージの名前とメール アドレスの一覧から一致する可能性があります。 

オートコンプリート リスト

コンピューター間でオートコンプリート リストをコピーする方法は、Outlook に追加したメール アカウントの種類によって異なります。 Microsoft 365 アカウント、Exchange Server アカウント、または IMAP アカウント (他のメール アカウントの最も一般的な種類) がある場合、オートコンプリート リストは Outlook データ ファイルに非表示のファイルとして保存されます。 手順 については、「オートコンプリート リストをコピーする」を参照してください。

POP3 アカウント (あまり一般的ではなく、Comcast、Earthlink、Verizon などのサード パーティのメール プロバイダーでよく使用される) を使用している場合、オートコンプリート リストはコンピューターに保存されているファイルに保存されます。 「.nk2 ファイルをコピーしてインポートする」を参照してください

使用しているアカウントの種類が分からない場合は、[アカウント設定]の [ファイル>を選択>選択します。 アカウントの種類はここで確認できます。

オートコンプリート リストをコピーする

手順 1: オートコンプリート メールボックス メッセージをエクスポートする

  1. Outlook を終了し、メールボックスに接続Outlook Web Appワークステーションで Outlook Web Access または OWA (OWA) を終了します。

  2. HTTP://MFCMAPI.CODEPLEX.COM からインストールします。

  3. 実行mfcmapi.exe。

  4. [セッション] メニューの [ログオン] を クリックします

  5. プロファイルの入力を求めるメッセージが表示されたら、目的のプロファイル名を選び 、[OK]をクリックします。

  6. 上部のウィンドウで、メールボックスに対応する行を見つけてダブルクリックします。

  7. 左側のナビゲーション ウィンドウで、[ルートコンテナー] を展開し、[情報ストアの上部] または [フォルダー] IPM_SUBTREE。

  8. [受信トレイ] フォルダーを 右クリックし 、[関連コンテンツ テーブルを開く ] をクリックします。 このアクションにより、さまざまなプロパティを含む新しい [DLLMAPI] ウィンドウが開きます。

  9. [件名 ] 列 で、件名を含むアイテムを右クリックIPM.Config します。オートコンプリートして、[メッセージのエクスポート] をクリックします。 このアクションにより、[メッセージを ファイルに保存] ウィンドウが開 きます。

  10. ドロップダウン リストで 、MSG ファイル (UNICODE) を選択し 、[OK]をクリックします。

  11. メッセージを保存するフォルダーの場所を選択し、[保存] をクリック します。 この場所に注意してください。

手順 2: オートコンプリート メールボックス メッセージをインポートする

  1. Outlook を終了し、メールボックスに接続Outlook Web Appワークステーションで Outlook Web Access または OWA (OWA) を終了します。

  2. HTTP://MFCMAPI.CODEPLEX.COM からインストールします。

  3. 次のmfcmapi.exe。

  4. [セッション] メニューの [ログオン] を クリックします

  5. プロファイルの入力を求めるメッセージが表示されたら、目的のプロファイル名を選び 、[OK]をクリックします。

  6. 上部のウィンドウで、メールボックスに対応する行を見つけてダブルクリックします。

  7. 左側のナビゲーション ウィンドウで、[ルートコンテナー] を展開し、[情報ストアの上部] または [フォルダー] IPM_SUBTREE。

  8. [受信トレイ] フォルダーを 右クリックし 、[関連コンテンツ テーブルを開く ] をクリックします。 このアクションにより、さまざまなプロパティを含む新しい [DLLMAPI] ウィンドウが開きます。

  9. エントリが重複しないようにするには、既存のオートコンプリート メッセージを削除する必要があります。

    注: 削除する前に、IPM.Configします。オートコンプリート メッセージの場合は、「オートコンプリート キャッシュをエクスポートする方法」セクションの手順に従ってメッセージをエクスポートする必要があります。

    既存のオートコンプリート メッセージを削除するには、次の手順を実行します。

    1. [件名 ] 列で、件名と uration が含 IPM.Configします。オートコンプリート.

    2. アイテムを右クリックし、[メッセージの削除] を クリックします。 [アイテムの削除] ウィンドウが開 きます。

    3. ドロップダウン リストで、[完全削除] (サポートされている場合は削除済みアイテムの保持に削除 )を選択し 、[OK]をクリックします。

  10. [フォルダー] メニューの [インポート] をクリックし、[MSG から] をクリックします。

  11. 上記の 「オートコンプリート メールボックス メッセージをエクスポートする」の手順 11 で作成した .msg ファイルを見つけ 、[OK]をクリックします。

  12. 表示される[MSG の読み込み] ウィンドウで、[読み込みスタイル] の一覧の [現在のフォルダーにメッセージを読み込む] を選び、[OK]をクリックします。

オートコンプリート情報は、オートコンプリートの url からIPM.Configされます。Autocomplete_<16 進数コード>.msg で、プレースホルダー<16 進数のコード> は、数字と文字の長い文字列を表します。

.nk2 ファイルをコピーしてインポートする

手順 1: 古いコンピューターからオートコンプリート ファイルをコピーする

  1. 既定のフォルダーは隠しフォルダーなので、フォルダーを開く最も簡単な方法は、[Windows Search]ボックスのコマンド %APPDATA%\Microsoft\Outlookを使用することです (または、C:\Users\ユーザー名 \AppData\Roaming\Microsoft\Outlook を参照します)。

  2. Outlook フォルダーで、オートコンプリート リスト (.nk2) ファイルを探します。

    注: 既定で、ファイル拡張子は Windows で表示されません。 ファイルの拡張子を表示するかどうかを変更するには、エクスプローラーの [ツール] メニュー (Windows 7 または Windows Vista の場合は、ALT キーを押して、[ツール] メニューを表示します) で、[フォルダー オプション] をクリックします。 [表示] タブで、[登録されている拡張子は表示しない] チェック ボックスをオンまたはオフにします。

  3. ファイルを新しいコンピューターにコピーします。 ファイルは小さく、USB メモリ スティックなどのリムーバブル メディアに配置できます。

手順 2: オートコンプリート ファイルを新しいコンピューターにコピーする

  1. 新しいコンピューターのコントロール パネルで、[メール] をクリックまたはダブルクリック します

    メールは、Microsoft Windows オペレーティング システムのバージョン、コントロール パネルの表示方法、32 ビット版と 64 ビット版のオペレーティング システムの違い、または Outlook 2010 のバージョンによって、コントロール パネルの場所が異なります。

    [メール] を見つけるには、Windows のコントロール パネルを開き、ウィンドウ上部の [検索] ボックスに「メール」と入力する方法が最も簡単です。 Windows XP のコントロール パネルでは、[アドレス] ボックスに「メール」と入力します。

    注: [メール] アイコンは、Outlook を初めて起動した後に表示されます。

  2. [Show Profiles] をクリックします。

  3. プロファイルの名前をメモします。 後で名前と一致する .nk2 ファイル名を変更する必要があります。

  4. .nk2 ファイルを、Outlook の構成が保存されているフォルダー内の新しいコンピューターにコピーします。 既定のフォルダーは隠しフォルダーなので、フォルダーを開く最も簡単な方法は、[Windows Search]ボックスのコマンド %APPDATA%\Microsoft\Outlookを使用することです (または、C:\Users\ユーザー名 \AppData\Roaming\Microsoft\Outlook を参照します)。

  5. ファイルをフォルダーにコピーした後、ファイルを右クリックし、[名前の変更] をクリックして、手順 3 で表示されたプロファイル名と一致する名前を変更します。

手順 3: オートコンプリート リストをインポートする

これで Outlook を起動してファイルをインポートする準備はできましたが、特別な 1 回のコマンドで Outlook を起動する必要があります。

  • Windows の [検索] ボックスに「outlook /importnk2」と入力し、Enter キーを押します。

オートコンプリート リストでは、メッセージを作成し、[To] ボックス、[CC]ボックス、または[BCC]ボックスに入力を開始するときに、他のコンピューターのエントリが表示されます。

ページの先頭へ

Outlook 2007 では、オートコンプリート リストの名前とメール アドレスをコンピューター間でコピーできます。 たとえば、新しいコンピューターにアップグレードし、オートコンプリート リストに保存されている情報を失わない場合は、古いコンピューターから新しいコンピューターに名前とメール アドレスをコピーできます。

重要: 次の手順を Microsoft Outlook 前に、この操作を終了する必要があります。 Outlook を再起動すると、オートコンプリート リストに名前が含まれます。

古いコンピューターからオートコンプリート ファイルをコピーする

  1. 古いコンピューターで、ドライブ名:\ユーザー\AppData\Local\Microsoft\Outlook に移動します。

    注: ファイルの設定によっては、このフォルダーが非表示になる場合があります。

  2. プロファイル名.nk2 を右クリックし、[コピー] を クリックします

    ヒント: USB メディア スティックなどのリムーバブル メディアにファイルをコピーし、新しいコンピューター上の正しい場所にファイルをコピーできます。 または、メール メッセージにファイルを添付して、自分にメッセージを送信することもできます。 新しいコンピューターで、Outlook で添付ファイルを開き、正しい場所に保存します。

  3. オートコンプリート リストを作成するコンピューターで、ドライブ名\ユーザー\AppData\Local\Microsoft\Outlook の任意の場所を右クリックし、[貼り付け] をクリックしてプロファイル名.nk2 を保存します。

  4. .nk2 ファイルを移動するコンピューターで Outlook ユーザー プロファイル名が異なる場合は、ファイルを正しいフォルダーにコピーした後、新しいコンピューターで使用されている Outlook ユーザー プロファイル名でファイルの名前を変更する必要があります。 たとえば、元のコンピューターから Kim Akers.nk2 を Outlook ユーザー プロファイル名の Kim Akers に移動し、Kim Akers.nk2 ファイルを新しいコンピューターにコピーする場合は、新しいコンピューターで使用されている Outlook プロファイル名でファイルの名前を変更する必要があります。

  5. 既存のファイルの置き換えについて確認するメッセージが表示されたら、[はい] を クリックします

  6. Outlook を開き、オートコンプリート リストの変更を表示します。

ページの先頭へ

ヘルプを表示

スキルを磨く
トレーニングの探索
新機能を最初に入手
Microsoft Insider に参加する

この情報は役に立ちましたか?

翻訳品質にどの程度満足していますか?

どのような要因がお客様の操作性に影響しましたか?

その他にご意見はありますか?(省略可能)

フィードバックをお送りいただきありがとうございます!

×