以前のバージョンの Excel と互換性がある Excel ブックを保存する

新しいバージョンの Excel にアップグレードしましたが、まだアップグレードしていないユーザーとブックを共有することになったとします。 互換性チェックを実行すると、以前のバージョンで利用できない機能や情報を識別できるため、ブックの共有前に、それらの問題の一部を解決できます。

.xls 形式でファイルを保存して、互換性チェックの問題を確認する

手順

  1. [ファイルの種類>エクスポート] >ファイルの種類の変更] をクリックします

    [エクスポート] タブの [ファイルの種類の変更]

  2. [エクスポート] タブの [ファイルの種類の変更]

  3. [ブック ファイルの種類] で、[Excel 97-2003 ブック (*.xls)] をダブルクリックします。

    [Excel 97-2003 ブック] 形式

  4. [名前 を付けて保存 ] ポップアップ ウィンドウで、ブックのフォルダーの場所を選択します。

  5. [ファイル 名] ボックス に、新しいファイル名を入力します (または、既にあるファイル名を使用します)。

  6. [保存] をクリックします。

  7. 互換性チェック が表示された 場合は、見つかった互換性の問題を確認します。

    元のデータを忠実に再現できなくなる問題を示す互換性チェッカー

    [検索] リンクをクリックすると、ワークシート内のその場所にアクセスし、[ヘルプ] リンクをクリックすると、問題と考えられる解決策に関する情報が表示されます。
     

注: 

  • 新しいバージョンの Excel では、.xls 形式で保存したブックが互換モードで開きます。 このブックを、以前のバージョンの Excel で開くユーザーとやり取りする予定がある場合は、このモードで作業を続けます。

  • 下位互換性が不要になったら、[ファイル>情報> 変換] をクリックしてブックを現在のファイル形式に変換し、新しい機能を利用Excel。

Excel 2007 以降との互換性チェックを実行する

ブックと Excel 2013、2010、2007 との互換性を確認するには、初めてブックを保存するときに、互換性チェックを手動で実行します。 次に、ブックを保存するたびに互換性チェックが自動的に実行されるように設定します。

手順

  1. [ファイル]、[情報]、[問題のチェック] の順にクリックします。

    互換性を確認する

  2. [互換性 チェック] を選択します

  3. 今後は自動的に互換性をチェックするには、[このブックを保存するときに互換性を確認する] チェック ボックスをオンにします。
     

    ヒント: 互換性を確認するときに含めるExcelバージョンを指定できます。 すべてのバージョンが既定でオンになっているので、含めたくないバージョンをオフにしてください。

    チェックするバージョンが表示された互換性チェッカー

    問題が見つかった場合は、[検索] リンクをクリックするとワークシート内のその場所にアクセスし、[ヘルプ] リンクをクリックすると、問題と考えられる解決策に関する情報が表示されます。

Access を使用して、複数のテーブルを使用するデータ機能のデータ ソースを結合する

注: Excel のVLOOKUP関数を使用してこの問題に対処できますが、このプロセスはやや複雑で、結合するデータ ソースの数が増えるほど複雑になります。

Excel 2010 以前のバージョンでは、複数のテーブルを分析するデータ機能はサポートされていません。これらの Excel バージョンにはデータ モデルが含まれておりないのでです。 ブックにこのような機能が含まれている場合は、機能のデータ ソースを 1 つのテーブルに結合し、その新しいテーブルをデータ ソースとして使用することで、以前のバージョンで使用する準備が可能な場合があります。

これを行う 1 つの方法は、Access を使用してデータ ソースを結合し、クエリとして再現し、ブックにインポートすることです。 このプロセスは次のように行います。

  1. Access で、 元の各 データ ソースを新しいテーブルとしてインポートします。

  2. このExcel、[データ >データツール] > リレーションシップ] をクリックして [リレーションシップ] ダイアログ ボックスを開き、元のデータ ソース間のリレーションシップをメモします。

  3. Access で、 各リレーションシップ を再作成します

  4. Access で、データ機能に必要なすべてのフィールドを含Excel作成します。

  5. このExcel、クエリをテーブルとして新しいワークシートにインポートします。

Excel の 1 つのテーブルにデータが入った後、そのテーブルを複数のテーブルを使用していたデータ特徴のデータ ソースとして選択するか、データ機能を再作成して新しいテーブルをデータ ソースとして選択します。

補足説明

Excel Tech Community では、いつでも専門家に質問できます。Microsoft コミュニティでは、サポートを受けられます。また、Excel User Voice では、新機能についての提案や改善案を送信することができます。

関連項目

Excelファイル形式に転送されない書式設定と機能

ワークシートの互換性に関する問題

ヘルプを表示

スキルを磨く
トレーニングの探索
新機能を最初に入手
Microsoft Insider に参加する

この情報は役に立ちましたか?

翻訳品質にどの程度満足していますか?

どのような要因がお客様の操作性に影響しましたか?

その他にご意見はありますか?(省略可能)

フィードバックをお送りいただきありがとうございます!

×