アドインは、Microsoft Excel のオプションのコマンドと機能を提供します。 既定では、Excel でアドインをすぐに利用できないため、最初にアドインをインストールし、(場合によっては) ライセンス認証を行って使用できるようにします。

HTML、CSS、JS に基Officeアドインに関する情報をお探しですか? その場合は、「アドインのOfficeを取得する」を参照Excel。

一部のアドインは、ソルバー Excel分析ツールPakなど、アプリケーションに組み込みされています。 その他のアドインはダウンロード センターから利用できます。最初にダウンロードしてインストールする必要があります。 最後に、組織内のプログラマーやソフトウェア ソリューション プロバイダーなど、サード パーティによって作成されるアドインがあります。 これらは、コンポーネント オブジェクト モデル (COM) アドイン、Visual Basic for Applications (VBA) アドイン、および DLL アドインです。 これらのアドインを使用するには、これらのアドインもインストールする必要があります。

ほとんどのアドインは、次の 3 種類に分類できます。

  • Excel アドイン:    これらには、主に Excel アドイン (.xlam) ファイル、Excel 97-2003 アドイン (.xla) ファイル、DLL アドイン (.xll) ファイルなどで、オートメーション アドインです。 ソルバーや分析ツールなどの Excel アドインは、Excel または Microsoft Office をインストールすると使用できるようになります。 通常、これらのアドインの使用に必要なのはライセンス認証だけです。

  • ダウンロード可能なアドイン    追加のアドインは、Excel のダウンロードからダウンロードしてインストール Office.com。

  • カスタム アドイン    開発者とソリューション プロバイダーは通常、カスタム コンポーネント オブジェクト モデル (COM) アドイン、自動化アドイン、VBA アドイン、XLL アドインを設計します。 これらを使用するには、これらをインストールする必要があります。

アドインをインストールまたは有効にすると、アドインとそのコマンドが次のいずれかの場所で使用できるようになります。

  • [データ] タブ。 分析ツール アドインとソルバー アドインをインストールして有効にすると、[分析] で [データ分析] と [ソルバー] を使用できます。

    [データ分析] と [ソルバー]

  • [数式] タブ。 ユーロ通貨対応ツールをインストールして有効にすると、[ソリューション] に [ユーロ換算] および [ユーロ書式設定] が表示されます。

    [ユーロ換算] と [ユーロ書式設定]

  • [アドイン] タブ。 その他のアドインは [アドイン] タブに追加できます。 [アドイン] タブに表示される最初のアドインをインストールして有効にすると、このタブがリボンに追加されます。 [アドイン] タブが表示されない場合は、Excel を終了して再起動する必要があります。

[はじめに] タブなど、その他のアドインは、Excel の他の場所 (リボンのタブなど) で使用したり、マクロやユーザー設定のメニューから使用できます。

重要: ソフトウェア開発者の場合は、アドインのインストールプログラムと削除プログラムを設計する前に、この手順を使用してオートメーション プログラムをインストールまたは削除できます。

Excel アドインを有効にするには    

  1. [ファイル] タブをクリックします。[オプション] をクリックし、[アドイン] カテゴリをクリックします。

  2. [管理] ボックスの一覧の [Excel アドイン] をクリックし、[設定] をクリックします。

    [アドイン] ダイアログ ボックスが表示されます。

  3. [有効なアドイン] ボックスで、有効にするアドインの横のチェック ボックスをオンにして、[OK] をクリックします。

有効にするアドインが [有効なアドイン] ボックスに表示されない場合は、インストールする必要があります。

Excel アドインをインストールするには    

  • ソルバーや分析ツールなど、通常は Excel と共にインストールされるアドインをインストールするには、Excel または Microsoft Office のセットアップ プログラムを実行し、[変更] オプションを選択してアドインをインストールします。 Excel を再起動した後、[有効なアドイン] ボックスにアドインが表示されます。

  • 一部の Excel アドインはコンピューターに保存されており、[アドイン] ダイアログ ボックスの [参照] をクリックしてアドインを探し、[OK] をクリックすると、インストールまたは有効にすることができます。

  • 一部の Excel アドインは、インストール パッケージの実行が必要です。 インストール パッケージをコンピューターにダウンロードまたはコピーして (インストール パッケージは通常 .msi 拡張子のファイル) 実行することが必要な場合があります。

  • コンピューターにないその他のアドインは、Web ブラウザーを使用して「ダウンロード センター」かインターネット上の他のサイトや組織内のサーバーからダウンロードしてインストールできます。 必要に応じて、ダウンロードのセットアップで表示される手順に従って操作してください。

Excel アドインを無効にするには    

  1. [ファイル] タブをクリックします。[オプション] をクリックし、[アドイン] カテゴリをクリックします。

  2. [管理] ボックスの一覧の [Excel アドイン] をクリックし、[設定] をクリックします。

  3. [有効なアドイン] ボックスで、無効にするアドインの横のチェック ボックスをオフにして、[OK] をクリックします。

    多くの場合、アドインを無効にすると、リボンのグループから削除されます。 別のケースでは、リボンからアドインを削除するために、Excel の再起動が必要になる場合があります。

    メモ    アドインを無効にしても、コンピューターからアドインが削除されるわけではありません。 コンピューターからアドインを削除するには、そのアドインをアンインストールする必要があります。

Excel アドインを削除するには    

重要: ネットワーク ファイル サーバーまたは共有フォルダーから Excel アドインを最初にインストールした場合は、その場所からアドインを削除する必要がある場合があります。 CD から Excel アドインをインストールし、アドインのインストール後に CD ドライブを新しいドライブ文字にマップした場合は、CD からアドインを再インストールする必要があります。 CD から任意の Excel アドインを実行している場合は、Excel アドインをアンインストールしてから、CD から再インストールする必要があります。

  1. [ファイル] タブをクリックして、[終了] をクリックします。

  2. コントロール パネルの [プログラムと機能] (Windows 7 および Windows Vista の場合) または [プログラムの追加と削除] (Windows XP の場合) をクリックします。

  3. 次のいずれかの操作を行います。

    • Excel を Microsoft Office の一部としてインストールした場合は、インストールされているプログラムの一覧で [Microsoft Office] をクリックし、[変更] をクリックします。

    • Excel を個別にインストールした場合は、インストールされているプログラムの一覧で目的のプログラム名をクリックし、[変更] をクリックします。

    • ダウンロード センターからダウンロードしたアドインをインストールした場合は、インストールされているプログラムの一覧で目的のプログラム名をクリックし、[アンインストール] をクリックします。

  4. インストール プログラムに表示される指示に従って操作します。

重要: ソフトウェア開発者の場合は、アドインのインストールプログラムと削除プログラムを設計する前に、この手順を使用してオートメーション プログラムをインストールまたは削除できます。 開発者ではない場合は、この手順を使用する必要はない必要があります。 インストールと削除の手順が必要な場合は、アドインを提供したシステム管理者に問い合わせてください。

COM アドインを追加する

  1. [ファイル] タブをクリックします。[オプション] をクリックし、[アドイン] カテゴリをクリックします。

  2. [管理] ボックスの [COM アドイン] をクリックし、[設定] をクリックします。

    [COM アドイン] ダイアログ ボックスが表示されます。

  3. [有効なアドイン] ボックスで、インストールするアドインの横のチェック ボックスをオンにして、[OK] をクリックします。

    ヒント    [有効なアドイン] ボックスの一覧に目的のアドインが表示されない場合は、[追加] をクリックしてアドインを検索します。

COM アドインを削除する

  1. [ファイル] タブをクリックします。[オプション] をクリックし、[アドイン] カテゴリをクリックします。

  2. [管理] ボックスの [COM アドイン] をクリックし、[設定] をクリックします。

    [COM アドイン] ダイアログ ボックスが表示されます。

  3. [有効なアドイン] ボックスで、削除するアドインの横のチェック ボックスをオフにして、[OK] をクリックします。

    メモ    これにより、メモリからアドインが削除されますが、その名前は使用可能なアドインの一覧に保持されます。 コンピューターからアドインが削除されるわけではありません。

  4. 有効なアドインの一覧から COM アドインを削除し、コンピューターからアドインを削除するには、[使用できるアドイン] ボックスの一覧でアドイン名をクリックし、[削除] をクリックします。

注: ソフトウェア開発者の場合は、アドインのインストールプログラムと削除プログラムを設計する前に、この手順を使用してオートメーション プログラムをインストールまたは削除できます。 開発者ではない場合は、この手順を使用する必要はない必要があります。 インストールと削除の手順が必要な場合は、アドインを提供したシステム管理者に問い合わせてください。

  1. [ファイル] タブをクリックします。[オプション] をクリックし、[アドイン] カテゴリをクリックします。

  2. [管理] ボックスの一覧の [Excel アドイン] をクリックし、[設定] をクリックします。

    [アドイン] ダイアログ ボックスが表示されます。

  3. オートメーション アドインをインストールするには、[オートメーション] をクリックし、[有効なオートメーション サーバー] ボックスで目的のアドインをクリックします。

    ヒント    目的のアドインが一覧に表示されていない場合は、[参照] をクリックし、アドインを探し、[OK] をクリックします

  4. オートメーション アドインを削除するには、レジストリから削除する必要があります。 詳細については、システム管理者にお問い合わせください。

一部のアドインは、ソルバー Excel分析ツールPakなど、アプリケーションに組み込みされています。 その他のアドインはダウンロード センターから利用できます。最初にダウンロードしてインストールする必要があります。 最後に、組織内のプログラマーやソフトウェア ソリューション プロバイダーなど、サード パーティによって作成されるアドインがあります。 これらは、コンポーネント オブジェクト モデル (COM) アドイン、Visual Basic for Applications (VBA) アドイン、および DLL アドインです。 これらのアドインを使用するには、これらのアドインもインストールする必要があります。

ほとんどのアドインは、次の 3 種類に分類できます。

  • Excel アドイン:    これらには、主に Excel アドイン (.xlam) ファイル、Excel 97-2003 アドイン (.xla) ファイル、DLL アドイン (.xll) ファイルなどで、オートメーション アドインです。 ソルバーや分析ツールなどの Excel アドインは、Excel または Microsoft Office をインストールすると使用できるようになります。 通常、これらのアドインの使用に必要なのはライセンス認証だけです。

  • ダウンロード可能なアドイン    追加のアドインは、Excel のダウンロードからダウンロードしてインストール Office.com。

  • カスタム アドイン    開発者とソリューション プロバイダーは通常、カスタム コンポーネント オブジェクト モデル (COM) アドイン、自動化アドイン、VBA アドイン、XLL アドインを設計します。 これらを使用するには、これらをインストールする必要があります。

アドインをインストールまたは有効にすると、アドインとそのコマンドが次のいずれかの場所で使用できるようになります。

  • [データ] タブ。 Analysis ToolPak アドインとソルバー アドインをインストールしてアクティブ化すると、リボンの[データ] タブで [データ分析] コマンドと [ソルバー] コマンドを使用できます。

  • [ホーム] タブ 。 その他のアドインは、[ホーム] タブに 追加 できます。

[はじめに] タブなど、その他のアドインは、Excel の他の場所 (リボンのタブなど) で使用したり、マクロやユーザー設定のメニューから使用できます。

重要: ソフトウェア開発者の場合は、アドインのインストールプログラムと削除プログラムを設計する前に、この手順を使用してオートメーション プログラムをインストールまたは削除できます。

プレインストール済みのアドインをアクティブExcelするには    

  1. [ツール] メニュー の [アドイン ] を選択します

  2. [使用可能 なアドイン] ボックス で、アクティブ化するアドインのチェック ボックスをオンにし 、[OK] をクリックします

Excel アドインをインストールするには    

  • 一部Excelアドインはコンピューター上にあり、(上の [アドイン] ダイアログ ボックスで) [参照]をクリックしてアドインを見つけ、[OK]をクリックしてインストールまたはアクティブ化できます。

  • 一部の Excel アドインは、インストール パッケージの実行が必要です。 インストール パッケージをコンピューターにダウンロードまたはコピーして (インストール パッケージは通常 .msi 拡張子のファイル) 実行することが必要な場合があります。

  • コンピューターで使用できないその他のアドインは、ダウンロードから Web ブラウザーまたはインターネット上の他の サイト、組織内のサーバー、または Excel の組み込みストアオプションを使用してダウンロードしてインストールできます。 必要に応じて、ダウンロードのセットアップで表示される手順に従って操作してください。

    ストアからアドインをインストールするには

    1. リボンの [挿入] タブをクリックします。

    2. [ストア] ボタンをクリック します。

    3. [カテゴリ] または[検索] フィールド を使用して、アドインを検索します。

    4. [追加 ] を クリックしてアドインをインストールします。

      注: 一部のアドインを購入する必要があります。

Excel アドインを削除するには    

  1. [挿入] タブを クリックし、[マイ アドイン ] をクリックします

  2. [Office] で、[アドイン] の横にある [3 ドット] メニューをクリックします。

  3. [削除] をクリックします。

  4. 他のデバイスに関して表示される通知を読み、[削除] を クリックします

ヘルプを表示

スキルを磨く
トレーニングの探索
新機能を最初に入手
Microsoft Insider に参加する

この情報は役に立ちましたか?

翻訳品質にどの程度満足していますか?

どのような要因がお客様の操作性に影響しましたか?

その他にご意見はありますか?(省略可能)

フィードバックをお送りいただきありがとうございます!

×