オブジェクト リンクと埋め込み (OLE) を使用して、Word や Excel などの他のプログラムのコンテンツを含めできます。

OLE はさまざまなプログラムでサポートされ、OLE は 1 つのプログラムで作成されたコンテンツを別のプログラムで使用するために使用されます。 たとえば、Excel ブックに Word Office文書を挿入Officeできます。 挿入できるコンテンツの種類を確認するには、[挿入]タブの[テキスト] グループの [オブジェクト]をクリックします。 [オブジェクトの種類] ボックスには、コンピューターにインストールされ、OLE オブジェクトをサポートする プログラムだけが表示 されます。

Excel または Word などの OLE をサポートするプログラムの間で情報をコピーする場合は、その情報を リンク オブジェクト または 埋め込みオブジェクトとしてコピーできます。 リンクされたオブジェクトと埋め込みオブジェクトの主な違いは、データが格納される場所と、データをデータに配置した後にオブジェクトを更新する方法 転送先ファイル。 埋め込みオブジェクトは、挿入されたブックに格納され、更新されません。 リンクされたオブジェクトは個別のファイルとして残り、更新できます。

文書にリンクされたオブジェクトと埋め込まれたオブジェクト

Office for Windows ドキュメントのリンク オブジェクトと埋め込みオブジェクト

1. 埋め込みオブジェクトにソース ファイルへの接続はありません。

2. リンクされたオブジェクトがソース ファイルにリンクされます。

3. リンクされたオブジェクトがソース ファイルによって更新されます。

リンクされたオブジェクトを使用する場合

アプリケーション内のデータが変更された 転送先ファイル 情報を更新する場合は、リンクされた ソース ファイル を使用します。

リンクされたオブジェクトでは、元の情報はソース ファイルに保存されたままです。 リンク先ファイルには、リンクされた情報の表現が表示されますが、元のデータの場所 (およびオブジェクトが Excel グラフ オブジェクトの場合はサイズ) のみを格納します。 元のデータへのリンクを維持するには、ソース ファイルをコンピューターまたはネットワークで使用できる状態に維持する必要があります。

ソース ファイル内の元のデータを変更すると、リンクされた情報を自動的に更新できます。 たとえば、Word 文書で段落を選択し、Excel ブックにリンク されたオブジェクトとして段落を貼り付ける場合、Word 文書内の情報を変更すると、Excel で情報を更新できます。

埋め込みオブジェクトを使用する場合

コピーしたデータをソース ファイルで変更するときに更新しない場合は、埋め込みオブジェクトを使用します。 ソースのバージョンは、ブックに完全に埋め込まれています。 情報を埋め込みオブジェクトとしてコピーする場合、リンク先ファイルには、情報をリンクする場合よりも多くのディスク領域が必要です。

ユーザーが別のコンピューターでファイルを開くと、元のデータにアクセスせずに埋め込みオブジェクトを表示できます。 埋め込みオブジェクトにはソース ファイルへのリンクが含まれているため、元のデータを変更した場合、オブジェクトは更新されません。 埋め込みオブジェクトを変更するには、オブジェクトをダブルクリックしてソース プログラムで開いて編集します。 ソース プログラム (またはオブジェクトを編集できる別のプログラム) をコンピューターにインストールする必要があります。

OLE オブジェクトの表示方法を変更する

ブック内の リンク オブジェクト または 埋め込みオブジェクト 、ブックに表示されるのとまったく同じ ソース プログラム アイコンとして表示できます。 ブックがオンラインで表示され、ブックを印刷する予定がない場合は、オブジェクトをアイコンとして表示できます。 これにより、オブジェクトが占有する表示領域の量を最小限に抑える。 情報を表示する閲覧者は、アイコンをダブルクリックできます。

ワークシートにオブジェクトを埋め込む

  1. オブジェクトを挿入するスプレッドシートのセルの内側をクリックします。

  2. [挿入] タブの[テキスト]グループで、[オブジェクト]をクリック リボンの [オブジェクト] アイコン
    オブジェクトの挿入

  3. [オブジェクト] ダイアログ ボックスで、[ファイルから作成 ] タブをクリック します。

  4. [参照] をクリックし、挿入するファイルを選択します。

  5. ファイルの内容を表示する代わりに、スプレッドシートにアイコンを挿入する場合は、[アイコンで表示] チェック ボックスをオンにします。 すべてのチェック ボックスをオンにしない場合、Excel にはファイルの最初のページが表示されます。 どちらの場合も、ダブルクリックで完全なファイルが開きます。 [OK] をクリックします。

    注: アイコンまたはファイルを追加した後は、ワークシート上の任意の場所にドラッグ アンド ドロップすることができます。 サイズ変更ハンドルを使用して、アイコンまたはファイルのサイズを変更することもできます。 ハンドルを見つけるには、ファイルまたはアイコンを一度クリックします。

ファイルにリンクを挿入する

完全に埋め込むのではなく、オブジェクトへのリンクのみを追加する必要がある場合があります。 追加するブックとオブジェクトが両方 SharePoint サイト、共有ネットワーク ドライブまたは同様の場所に保存されていて、ファイルが同じ場所に保持されている場合は、この操作を行うことができます。 リンクは常に最新のドキュメントを開くため、これはリンクされたオブジェクトが変更された場合に便利です。

注: リンクされたファイルを別の場所に移動すると、そのリンクは機能しなくなります。

  1. オブジェクトを挿入するスプレッドシートのセルの内側をクリックします。

  2. [挿入] タブの[テキスト]グループで、[オブジェクト]をクリック リボンの [オブジェクト] アイコン
    オブジェクトの挿入

  3. [ファイルから作成 ] タブをクリック します。

  4. [参照] をクリックし、リンクするファイルを選択します。

  5. [ファイルへのリンク] チェック ボックスをオンにして、[OK] をクリックします。

Excel 内から新しいオブジェクトを作成する

ブックを終了せずに、別のプログラムに基づくまったく新しいオブジェクトを作成することができます。 たとえば、グラフや表に詳細な説明を追加する場合は、Excel で Word や PowerPoint ファイルなどの埋め込みドキュメントを作成できます。 オブジェクトをワークシートに直接表示されるように設定するか、ファイルを開くアイコンを追加するかのいずれかを行うことができます。

この埋め込まれたオブジェクトは、Word 文書です。
  1. オブジェクトを挿入するスプレッドシートのセルの内側をクリックします。

  2. [挿入] タブの[テキスト]グループで、[オブジェクト]をクリック リボンの [オブジェクト] アイコン
    オブジェクトの挿入

  3. [新規作成] タブで、表示されるリストから挿入するオブジェクトの種類を選択します。 オブジェクト自体ではなく、スプレッドシートにアイコンを挿入する場合は、[アイコンで表示] チェック ボックスをオンにします。

  4. [OK] をクリックします。 挿入しているファイルの種類によって、新しいプログラム ウィンドウが開くか、Excel 内に編集ウィンドウが表示されるかのいずれかになります。

  5. 挿入する新しいオブジェクトを作成します。

    完了したときに、Excel でオブジェクトを作成した新しいプログラム ウィンドウが開かれた場合、そのウィンドウ内で直接操作を行うことができます。

    Excel で、埋め込まれた Word 文書を直接編集できます。

    ウィンドウでの作業が完了したら、埋め込みオブジェクトを保存せずに、その他のタスクを行うことができます。 ブックを閉じると、新しいオブジェクトは自動的に保存されます。

    注: オブジェクトを追加した後は、Excel ワークシート上の任意の場所にドラッグ アンド ドロップすることができます。 サイズ変更ハンドルを使用して、オブジェクトのサイズを変更することもできます。 ハンドルを見つけるには、オブジェクトを一度クリックします。

ワークシートにオブジェクトを埋め込む

  1. オブジェクトを挿入するスプレッドシートのセルの内側をクリックします。

  2. [挿入] タブの [テキスト] グループで [オブジェクト] をクリックします。

    [オブジェクト] オプションは、[挿入] タブにあります。
  3. [ファイルから作成] タブをクリックします。

    [オブジェクト] ダイアログ ボックスの [ファイルから作成] タブ。
  4. [参照] をクリックし、挿入するファイルを選択します。

  5. ファイルの内容を表示する代わりに、スプレッドシートにアイコンを挿入する場合は、[アイコンで表示] チェック ボックスをオンにします。 すべてのチェック ボックスをオンにしない場合、Excel にはファイルの最初のページが表示されます。 どちらの場合も、ダブルクリックで完全なファイルが開きます。 [OK] をクリックします。

    注: アイコンまたはファイルを追加した後は、ワークシート上の任意の場所にドラッグ アンド ドロップすることができます。 サイズ変更ハンドルを使用して、アイコンまたはファイルのサイズを変更することもできます。 ハンドルを見つけるには、ファイルまたはアイコンを一度クリックします。

ファイルにリンクを挿入する

完全に埋め込むのではなく、オブジェクトへのリンクのみを追加する必要がある場合があります。 追加するブックとオブジェクトが両方 SharePoint サイト、共有ネットワーク ドライブまたは同様の場所に保存されていて、ファイルが同じ場所に保持されている場合は、この操作を行うことができます。 リンクは常に最新のドキュメントを開くため、これはリンクされたオブジェクトが変更された場合に便利です。

注: リンクされたファイルを別の場所に移動すると、そのリンクは機能しなくなります。

  1. オブジェクトを挿入するスプレッドシートのセルの内側をクリックします。

  2. [挿入] タブの [テキスト] グループで [オブジェクト] をクリックします。

    [オブジェクト] オプションは、[挿入] タブにあります。
  3. [ファイルから作成] タブをクリックします。

  4. [参照] をクリックし、リンクするファイルを選択します。

  5. [ファイルへのリンク] チェック ボックスをオンにして、[OK] をクリックします。

    [ファイルから作成] タブで、[ファイルにリンク] を選択します。

Excel 内から新しいオブジェクトを作成する

ブックを終了せずに、別のプログラムに基づくまったく新しいオブジェクトを作成することができます。 たとえば、グラフや表に詳細な説明を追加する場合は、Excel で Word や PowerPoint ファイルなどの埋め込みドキュメントを作成できます。 オブジェクトをワークシートに直接表示されるように設定するか、ファイルを開くアイコンを追加するかのいずれかを行うことができます。

この埋め込まれたオブジェクトは、Word 文書です。
  1. オブジェクトを挿入するスプレッドシートのセルの内側をクリックします。

  2. [挿入] タブの [テキスト] グループで [オブジェクト] をクリックします。

    [オブジェクト] オプションは、[挿入] タブにあります。
  3. [新規作成] タブで、表示されるリストから挿入するオブジェクトの種類を選択します。 オブジェクト自体ではなく、スプレッドシートにアイコンを挿入する場合は、[アイコンで表示] チェック ボックスをオンにします。

    [オブジェクト] ダイアログ ボックスの [新規作成] タブ
  4. [OK] をクリックします。 挿入しているファイルの種類によって、新しいプログラム ウィンドウが開くか、Excel 内に編集ウィンドウが表示されるかのいずれかになります。

  5. 挿入する新しいオブジェクトを作成します。

    完了したときに、Excel でオブジェクトを作成した新しいプログラム ウィンドウが開かれた場合、そのウィンドウ内で直接操作を行うことができます。

    Excel で、埋め込まれた Word 文書を直接編集できます。

    ウィンドウでの作業が完了したら、埋め込みオブジェクトを保存せずに、その他のタスクを行うことができます。 ブックを閉じると、新しいオブジェクトは自動的に保存されます。

    注: オブジェクトを追加した後は、Excel ワークシート上の任意の場所にドラッグ アンド ドロップすることができます。 サイズ変更ハンドルを使用して、オブジェクトのサイズを変更することもできます。 ハンドルを見つけるには、オブジェクトを一度クリックします。

OLE オブジェクトの表示方法を変更する

  1. アイコンまたはオブジェクトを右クリックし、オブジェクトの種類 [オブジェクト]([ドキュメント オブジェクト] など) をポイントし、[変換] をクリックします

  2. 次のいずれかの操作を行います。

    • コンテンツを表示するには、[アイコンとして表示 ] チェック ボックス をオフにします。

    • アイコンを表示するには、[アイコンとして表示 ] チェック ボックス をオンにします。 必要に応じて、既定のアイコン イメージまたはラベルを変更できます。 これを行うには、[アイコンの変更]をクリックし、[アイコン] リストから必要なアイコンをクリックするか、[キャプション] ボックスにラベルを入力します。

OLE プログラムからコンテンツを編集する

Excel を使用している間は、別のプログラムからリンクまたは埋め込まれたコンテンツを変更できます。

ソース プログラムでリンクされたオブジェクトを編集する

  1. [データ] タブの [接続] で [リンクの編集] をクリックします。

    Excel のリボンのイメージ

    注: リンクされたデータが作業中のファイルにない場合、[リンクの編集] は使用できません。

  2. [ソース ファイル ] ボックス の一覧で、ソースのソースをクリック リンク オブジェクト[ソースを開く] をクリックします

  3. リンクされたオブジェクトに対して必要な変更を行います。

  4. コピー元の ソース プログラム を終了して、コピー先のファイルに戻します。

ソース プログラムで埋め込みオブジェクトを編集する

  1. ウィンドウをダブルクリックして 埋め込みオブジェクト 開きます。

  2. オブジェクトに対して必要な変更を行います。

  3. 開いているプログラム内でオブジェクトを編集する場合は、オブジェクトの外側の任意の場所をクリックして、オブジェクトに戻 転送先ファイル。

    別のウィンドウでソース プログラムの埋め込みオブジェクトを編集する場合は、ソース プログラムを終了してコピー先のファイルに戻ります。

注: プログラムを開く代わりに、ビデオ クリップやサウンド クリップなどの特定の埋め込みオブジェクトをダブルクリックすると、オブジェクトが再生されます。 これらの埋め込みオブジェクトのいずれかを編集するには、アイコンまたはオブジェクトを右クリックし、オブジェクトの種類 [オブジェクト] ([メディア クリップ オブジェクト] など) をポイントし、[編集] をクリックします

ソース プログラム以外のプログラムの埋め込みオブジェクトを編集する

  1. 編集する 埋め込みオブジェクト を選択します。

  2. アイコンまたはオブジェクトを右クリックし、オブジェクトの種類 [オブジェクト]([ドキュメント オブジェクト] など) をポイントし、[変換] をクリックします

  3. 次のいずれかの操作を行います。

    • 埋め込みオブジェクトを一覧で指定した型に変換するには、[変換先] をクリックします

    • 埋め込みオブジェクトの種類を変更せずに、リストで指定した型として埋め込みオブジェクトを開く場合は、[アクティブ化] を クリックします

キーボードを使用して OLE オブジェクトを選択する

  1. Ctrl キーを押しながら G キーを押して、[ 移動] ダイアログ ボックス を表示します。

  2. [特殊 ] をクリックし、[ オブジェクト] を選択、[OK] をクリックします

  3. 目的のオブジェクトが選択されるまで TAB キーを押します。

  4. Shift キーを押しながら F10 キーを押します。

  5. [オブジェクト]または [グラフ オブジェクト] をポイントし、[編集] をクリックします

問題: リンクされたオブジェクトまたは埋め込みオブジェクトをダブルクリックすると、"編集できません" というメッセージが表示されます

このメッセージは、 ソース ファイル または ソース プログラム 開けなかったときに表示されます。

ソース プログラムが使用可能なのを確認します。     ソース プログラムがコンピューターにインストールされていない場合は、インストールしたプログラムのファイル形式にオブジェクトを変換します。

メモリが十分な容量を確保する     ソース プログラムを実行するのに十分なメモリを持っている必要があります。 必要に応じて、他のプログラムを閉じてメモリを解放します。

すべてのダイアログ ボックスを閉じる     ソース プログラムが実行されている場合は、開いているダイアログ ボックスが表示されていないか確認します。 ソース プログラムに切り替えて、開いているダイアログ ボックスを閉じます。

ソース ファイルを閉じる     ソース ファイルがリンクされたオブジェクトである場合は、別のユーザーが開いていないか確認します。

ソース ファイル名が変更されていないか確認する     編集するソース ファイルがリンク オブジェクトの場合は、リンクの作成時と同じ名前を持ち、リンクが移動されていないことを確認します。 リンクされたオブジェクトを選択し、[データ]タブの [接続] グループの [リンクの編集] コマンドをクリックして、ソース ファイルの名前を表示します。 ソース ファイルの名前が変更または移動された場合は、[リンクの編集]ダイアログ ボックスの [ソースの変更] ボタンを使用して、ソース ファイルを見つけてリンクを再接続します。

補足説明

Excel 技術コミュニテでは、いつでも専門家に質問できます。また、Answers コミュニティでは、サポートを受けられます。

ヘルプを表示

スキルを磨く
トレーニングの探索
新機能を最初に入手
Microsoft Insider に参加する

この情報は役に立ちましたか?

翻訳品質にどの程度満足していますか?

どのような要因がお客様の操作性に影響しましたか?

その他にご意見はありますか?(省略可能)

フィードバックをお送りいただきありがとうございます!

×