UML の使用事例図を Visio で作成して、ユーザー (または アクター)がソフトウェア アプリケーションなどのシステムとやり取りする方法を要約できます。 アクターには、人、組織、または別のシステムを指定できます。

使用例の図は、システムの想定される動作を示しています。 手順の実行順序は表示されません。 (シーケンス図を 使用して、 時間の間にオブジェクトがどのように対話を 行うのか示します)。

レフェリー認定システムを示す UML の使用事例図のサンプル

システムの システム境界 定義すると、システムの外部または内部と見なされる項目が決されます。

外部 アクター は、外部オブジェクトによって再生されるロールを表します。 1 つのオブジェクトは複数のロールを果たします。そのため、複数のアクターによって表されます。

関連付けは、アクターが使用事例に参加する方法を示しています。

" ユース ケース " は、アクターがシステムを使用してプロセスを完了するときに発生する一連のイベントです。 通常、使用事例は、個々のステップやトランザクションではなく、比較的大規模なプロセスです。

新しい使用事例の図を作成する

  1. [ファイル] タブで 、[新規] を ポイントします

  2. [検索 ] ボックス、「UML の使用例」と入力します

  3. 検索結果から [UML Use Case] を選択します

  4. ダイアログ ボックスで、空のテンプレートまたは 3 つのスターター図のいずれかを選択します。 (各説明は、選択すると右側に表示されます)。 次に、[メトリック単位 ] または [米国単位 ] を選択します

  5. [作成] を選択します。

  6. ダイアグラムが開きます。 図の横に [図形] ウィンドウが表示されるはずです。 UML の [使用例] ステンシルが [図形] ウィンドウ で開 きます。

    ([図形] ウィンドウが表示しない場合は、[タスクウィンドウの表示] >表示] に移動し、[図形] が選択されている必要があります。 それでも表示しない場合は、左側の [図形の 展開] ウィンドウ ボタンをクリックします)。

サブシステムを使用事例図に追加する

  1. [サブシステム] 図形 を図面ページにドラッグします。 サブシステムは、システム全体または主要コンポーネントを表します。

    サブシステム図形。

  2. サブシステム図形を ダブルクリックし 、その新しい名前を入力するか、Delete キーを押して既存の名前を削除します。 図面ページの図形の外側をクリックします。

  3. サブシステムのサイズを変更するには、図形を選択し、選択ハンドルをドラッグします。

図形とコネクタをダイアグラムに追加する

  1. [UML Use Case]ステンシルから [[Use Case] 図形。 ] をドラッグしてサブシステム境界内に配置 し、アクター図形 アクター図形。 をサブシステム境界の外側にドラッグします。

  2. コネクタ図形を使用して、図内の図形間の関係を示します。 次の 5 つのコネクタを使用できます。

    コネクタ

    説明

    関連付け

    関連付けコネクタ。

    アクターとケースの関係を示します。

    依存性

    Dependency コネクタ。

    1 つの使用例が別のケースと依存関係を持つかどうかを示します。

    一般化

    Generalization コネクタ。

    一般的な使用事例の目標を達成するための具体的な方法が、使用事例を示します。

    含む

    Include コネクタ。

    使用事例を小さな手順に分割する方法を示します。

    拡張

    Extend コネクタ。

    1 つの使用例が別のケースに機能を追加する方法を示します。

    例: アクターと使用例の間の関係を示す場合

    1. [関連 ユース ケース図図形を図面 ページにドラッグします。

    2. 関連付け図形の 1 つの端点をアクター図形の接続ポイントに 接着 します。 他のエンドポイントを[Use Case] 図形の接続ポイント に接着 します。

関連項目

使用事例図 (および Microsoft Visual Studio を使用して使用する場合の手順) の詳細については、「UMLの使用事例図: ガイドライン」を参照してください。

注:  Web 用 Visio で UML 図を作成および編集するには、Visio Plan 1 または Visio Plan 2 ライセンス が必要です。これは、 Microsoft 365とは別に購入されます。 詳細については、管理者にお問い合Microsoft 365ください。 管理者が "セルフサービス購入" を有効にしている場合は、ユーザー自身のライセンスをVisioできます。 詳細については、「セルフサービス購入に関 する FAQ」を参照してください

新しい使用事例の図を作成する

  1. Web Visio を開きます。 

  2. ページの右上隅にある [その他のテンプレート] を選択します

  3. ギャラリーで、[UML Use Case] 行まで下にスクロール します。

    行の最初の項目は、空白のテンプレートとコンパニオン ステンシルを表します。 行内の他の項目は、すぐに使い始めるのに役立ついくつかの図形が既に描画されているサンプル図です。

  4. 任意の項目をクリックすると、より大きなプレビューが表示されます。

  5. 使用するダイアグラムが見つけたら、[作成] ボタン をクリック します。

    関連するステンシルを含む新しいダイアグラムがブラウザーで開きます。

サブシステムを使用事例図に追加する

  1. [サブシステム] 図形 を図面ページにドラッグします。 サブシステムは、システム全体または主要コンポーネントを表します。

    サブシステム図形。

  2. サブシステム図形を ダブルクリックし 、その新しい名前を入力するか、Delete キーを押して既存の名前を削除します。 図面ページの図形の外側をクリックします。

  3. サブシステムのサイズを変更するには、図形を選択し、選択ハンドルをドラッグします。

図形とコネクタをダイアグラムに追加する

  1. [Use Case] ステンシル [Use Case] 図形。 から [Use Case] 図形をドラッグし、サブシステムの境界内に配置します。

  2. アクター 図形を 境界の外側にドラッグします。

  3. コネクタ図形を使用して、図内の図形間の関係を示します。 次の 5 つのコネクタを使用できます。

    コネクタ

    説明

    関連付け

    関連付けコネクタ。

    アクターとケースの関係を示します。

    依存性

    Dependency コネクタ。

    1 つの使用例が別のケースと依存関係を持つかどうかを示します。

    一般化

    Generalization コネクタ。

    一般的な使用事例の目標を達成するための具体的な方法が、使用事例を示します。

    含む

    Include コネクタ。

    使用事例を小さな手順に分割する方法を示します。

    拡張

    Extend コネクタ。

    1 つの使用例が別のケースに機能を追加する方法を示します。

    例: アクターと使用例の間の関係を示す場合

    1. [関連 ユース ケース図図形を図面 ページにドラッグします。

    2. 関連付け図形の 1 つの端点をアクター図形の接続ポイントに 接着 します。 他のエンドポイントを[Use Case] 図形の接続ポイント に接着 します。

  4. Web 用 Visio 保存されます。 図面の名前を変更するには、図面の上部にある既定の名前 ([図面 1]など) をダブルクリックして選択し、その上に新しい名前を入力します。

関連項目

使用事例図 (および Microsoft Visual Studio を使用して使用する場合の手順) の詳細については、「UMLの使用事例図: ガイドライン」を参照してください。

新しい使用事例の図を作成する

  1. [ファイル] タブで 、[新規] を ポイントします

  2. [検索 ] ボックス、「UML の使用例」と入力します

  3. 検索結果から [UML Use Case] を選択します

  4. ダイアログ ボックスで、空のテンプレートを選択します。 次に、[メトリック単位 ] または [米国単位 ] を選択します

  5. [作成] を選択します。

  6. ダイアグラムが開きます。 図の横に [図形] ウィンドウが表示されるはずです。 UML の [使用例] ステンシルが [図形] ウィンドウ で開 きます。

    ([図形] ウィンドウが表示しない場合は、[タスクウィンドウの表示>]に移動し、[図形] が選択されている必要があります。 それでも表示しない場合は、左側の [図形の 展開] ウィンドウ ボタンをクリックします)。

サブシステムを使用事例図に追加する

  1. [サブシステム] 図形 を図面ページにドラッグします。 サブシステムは、システム全体または主要コンポーネントを表します。

  2. サブシステム図形を ダブルクリックし 、その新しい名前を入力するか、Delete キーを押して既存の名前を削除します。 図面ページの図形の外側をクリックします。

  3. サブシステムのサイズを変更するには、図形を選択し、選択ハンドルをドラッグします。

図形とコネクタをダイアグラムに追加する

  1. UMLの [Use Case] ステンシルから [Use Case] 図形をドラッグし、サブシステム境界内に配置し、アクター図形をサブシステム境界の外側にドラッグします。

  2. コネクタ図形を使用して、図内の図形間の関係を示します。 次の 5 つのコネクタを使用できます。

    コネクタ

    説明

    関連付け

    アクターとケースの関係を示します。

    依存性

    1 つの使用例が別のケースと依存関係を持つかどうかを示します。

    一般化

    一般的な使用事例の目標を達成するための具体的な方法が、使用事例を示します。

    含む

    使用事例を小さな手順に分割する方法を示します。

    拡張

    1 つの使用例が別のケースに機能を追加する方法を示します。

    例: アクターと使用例の間の関係を示す場合

    1. [関連 ユース ケース図図形を図面 ページにドラッグします。

    2. 関連付け図形の 1 つの端点をアクター図形の接続ポイントに 接着 します。 他のエンドポイントを[Use Case] 図形の接続ポイント に接着 します。

関連項目

使用事例図 (および Microsoft Visual Studio を使用して使用する場合の手順) の詳細については、「UMLの使用事例図: ガイドライン」を参照してください。

  1. [ファイル] タブで 、[新規] を ポイントします

  2. [テンプレート カテゴリ] の [ソフトウェアと データベース] をクリックします

    [ソフトウェアとデータベース] を選択する

  3. [UML モデル図] をクリックします。 空白の図面ページが表示されます。

    UML モデル図を選択する

  4. ツリー ビューで、使用事例図を含めるパッケージまたはサブシステムを右クリックし、[新規] をポイントし、[使用事例図] をクリックします

    [Use Case Diagram]をクリックします。

    空白ページが表示され 、[UML Use Case] ステンシルが一番上のステンシルになります。 図を表すアイコンがツリー ビューに追加されます。

    使用例がツリー ビューに追加される

    注: ツリー ビューが表示されない場合は、[UML] タブの [表示 / 非表示] グループで、[モデル エクスプローラー] を選択します

  5. 使用事例の 図でシステム 境界を示す方法

    1. [システム境界 ] 図形を 図面ページにドラッグします。

      [システム境界] を選択する

    2. [システム境界] 図形を ダブルクリックし、システムの新しい名前を入力するか、Delete キーを押して既存の名前を削除します。 図面ページの図形の外側をクリックします。

    3. システム境界のサイズを変更するには、図形を選択し、選択ハンドルをドラッグします。

  6. [Use Case] ステンシルから[Use Case]図形をドラッグ してシステム境界内に配置し、アクター図形をシステム境界の外側にドラッグします。

  7. [ 通信] 図形を使用 して、使用例とアクター間の関係を示します。

    アクターと使用例の間の関係を示す方法

    1. [通信] ユース ケース図図面 ページに [通信 ] 図形をドラッグします。

    2. [通信] 終点の画像 (緑色の四角形の中にプラス記号) 1 つのエンドポイントを、アクター図形上の接続 接続ポイントの画像 - 青い X ポイントに 接着 します。 他のエンドポイントを[Use Case] 図形の接続ポイント に接着 します。

    3. 情報のフローを示す矢印を追加する場合は、次の操作を行います。

      • [通信]図形をダブルクリックし、[関連付け] で編集する端をクリックし、[プロパティ] をクリックします

      • [関連付け終了] カテゴリで、[IsNavigable]をオンにし、[OK]をクリックし、もう一度[OK] をクリックします。

      • [通信] 図形を 右クリックし、[ 図形の表示 オプション] をクリックします。 [ 終了オプション] で、[End navigability] を選択し 、[OK] をクリックします

  8. [ 使用]と [図形の拡張 ] を使用して、使用事例間の関係を示します。

    2 つの使用事例間の使用関係を示す場合

    1. [図面] ユース ケース図図面ページに [リレーションシップ の使用] 図形をドラッグします。

    2. 矢印を 付けず に [使用] エンドポイントを、 接続ポイントの画像 - 青い X の動作を使用する [Use Case] 図形の接続ポイントに接着します。

    3. Use エンドポイント (矢印付き) を、使用されている使用事例の接続ポイントに接着します。

    4. [使用] 図形 をダブルクリック して 、[UML 一般化プロパティ ] ダイアログ ボックスを開きます。 プロパティ値を追加し 、[OK] をクリックします

    2 つの使用例間の拡張関係を示す場合

    1. [拡張] ユース ケース図図面ページに [拡張 ] 図形をドラッグします。

    2. 拡張を 提供する 終点の画像 (緑色の四角形の中にプラス記号) の接続ポイントに矢印を付けず 接続ポイントの画像 - 青い X 拡張エンドポイントを接着します。

    3. 基本の 使用例の 接続ポイントに矢印で Extends エンドポイントを接着します。

    4. [拡張] 図形をダブルクリックして、[UML 一般化プロパティ] ダイアログ ボックスを開きます。 プロパティ値を追加し 、[OK] をクリックします

  9. 任意の図形 ([システム境界] 図形を除く) をダブルクリックして[UMLプロパティ] ダイアログ ボックスを開き、名前、属性、操作、その他のプロパティ値を追加できます。

  10. 図面を保存します。

  1. [ファイル ] メニューの [新規] を ポイントし、[ ソフトウェアとデータベース] をポイントし、[UML モデル図] をクリックします

    [ソフトウェアとデータベース] を選択する

  2. [ ツリー ビュー] で、 ユース ケース図を含めるパッケージまたはサブシステムを右クリックし、[新規] をポイントし、[使用事例図] をクリックします

    Selece の使用例の図

    空白ページが表示され 、[UML Use Case] ステンシルが一番上のステンシルになります。 図を表すアイコンがツリー ビューに追加されます。

    注: ツリー ビューが表示されない場合は、[UML] メニューの [ビュー] をポイントし、[モデル エクスプローラー] をクリックします。

  3. 使用事例図でシステム境界を示す方法

    1. [システム境界 ] 図形を 図面ページにドラッグします。

      使用例のステンシル

    2. [システム境界] 図形を ダブルクリックし、システムの新しい名前を入力するか、Delete キーを押して既存の名前を削除します。 図面ページの図形の外側をクリックします。

    3. システム境界のサイズを変更するには、図形を選択し、選択ハンドルをドラッグします。

  4. [Use Case] ステンシルから[Use Case]図形をドラッグ してシステム境界内に配置し、アクター図形をシステム境界の外側にドラッグします。

  5. [ 通信] 図形を使用 して、使用例とアクター間の関係を示します。

    アクターと使用例の間の関係を示す方法

    1. [通信] ユース ケース図図面 ページに [通信 ] 図形をドラッグします。

    2. [通信] 終点の画像 (緑色の四角形の中にプラス記号) 1 つのエンドポイントを、アクター図形上の接続 接続ポイントの画像 - 青い X ポイントに 接着 します。 他のエンドポイントを[Use Case] 図形の接続ポイント に接着 します。

    3. 情報のフローを示す矢印を追加する場合は、次の操作を行います。

      • [通信]図形をダブルクリックし、[関連付け] で編集する端をクリックし、[プロパティ] をクリックします

      • [関連付け終了] カテゴリで、[IsNavigable]をオンにし、[OK]をクリックし、もう一度[OK] をクリックします。

      • [通信] 図形を 右クリックし、[ 図形の表示 オプション] をクリックします。 [ 終了オプション] で、[End navigability] を選択し 、[OK] をクリックします

  6. [ 使用]と [図形の拡張 ] を使用して、使用事例間の関係を示します。

    2 つの使用事例間の使用関係を示す場合

    1. [図面] ユース ケース図図面ページに [リレーションシップ の使用] 図形をドラッグします。

    2. 矢印を 付けず に [使用] エンドポイントを、 接続ポイントの画像 - 青い X の動作を使用する [Use Case] 図形の接続ポイントに接着します。

    3. Use エンドポイント (矢印付き) を、使用されている使用事例の接続ポイントに接着します。

    4. [使用] 図形 をダブルクリック して 、[UML 一般化プロパティ ] ダイアログ ボックスを開きます。 プロパティ値を追加し 、[OK] をクリックします

    2 つの使用例間の拡張関係を示す場合

    1. [拡張] ユース ケース図図面ページに [拡張 ] 図形をドラッグします。

    2. 拡張を 提供する 終点の画像 (緑色の四角形の中にプラス記号) の接続ポイントに矢印を付けず 接続ポイントの画像 - 青い X 拡張エンドポイントを接着します。

    3. 基本の 使用例の 接続ポイントに矢印で Extends エンドポイントを接着します。

    4. [拡張] 図形をダブルクリックして、[UML 一般化プロパティ] ダイアログ ボックスを開きます。 プロパティ値を追加し 、[OK] をクリックします

  7. 任意の図形 ([システム境界] 図形を除く) をダブルクリックして[UMLプロパティ] ダイアログ ボックスを開き、名前、属性、操作、その他のプロパティ値を追加できます。

  8. 図面を保存します。

ヘルプを表示

スキルを磨く
トレーニングの探索
新機能を最初に入手
Microsoft Insider に参加する

この情報は役に立ちましたか?

翻訳品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?

フィードバックをお送りいただきありがとうございます!

×