Visio 図面で共同作業を行う

複数のユーザーが 1 つの図 Visio 同時に、それぞれのユーザーが自分のコンピューターで作業できます。 共同編集を行って、チーム メンバーは複数ページの図をすばやく作成し、互いに図の動作を決定するのに役立ちます。

図面を OneDrive for Business または SharePoint Online に保存すると、図面で同僚と同時に作業を行うことができます。 図面を同時に編集するには、Windows 上のすべての作成者が Visio プラン 2 を使用し、Visio デスクトップ アプリを使用する必要があります。

図面を他のユーザーと共有して同時に共同作業する

  1. デスクトップ アプリ Visio 図面を開き、共同作業の準備ができたら、リボンの右上隅にある [共有] を選択します。

    他のユーザーと図面を共有する

  2. [共有] ダイアログ ボックスに、図面を共有する相手のメール アドレスを入力します。

    Visio の [共有] ウィンドウ ダイアログ

    既にユーザーの連絡先情報が保存されている場合は、名前を入力するだけです。 ドロップダウン リストでは、図面を共有する相手を決定することができます。

  3. [送信] をクリックします。

    ファイルが既にクラウドに保存されている場合、招待メールが招待者に送信されます。 図面を OneDrive for Business または SharePoint Online に保存していない場合、Visio で保存を求めるメッセージが表示されます。

    図面を OneDrive または SharePoint に保存していない場合は、Visio で保存するように求められます。

    ファイルをクラウドに保存した後、招待メールが送信されます。

共有図面で編集しているユーザーを表示する

  1. Visio アプリで図面を開き、作業を開始します。 他のユーザーが図面を表示または編集している場合は、リボンの右上隅にユーザーのサムネイル画像が表示されます。 Visio では、ユーザーが図面を表示または終了すると、通知されます。

    現在、図面で作業を行っているユーザーを表示する

  2. コメントを確認および追加するには、[コメント] コメント ウィンドウを開く を選びます。

    コメント ウィンドウ内のコメント

    コメントに返信したり、削除したりすることもできます。

    他のユーザーが図面にコメントした場所を確認する場合は、コメント アイコンをクリックします。

    コメント アイコン

    任意の図形に自分のコメントを追加するには、図形を右クリックして、[コメントの追加] を選びます。

  3. 作業が終わったら、ファイルを保存します。

    自分と他の編集者の更新内容が競合しなければ、変更箇所は自動的に統合され、それ以上操作は必要ありません。

図面ファイルの以前のバージョンを表示する

図面ファイルの以前のバージョン Visio 表示できます。 現在のバージョンの図面ファイルを以前のバージョンに置き換えることができるようになりました。

以前のバージョンの図面ファイルを表示する

  1. [ファイル] タブ>情報>履歴の表示] を選択します

    [.... に保存されているバージョン] ダイアログボックスが開きます。 ファイルの保存済みバージョンが一覧表示され、先頭に現在のバージョンが表示されます。

  2. 表示するファイルのバージョンを選択します。

  3. [開く] を選びます。

    そのバージョンの読み取り専用ビューが新しいウィンドウで Visio されます。

  4. ファイルの以前>読み取り専用の確認が完了したら、[ファイルを閉じる] を選択します。

以前のバージョンの図面ファイルを復元する

  1. [ファイル] タブ>情報>履歴の表示] を選択します

    [.... に保存されているバージョン] ダイアログボックスが開きます。 ファイルの保存済みバージョンが一覧表示され、先頭に現在のバージョンが表示されます。

  2. 現在のバージョンにするファイルのバージョンを選択します。

  3. [復元] を選択します

    メッセージ ボックスに、現在のバージョンのファイルを選択した以前のバージョンに置き換える必要がある確認が表示されます。

  4. [OK]を選択して、変更を行う必要を確認します。

    開いている図面ファイルが更新され、新しい現在のバージョンとして選択したファイルのバージョンが反映されます。

Web 用 Visio の共同編集機能を使用すると、他のユーザーと同時に図を編集できます。 図が SharePoint または 職場または学校の OneDriveにオンラインで保存されている場合、他のユーザーを招待して、スレッド化された会話の一部として、図の作成、編集、確認、コメントの追加を簡単に行うことができます。 

SharePoint または OneDrive を持つ他のユーザーと図を共有する

他のユーザーと図面を共有するには、図面へのリンクを電子メールで送信します。

  1. Web 用 Visio で図面を開きます。

  2. 次のいずれかの操作を行います。

    • 図を表示している場合は、[共有] [共有] を選択します。

    • 図を編集している場合は、[ファイル]、[共有]、[ユーザーと共有] の順に選択します。

      [ユーザーと共有] オプション。

  3. [共有] ダイアログ ボックスで、[送信] を選択します。

SharePoint または OneDrive を持っている他のユーザーと共有する

リンクを送信することで、図を共有できます。 他のユーザーは、デスクトップ アプリを持っていなくても、任意の web ブラウザー Visio できます。 次の手順では、管理者が外部共有を有効にする必要 Microsoft 365 の SharePoint。 詳細については、次を参照してください

  1. Web 用 Visio で図面を開きます。

  2. 次のいずれかの操作を行います。

    • 図を表示している場合は、[共有] [共有] を選択します。

    • 図を編集している場合は、[ファイル]、[共有]、[ユーザーと共有] の順に選択します。

  3. [共有] ダイアログ ボックスで、[リンクのコピー] を選択します。

    ダイアグラム ファイルをポイントするリンクを送信する [共有] ダイアログ ボックス。

図を他のユーザーと共有 Microsoft Teams

他のユーザーと図を共有するには、次の Microsoft Teams。 

ファイルが Teams チャネルで利用できる場合:

  1. Teams チャネルに移動し、共有Visio 図面を選択します。

  2. 次のいずれかの操作を行います。 

    1. リボンの [リンクのコピー]を選択します

      [リンクのコピー] ボタン。

    2. ファイル名 の横 にある [詳細](...)オプションを選択し、[リンクのコピー]を選択します。 

      リンクをコピーするための Microsoft Teams のその他のオプション。

  3. ダイアログ ボックスで、アクセス許可を設定し、[コピー] を 選択します

    必要なアクセス許可を設定し、[コピー] ボタンを選択します。

上記のいずれかの方法でファイルへのリンクが既にある場合は、次の操作を行います。 

  1. Teams チャネルまたはチャット内の他のユーザーにリンクを送信します。

  2. ファイルが送信された後、ファイルを開く他のユーザーは、その他のオプションから選択し 、[Teams で編集] も選択できます。

図面を同時に共同編集する

編集権限とライセンスを持Web 用 Visio ユーザーは、共有されているファイルを共同編集できます。

  1. 自分と共有されているダイアグラム リンクを開きます。

  2. [ダイアグラム の編集] > ブラウザーで編集] を選択します

    [ブラウザーで編集] オプション。

  3. 中断することなく、通常と同じ方法で変更を行います。

他のユーザーが文書内のどこにいるか確認する

現在の共同編集者がツール バー リボンの横に表示されます。 プレゼンス インジケーター を使用 すると、他の共同作成者がキャンバス内で作業している場所を確認できます。 たとえば、共同編集者がオブジェクトを選択すると、オブジェクトの境界ボックスに色付きの枠線が表示されます。

図形ボックスの色付き枠は、別のユーザーが図形で作業している場合を示します。

また、共同編集者が複数の図形または不連続の図形を選択すると、各図形のプレゼンス境界と、グループの選択境界が表示されます。 

色付き罫線は、別の作成者が複数の図形を選択した場合に示されます。

コメントを操作する

図には、編集モードと表示モードの両方でコメントを入力できます。 図形やページ全体にコメントを追加できます。 図形にコメントを追加すると、その図形が移動しても、そのコメントは図形と一緒に残されます。 

表示モードの場合:

  1. 表示のために図面を開きます。

  2. [その他のコマンドを表示] (...)、[コメント] の順に選択します。

    省略記号メニューの下の [コメント] を選択します。

    [コメント] ウィンドウが表示されます。

  3. 自分のコメントを追加し、他のユーザーのコメントを表示します。 [データ の更新] を使用 して、他のユーザーからのコメントを読み込む。

編集モードの場合:

  1. コメントを追加する図形を選択するか、ページの空白領域をクリックします。ページにコメントを追加するために何も選択されません。

  2. 次のいずれかの操作を行って、コメントを追加します。

    • [レビュー ] タブで 、[新しい コメント] を選択し 、コメントを追加します。

      [新しいコメント] ボタン。

    • ページの右上隅で、[コメント] タブの[新しいコメント>を選択し、コメントを追加します。

      [新しいコメント] ボタン。

  3. 次の 2 つのボタンを使用して、コメントに返信したり、コメントを削除したりすることもできます。

    コメントに返信し、コメントを削除するためのボタン。

  4. 他のユーザーのコメントは、表示されたページ上または図形上に表示できます。

共同編集中に発生する可能性があるメッセージ

  • 図を編集している場合、編集の競合が発生する可能性を最小限に抑えるために、10 分間操作を行っていなきセッションがタイムアウトになります。 次の場合に表示されるメッセージバーで[作業の続行] を選び、編集を続けできます。

    Visio Online セッションが 5 分以上アイドル状態のときに表示されるメッセージ。

  • 共同編集中に、最後の操作が完了していな Visio。 これは、自分と共同編集者が競合する方法で同じオブジェクトを変更しようとしているときに発生します。 同じダイアグラムで作業を続け、最後の操作を再度実行する必要があります。 ポップアップ メッセージが自動的に消えます。

    Visio ファイル内の複数のユーザーによる変更の競合に関するエラー メッセージ。

  • ユーザーの言語設定が異なる共同編集セッションでは、Visio は特定のステンシルの図形テキストのみを 1 つの言語で表示できます。 Visio は、最初にステンシルから図形をキャンバスにドラッグするセッションのユーザーの言語設定を使用します。 

    ユーザーが別の言語で共同編集している場合に表示されるエラー メッセージ。

  • 別のユーザーがデスクトップ アプリで Visio 図面を既に編集している場合に、ブラウザーで図面を編集しようとすると、図面が編集用にロックされ、メッセージ ボックスが表示されます。 そのような場合は、デスクトップ ユーザーにファイルを閉じるか、メッセージ ボックスの指示に従って操作します。

    ロック エラーを説明するメッセージ ボックス。

    • 図面を表示するには、[閲覧表示で開く] を選択します。

    • 図のコピーをライブラリまたはフォルダーに SharePoint するには 職場または学校の OneDrive を 選択します

図の作業を行うすべてのユーザーが、コンピューターに Visio Professional エディションをインストールしている必要があります。

共同編集用に図を設定する

  1. SharePoint ライブラリで Visio 図面を作成するか、 Visio で図面を開始し、その図面を OneDriveにアップロードします。

  2. 作業を行うすべてのユーザーに編集権限を付与します。

各作成者は、サーバーから図を開き、 Visio 、編集、または確認を開始します。 隅にある通知は、誰かがセッションに参加またはセッションから離れるときに表示されます (つまり、基本的に、編集用にダイアグラムを開く、または閉じるという意味です)。 ダイアグラムで作業しているユーザーの数は、いつでもステータス バーに表示されます。

変更が図に表示される方法

他のユーザーが何らかの方法で編集した図形によって小さいアイコンが表示されます。 編集中のアイコンを含む図形はロックされません。たとえば、他のユーザーが色を変更している場合でも、図形上のテキストを同時に編集できます。 チームの全員が共同作業を行い、特定の領域で作業している場合、同じ図形上のテキストを変更する場合など、2 人のユーザーがまったく同じ情報を同時に編集する問題はめったにありません。 その場合、最後の変更はそのまま残ります (他のユーザーがもう一度変更するまで)。

図面に加えた変更を保存すると、Visio によって変更内容がサーバーに同期されます。 同時に、Visio では、他のユーザーが行った変更が図面のコピーに取り込まれています。 他のユーザーが変更をサーバーに保存し戻した場合は、アイコンが表示され、ステータス バーに更新プログラムが利用可能なことを通知する通知が表示されます。 頻繁に保存して、他の作成者が加えた最新の変更を確認し、変更を利用できます。

関連項目

Web 用 Visio で図面を表示、作成、編集する

Microsoft 365 で SharePoint のファイルやフォルダーを共有する

Web 用 Visio のヘルプ

ヘルプを表示

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×