メイン コンテンツへスキップ
サポート
Microsoft アカウントでサインイン
サインインまたはアカウントを作成してください。
こんにちは、
別のアカウントを選択してください。
複数のアカウントがあります
サインインに使用するアカウントを選択してください。

現象

たとえば、次のような状況を想定します。

  • プリンターをインストールするには、Windows 7 または Windows Server 2008 R2 を実行しているコンピューター上のボックスでプリンター ドライバーを使用します。

  • までファイルの更新プログラムを含む新しいまたは更新されたプリンター ドライバーをインストールするとします。

  • ボックスでプリンター ドライバーを使用して印刷待ち行列のプロパティを変更しようとするとします。

このシナリオ、Windows エクスプ ローラーがクラッシュする、次のエラー メッセージが表示されます。

Windows エクスプ ローラーが動作してをいません。

Windows では、問題の解決策をオンラインで確認でき、プログラムの再起動を試行することができます。


注: までを更新するプロセスのいくつかの状況から、この問題が発生します。たとえば、Windows service pack、更新プログラムのロールアップ パッケージ、またはサードパーティ製のプリンター ドライバーをインストールします。

原因

この問題は、新しいバージョンまでの既存の印刷キューの更新をトリガーするために発生します。この更新プロセスは、レジストリの値をボックスでドライバーを使用する印刷キューに追加するドライバーのアップグレードを開始します。

解決策

Important
このセクションの手順の実行には注意が必要です。レジストリを誤って変更すると、深刻な問題が発生することがあります。前に変更する、復元用のレジストリをバックアップする問題が発生する場合に。

自動的にこの問題を解決するには、「自動修正」セクションに進みます。自分でこの問題を解決する場合は、「自分で解決する」セクションに移動します。


Fix it で解決する

この問題を解決するには、問題を修正] ボタンまたはリンクをクリックします。ファイルのダウンロード] ダイアログ ボックスで、[実行を] をクリックし、それを修正するウィザードで手順を実行します。



  • このウィザードは英語版のみである場合があります。しかし、自動的な解決は英語版以外の Windows でも機能します。

  • 問題が発生しているコンピュータで作業していない場合は、Fix it ソリューションをフラッシュ ドライブまたは CD に保存して、問題のあるコンピューターで実行してください。

  • フィードバックをお待ちしております。フィードバックを提供する、またはこのソリューションに関連する問題を報告するには、「Fix it for me」ブログにコメントを残すか、電子メール メッセージを送信してください。



この問題を解決するには、ドライバーのアップグレードによって追加されるレジストリ エントリを削除します。これを行うには、以下の手順を実行します。

  1. デバイスとプリンター] を開くし、し、問題の印刷キューのプリンター名を識別します。

    この例では、「HP レーザー ジェット 4100 シリーズ PCL6」が問題のあるプリンターを特定します。


  2. レジストリ エディターを開きます。これを行うには、[スタート] ボタンし、[検索] ボックスで、 regedit.exeを入力し、Enter キーを押します。

  3. 検索して、次のレジストリ キーを展開します。

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers

  4. 手順 1 で指定されている問題のあるプリンターと同じ名前を持つレジストリ サブキーを展開し、[ PrinterDriverData] をクリックします。


  5. PrinterDriverDataのレジストリ サブキーをバックアップします。これを行うには、以下の手順を実行します。

    • PrinterDriverDataを右クリックし、[エクスポート] をクリックします。

    • [ファイル名] ボックスで、エクスポートしたレジストリ キーを使用する名前を入力します。

    • エクスポートし、選択したレジストリ キーを保存する保存をクリックします。

  6. 右側のウィンドウで、 DMCExistレジストリ値を右クリックし、[削除] をクリックします。削除の確認メッセージが表示されたら、[はい] をクリックします。

    注: 1 つ以上の印刷キューには、同じ問題が発生する場合は、これらのプリンターの手順と同じ手順を繰り返します。

  7. レジストリ エディターを終了します。

  8. 停止し、印刷スプーラー サービスを再起動します。これを行うには、次の方法のいずれかを使用します。

    方法 1: は、[サービス] コンソールを使用します。

    1. [スタート] ボタンや、[検索] ボックスにservices.mscと入力し、Enter キーを押します。

    2. 印刷スプーラーを開き停止、] をクリックし、[開始] をクリックします。

    方法 2: コマンド プロンプトを使用します。

    1. 管理者特権でコマンド プロンプトを開きます。

    2. 印刷スプーラー サービスを停止するのには次のコマンドを実行します。

      Net Stop Spooler

    3. 印刷スプーラー サービスを開始するのには次のコマンドを実行します。

      Net Start Spooler

  9. 問題が解決されたことを確認するをテストします。


この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

ヘルプを表示

その他のオプションが必要ですか?

サブスクリプションの特典の参照、トレーニング コースの閲覧、デバイスのセキュリティ保護方法などについて説明します。

コミュニティは、質問をしたり質問の答えを得たり、フィードバックを提供したり、豊富な知識を持つ専門家の意見を聞いたりするのに役立ちます。

この情報は役に立ちましたか?

言語の品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?
[送信] を押すと、Microsoft の製品とサービスの改善にフィードバックが使用されます。 IT 管理者はこのデータを収集できます。 プライバシーに関する声明。

フィードバックをいただき、ありがとうございます。

×