コンポーネントが見つからないため、ソリューションのインポートが失敗する

この記事では、Microsoft Dynamics 365でソリューションをインポートしようとしたときに発生する可能性があるソリューション [ソリューション名] のインポートに失敗したエラーの解決策について説明します。

適用対象:Microsoft Dynamics 365
元の KB 番号: 4346030

現象

Microsoft Dynamics 365でソリューションをインポートしようとすると、インポートが失敗し、次のメッセージが表示されます。

ソリューション [ソリューション名] のインポートに失敗しました。 次のコンポーネントはシステムに存在せず、ソリューションには含まれていません。 これらのコンポーネントを含むマネージド ソリューション ([不足しているソリューションの名前] ([ソリューション バージョン])) をインポートし、もう一度ソリューションをインポートしてみてください。

エラー コード 8004801d への参照が表示される場合もあります。

原因

このエラーは、Microsoft Dynamics 365 organizationにない他のコンポーネントに依存するソリューションをインポートしようとしている場合に発生します。

例: カスタム エンティティ (ウィジェット) を含むソリューション (ソリューション A) を作成した開発環境があります。 ソリューション A のコンポーネントに依存する別のソリューション (ソリューション B) を作成しました (たとえば、Widget エンティティに新しいフィールドを追加しました)。 ソリューション A がまだインストールされていない別のorganization (運用organizationなど) にソリューション B をインポートしようとすると、このエラーが発生します。

解決方法

[インポート] ダイアログに表示されている不足しているコンポーネントの詳細を確認します。 このソリューションをインポートしようとしているorganizationにまだインポートされていない他のソリューションが一覧表示されている場合は、このソリューションをインポートする前に、まずそれらのソリューションをインポートしてください。

例: 上記の「原因」セクションの例を続けると、不足しているコンポーネントの一覧に、マネージド ソリューション列がソリューション A を参照する 1 つ以上の行が表示される場合があります。これは、ソリューション B を正常にインポートする前に、前述のバージョンのソリューション A をインポートする必要があることを示します。

詳細

エラー メッセージが Microsoft ソリューションを参照している場合は、次のソリューションの一覧と、ターゲット organizationにインストールされていない場合に見つかる場所を参照してください。

Dynamics 365の LinkedIn Sales Navigator

ソリューション名:

  • LinkedInSalesNavigatorControlsForUnifiedClient

  • LinkedIn

  • msdyn_LinkedInSalesNavigatorAnchor

    注:

    これらのソリューションをアンインストールする場合は、上記の一覧の順序でアンインストールする必要があります。