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「解決方法」に記載の修正プログラムを適用すると、エンタープライズ シングル サインオン (ENTSSO) サービスはメモリ リークを発生します。そのため、以後の修正プログラムをインストールすることをお勧めします。

現象

次のような状況を考えます。

  • Microsoft BizTalk Server 2013年の R2、または Host Integration Server 2013 に含まれるエンタープライズ シングル サインオン (SSO) バージョン 5 のコンポーネントをインストールしました。

  • 次のシナリオの 1 つは、マスター シークレット キーを復元するバックアップ ファイルから。

    • エンタープライズ SSO クラスターを設定する場合

    • エンタープライズ SSO の災害復旧時に

    • エンタープライズ SSO サーバーをマスター シークレット サーバー (MSS) を推進しているとき

    • エンタープライズ SSO の以前のバージョンからの移行時に

    • エンタープライズ SSO の以前のバージョンからのインプレース アップグレード中に

    • 複数のエンタープライズ SSO の V5 の復元とバックアップのシーケンスを実行するとき

これらのシナリオのいずれかにマスター シークレット キーを復元した後、エンタープライズ SSO は、エンタープライズ SSO データベースに格納されているデータを暗号化解除できません。エンタープライズ SSO では、このような状況で、アプリケーション ログに次のイベントが記録されます。

イベント ID: 10536
ソース: ENTSSO
レベル: 警告
SSO 監査機能: GetConfigInfo ({11111111-6055-4cda-89CD-389E8A2B1640}) の追跡 ID: b084f15b-43fd-474e-a075-398943753c91 クライアント コンピューター: コンピューター名 (実行可能ファイル名: PID) クライアント ユーザー: ユーザー名アプリケーション名: アプリケーション名のエラー コード: 0x80090005、不正なデータです。

さらに、BizTalk Server 管理 MMC スナップインを開くと、次のポップアップ エラーが記録されます。

BizTalk Server 管理
不正なデータです。
(WinMgmt)
ボタン:
わかりました

原因

エンタープライズ SSO V5 では、マスター シークレット キー、キーの有効期間を制限するためにタイムスタンプを追加します。さらに、マスター シークレット キーがタイム ・ スタンプを含めるかどうかを判断するチェックが追加されました。「現象」に記載されている問題は、エンタープライズ SSO サービスがマスター シークレット キーを復元する場合、タイム ・ スタンプが欠けていると誤って判断するために発生します。タイム ・ スタンプは、復元されたマスター シークレット キーに追加された、ために、復元したキーにはエンタープライズ SSO データベース内のデータの暗号化に使用されるキーが一致しません。したがって、データの暗号化を解除できませんと、これが起動する前に説明したエラー メッセージ。

解決策

修正プログラムの情報

サポートされている修正プログラムは、マイクロソフトから入手可能です。ただし、この修正プログラムは、ここで説明する問題のみを修正することを目的としたものです。この問題を防ぐためにすべてのエンタープライズ SSO V5 システムにし、この問題が既に発生しているすべてのシステムには、この修正プログラムを適用します。この修正プログラムには、追加の操作を防止し、問題を解決するのには必要ありません。

修正プログラムをダウンロードできる場合は、本サポート技術情報の資料の上部に「修正プログラムをダウンロードできます」というセクションがあります。このセクションが表示されていない場合は、マイクロソフト カスタマー サービス サポートにリクエストを送信し、修正プログラムを入手してください。

注 さらなる問題が発生した場合、またはトラブルシューティングが必要な場合には、別のサービス リクエストの作成が必要な場合があります。この修正プログラムの対象外の追加の質問および問題については、通常のサポート料金が適用されます。マイクロソフト カスタマー サービス サポートの電話番号一覧または別のサービス リクエストの作成については、次のマイクロソフト Web サイトを参照してください。

http://support.microsoft.com/contactus/?ws=support

注 「修正プログラムのダウンロード利用可能」フォームは、修正プログラムで利用可能な言語を表示します。お使いの言語が表示されない場合は、その言語の修正プログラムが利用できないためです。

必要条件

この修正プログラムを適用するには、エンタープライズ シングル サインオンの V5 をいる必要があります (9.0.2096) をインストールします。

再起動に関する情報

この修正プログラムの適用後、コンピューターの再起動が必要な場合があります。

ファイル情報

修正プログラム (英語版) のファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時間の時差を確認するには、コントロール パネルの [日付と時刻] で、[タイム ゾーン] タブを使用します。

32 ビット (x86) バージョン

ファイル名

ファイル バージョン

ファイル サイズ

日付

時刻

プラットフォーム

Infocache.dll

9.0.2187.0

130,536

01-Oct-2014

22:00

x86

Microsoft.enterprisesinglesignon.systemmmc.dll

9.0.2187.0

198,632

01-Oct-2014

22:00

x86

Ssoss.dll

9.0.2187.0

113,128

01-Oct-2014

22:00

x86

64 ビット (x64) バージョン

ファイル名

ファイル バージョン

ファイル サイズ

日付

時刻

プラットフォーム

Infocache.dll

9.0.2187.0

130,536

01-Oct-2014

22:00

x86

Microsoft.enterprisesinglesignon.systemmmc.dll

9.0.2187.0

198,632

01-Oct-2014

22:00

x86

Ssoss.dll

9.0.2187.0

113,128

01-Oct-2014

22:00

x86

Infocache.dll

9.0.2187.0

151,528

01-Oct-2014

22:00

x64

Microsoft.enterprisesinglesignon.systemmmc.dll

9.0.2187.0

198,632

01-Oct-2014

22:00

x86

Ssoss.dll

9.0.2187.0

124,392

01-Oct-2014

22:00

x64


注のためファイルの依存関係、これらのファイルを含む最新の修正プログラム可能性があります追加されています。

状況

マイクロソフトは、この問題を「対象製品」セクションに記載されているマイクロソフト製品の問題として認識しています。

詳細

その他の変更を必要とせず、問題が発生しているエンタープライズ SSO サーバーにこの更新プログラムを適用できます。さらに、マスター シークレット キーの復元操作を実行するときに問題を防ぐためのすべてのエンタープライズ SSO V5 システムにこの更新プログラムを適用する必要があります。

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