電話とタブレットのMicrosoft Dynamics CRMは、TokenLifetime の長さのために Dynamics CRM organizationに接続できません

この記事では、電話とタブレットのMicrosoft Dynamics CRMプロパティの長さのために Dynamics CRM organizationに接続できない問題の解決策についてTokenLifetime説明します。

適用対象: Microsoft Dynamics CRM 2013、Microsoft Dynamics CRM 2013 Service Pack 1
元の KB 番号: 3034570

現象

Microsoft Dynamics CRMモバイル クライアント アプリケーションのいずれかでMicrosoft Dynamics CRM organizationを設定しようとすると、認証は終わりのないループに入り、アプリケーションが何らかの認証を実行しようとしているように見えますが、完了しません。

原因

証明書利用者の AD FS のプロパティの TokenLifetime 既定値よりも大きいと、この認証ループが発生する可能性があります。

解決方法

の推奨値 TokenLifetime は既定値の 0 に設定する必要があります。これは、600 分または 10 時間を意味します。 代わりに、フェデレーション サービスで SSOLifetime オプションを使用すると、これらのMicrosoft Dynamics CRMモバイル アプリケーションでユーザーが資格情報を頻繁に導入する必要がなくなります。 SSOLifetime の既定値は 480 分または 8 時間です。

詳細

ADFS の SSO Lifetime プロパティを変更する方法については、「 Set-ADFSProperties」を参照してください。

PowerShell を TokenLifetime 使用して ADFS 証明書利用者のプロパティを変更する方法については、「 要求ベースの認証とセキュリティ トークンの有効期限」を参照してください。