デスクトップ フロー実行キュー エラーのトラブルシューティング

この記事では、デスクトップ フローの実行中に発生したキュー ベースのエラーの背景と潜在的な解決策について説明します。

適用先:Power Automate
元の KB 番号: 5004537

現象

デスクトップ フローは、エラー コード NoCandidateMachine またはエラーの詳細 "デスクトップ フローを実行できるコンピューターが見つかりませんでした" で実行できない可能性があります。

次の一般的なサブエラー コードのいずれかが表示される場合もあります。

  • SessionExistsForTheUserWhenUnattended
  • NoUnlockedActiveSessionForAttended
  • UIFlowAlreadyRunning

原因

使用可能なマシンがない場合、Power Automate は、実行を待機しているデスクトップ フローを保持するキューを作成します。 マシンが使用可能になると、次のデスクトップ フロー実行が選択され、 優先順位 と要求時間に基づいて実行されます。 要求されてから 6 時間後にコンピューターが使用できない場合、デスクトップ フローはタイムアウトし、エラー コードで NoCandidateMachine 失敗します。

エラー メッセージで説明したように、このエラーは、オーケストレーターがデスクトップ フローを実行するために使用可能なマシンを見つけることができないことを意味します。 このエラーは、デスクトップ フローの実行が開始される前に発生します。

重要

Power Automate では、同時デスクトップ フロー実行の数がサポートされている最大値に自動的にスケーリングされます。 マシン実行キューは、先入れ先出しのアプローチに従います。つまり、受信した最初の実行が次に実行されることを意味します。 使用可能なすべてのマシンが最大同時セッションに達し、キューで次の実行を実行できない場合、マシンがキューで次の実行を実行できるようになるまでキューはブロックされます。

解決方法

次のサブエラー コードでエラーを解決するには、次の手順を試してください。

SessionExistsForTheUserWhenUnattended

これは、デスクトップ フロー接続で使用されるユーザーがログインしているターゲット コンピューターで無人デスクトップ フローを実行しようとすると発生します。

解決方法

この問題を解決するには、セッションからサインアウトし (ロックされたセッションによってこのエラーが発生します)、コンピューター上の同じユーザーとログインしていないことをチェックします。

NoUnlockedActiveSessionForAttended

通常、このエラーは、ロックされているか、ユーザーがサインインしていないターゲット コンピューターで参加済みデスクトップ フローを実行しようとすると発生します。 このエラーは、ターゲット コンピューターに現在ログインしている Windows ユーザーが、接続で入力したユーザーと一致しない場合にも発生します。 参加済みデスクトップ フローは、現在のユーザーがデスクトップ フロー接続のユーザーと一致するセッションでマシンのロックが解除されている場合にのみ実行できます。

解決方法

この問題を解決するには、

  • 接続で使用されている資格情報を確認し、ロック解除されたセッションで使用される資格情報であることを確認します。 任意のコマンド プロンプトに「」と入力 whoami することで、ID を確認できます。
  • 適切なマシンをターゲットにしていることを確認します。 これを行うには、マシン ランタイム アプリケーションを開き、[ ポータルでコンピューターを表示 ] を選択して、実行で対象としているマシンに表示されることを確認します。
  • Power Automate サービス (UIFlowService) を実行するアカウントに、コンピューターに対するリモート デスクトップアクセス許可があることを確認します。 既定では、Power Automate サービスは として NT SERVICE\UIFlowService実行されます。 これを変更しなかった場合は、それが NT SERVICE\UIFlowService[リモート デスクトップ ユーザー ] グループにあることを確認します。 これを行うには、[Start Run]\(実行の開始\>) に移動し、「usrmgr.msc」と入力し、[グループ] を選択し、[リモート デスクトップ ユーザー] グループをダブルクリックして、アカウントが含まれていることを確認します。 含まれていない場合は、それを含め (管理者のアクセス許可が必要です)、コンピューターを再起動します。

UIFlowAlreadyRunning

コンピューターでデスクトップ フローが既に実行されている場合、このエラーは次のいずれかの状況で発生する可能性があります。

  • 参加済みまたは無人のデスクトップ フローを実行し、マシン上のアクティブなセッションの数が上限に達しました。
  • 既にログインしているユーザーのセッションを開こうとします。
解決方法

この問題を解決するには、既に実行されているフローが完了するのを待つか、 親クラウド フローの実行を取り消します

その他のエラー コード

デスクトップ フローの実行中に発生する可能性があるその他のエラー コードと軽減手順については、「 参加しているデスクトップ フローまたは無人デスクトップ フローを実行するときに発生するエラー コード」を参照してください。

詳細

サブエラー コードが指定されていない場合は、次の場合にチェックします。

  • マシンまたはマシン グループ内のすべてのマシンがオフラインです。

    マシンを起動し、Power Automate Desktop が正しくインストールされ、インターネットと通信できることを確認します。

  • マシン グループが空です。

    デスクトップ フロー実行を割り当てる前に、マシン グループに少なくとも 1 つのマシンが含まれていることを確認します。

  • マシンまたはマシン グループ内のすべてのマシンが継続的にビジー状態になります。

    マシンがデスクトップ フローを時間内に受け取らない場合は、割り当てられたマシン リソースがワークフローの需要を満たすのに十分にスケーリングされないためです。 マシンを追加すると、ワークロードの分散に役立つ可能性があります。

  • ネットワーク (プロキシやファイアウォールを含む) の問題のため、マシンにアクセスできません。

    IT 管理者と協力して、マシンに到達できることを確認します。

  • この問題は一時的なものです。

    アクションの設定で 再試行ポリシー を変更してみてください。

  • マシンまたはマシン グループ内のすべてのマシンは、デスクトップ フローに接続できません。

    次のいずれかが満たされていることを確認します。

    • すべてのマシンがログインしているグループで無人フローを実行しようとしているわけではありません。
    • すべてのマシンがサインアウトされているグループで、参加済みフローを実行しようとはしていません。
  • マシンは使用できなくなりました。

    新しいマシンを追加し、クラウド フロー内のデスクトップ フロー接続を更新して、新しいマシンを使用します。

上記のいずれかの理由により、実行キューにデスクトップ フローのバックアップがある場合は、[デスクトップ フローの実行] ページの [親フロー実行の取り消し] アクションを使用して親クラウド フローの実行を取り消すことで、デスクトップ フローの実行を一括で取り消すことができます。 マシンの問題が解決されたら、それらのクラウド フローを再起動できます。