現象

SQL Server を再起動する、SQL Server サービスがオンラインに失敗するし、起動時のログには、次のエラーが含まれています: 17182、17826、または 17120 。

注意事項

  • この問題は、ドメイン アカウントで実行される SQL Server インスタンスでのみ発生します。

  • ログに次のエントリの例のようなメッセージが表示されます。 Time stamp spid9s Error: 17182, Severity: 16, State: 1. Time stamp spid9s TDSSNIClient initialization failed with error 0xffffffff, status code 0x80. Reason: Unable to initialize SSL support. Time stamp spid9s Error: 17182, Severity: 16, State: 1. Time stamp spid9s TDSSNIClient initialization failed with error 0xffffffff, status code 0x1. Reason: Initialization failed with an infrastructure error. Check for previous errors. Time stamp spid9s Error: 17826, Severity: 18, State: 3. Time stamp spid9s Could not start the network library because of an internal error in the network library. To determine the cause, review the errors immediately preceding this one in the error log. Time stamp spid9s Error: 17120, Severity: 16, State: 1. Time stamp spid9s SQL Server could not spawn FRunCommunicationsManager thread. Check the SQL Server error log and the Windows event logs for information about possible related problems.

     

原因

この問題は、通常、SQL サービス アカウントに付与されているアクセス許可が不足しているために発生します。存在する必要がある SQL Server のスタートアップ アカウントのユーザー権利は次のとおりです。

  1. サービス (SeServiceLogonRight) としてログオンします。

  2. (SeAssignPrimaryTokenPrivilege) プロセス レベル トークンを交換してください。

  3. スキャン (SeChangeNotifyPrivilege) のチェックをバイパスします。

  4. プロセスのメモリ クォータを調整します。

解決策

問題を解決するには、SQL サービスのドメイン アカウントにアクセス権を付与します。サービスのアクセス許可の詳細については、サービスのアクセス許可] セクションで、「 Windows サービス アカウントの構成とアクセス許可を参照してください。

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