電話やタブレットの Microsoft Dynamics CRM は、TokenLifetime の長さを失い、Dynamics CRM 組織に接続できません。

現象

Dynamics CRM のモバイル クライアント アプリケーションのいずれかの Microsoft Dynamics CRM 組織をセットアップするとき、認証ループしないで終了するアプリケーションは実行しようとするいくつか、認証しますが、完了しません。

原因

AD FS の TokenLifetime プロパティの既定値よりも大きく、利用者は、この認証のループを引き起こすことができますの。

解決策

TokenLifetime の推奨値は 0 で、600 分または 10 時間の既定値に設定する必要があります。フェデレーション サービスで、SSOLifetime オプションを使用する代わりに防ぐことができますユーザーこれら Dynamics CRM のモバイル アプリケーションでは多くの場合、その資格情報を紹介する必要がなくなります。SSOLifetime の既定値は 480 分、または 8 時間です。

詳細

ADF の SSO の有効期間プロパティを変更する方法: https://technet.microsoft.com/en-us/library/ee892317.aspx

Powershell から ad FS が依存しているパーティの TokenLifetime プロパティを変更する方法: https://technet.microsoft.com/en-us/library/gg188586(v=crm.6).aspx

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