現象
Windows の イメージを展開するために Sysprep ツールを使用して Microsoft Windows XP Service Pack (SP3) のマスター イメージを作成すると、Windows のタスク バー上 の [既定の言語] が [日本語 (日本) - Microsoft Office IME 2010] に設定されず、[日本語 - Microsoft IME 2002] に戻ります。しかし、[テキスト サービスと入力言語] 画面内の [既定の言語] は、[日本語 (日本) - Microsoft Office IME 2010] と設定されています。
原因
システム固有の情報を削除するための Sysprep ツールの一般化プロセスで、デフォルト ユーザー プロファイルへカスタマイズを行ったプロファイルがコピーされますが、Inputlocale が Windows XP の既定の設定に戻ってしまうためにこの現象が発生します。
補足 : Inputlocale は、入力言語と使用する IME の組み合わせを表すプロパティです。
回避策
この現象を回避するには、以下のいずれかの方法を実行してください。
重要 : このセクション、方法、またはタスクには、レジストリの編集方法が記載されています。レジストリを誤って変更すると、深刻な問題が発生することがあります。レジストリを編集する際には十分に注意してください。万一に備えて、編集の前にレジストリをバックアップしておくと、問題が発生した場合にレジストリを復元することができます。バックアップおよび復元方法の詳細を参照するには、以下のサポート技術情報をクリックしてください。
322756 Windows でレジストリをバックアップおよび復元する方法
方法 1 : マスター イメージを作成する前にレジストリを削除する
-
以下のレジストリ値を削除します。
キー :HKEY_CURRENT_USER\Software\Microsoft\IMEJP\14.0値の型 : REG_DWORD
値 : SetPreload -
次に、以下のレジストリ値を 0 から 1 へ変更します。
キー :HKEY_CURRENT_USER\Software\Microsoft\CTF\TIP\{B3209488-CB34-4017-8E13-10CFCA2519FE}\LanguageProfile\0x00000411\{75E61AD7-8D9E-4436-A0BE-2098C0DDA2C1}
値の型 : REG_DWORD
名前 : Enable
データ : 1
キー : HKEY_CURRENT_USER\Software\Microsoft\CTF\TIP\{B3209488-CB34-4017-8E13-10CFCA2519FE}\LanguageProfile\0x00000411\{DAF93FA4-C39D-4AD8-BE61-16A1DFA3A1DA}
値の型 : REG_DWORD
名前 : Enable
データ : 1
方法 2 : Sysprep ツール実行後にレジストリを削除する
Sysprep ツール実行後にこの問題を回避するには、次の手順で操作します。
-
レジストリ エディタを起動します。
-
以下のレジストリ キーを見つけます。
HKEY_CURRENT_USER\Software\Microsoft\IMEJP\14.0 -
以下のレジストリ値を削除します。
値 : SetPreload
値の型 : REG_DWORD -
次に、以下のレジストリ キーを見つけます。
HKEY_CURRENT_USER\Software\Microsoft\CTF\TIP\{B3209488-CB34-4017-8E13-10CFCA2519FE}\LanguageProfile\0x00000411\{75E61AD7-8D9E-4436-A0BE-2098C0DDA2C1}
HKEY_CURRENT_USER\Software\Microsoft\CTF\TIP\{B3209488-CB34-4017-8E13-10CFCA2519FE}\LanguageProfile\0x00000411\{DAF93FA4-C39D-4AD8-BE61-16A1DFA3A1DA} -
以下のレジストリ値を 0 から 1 に変更します。
値の型 : REG_DWORD
名前 : Enable
データ : 1 -
レジストリ エディタを終了し、ログオフします。
-
再度、Windows にログオンします。ログオンにより [既定の言語] に [日本語 (日本) - Microsoft Office IME 2010] が設定されます。
状況
マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。
関連情報
既定の言語に関する問題の関連情報を参照するには、以下のサポート技術情報を参照してください。
896754 Office 2003 をインストールした Windows XP または Windows Server 2003 で Sysprep ツールを使用すると [既定の言語] で IME 2003 よりも古いバージョンの IME に変更される
940898 2007 Office System をインストールした Windows XP または Windows Server 2003 で Sysprep ツールを使用すると [既定の言語] が IME 2002 に戻る
941075 2007 Office System または 2010 Office System がインストールされた Windows で Sysprep ツールを使用すると、以前の IME に戻る