PEC でエンコードされている場合、Emailが Microsoft Dynamics 365 との同期に失敗する
この記事では、PEC でエンコードされたときに電子メールが Microsoft Dynamics 365 と同期できない問題の解決策について説明します。
適用対象: Microsoft Dynamics CRM
元の KB 番号: 4490718
概要
PEC メールとは
PEC メールは、一部の国/地域で使用される認定メールであり、登録済みメール (s/mime) と同じ法的有効性を持ちます。
S/MIME (Secure/多目的インターネット メール拡張機能) は、デジタル署名および暗号化されたメッセージを送信するための、広く受け入れられています。より正確にはプロトコルです。
S/MIME では電子メールを暗号化し、デジタル署名を行うことができます。
現象
PEC 電子メールは、Server-Side 同期またはEmailルーターと同期されません。
原因
Server-Side 同期とEmailルーターでは、Exchange Web サービスを使用してExchange Serverに接続します。
PEC と RFC6109 は REST または SOAP 経由で API を使用しません。たとえば、Server-Side 同期やルーター Emailではこれらの電子メールを正しく同期できません。
解決方法
電子メールが暗号化されると、そのメールの受信者に送信されるトークンが作成されます。
この 1 対 1 の関係により、ユーザーは別のユーザーにメールを送信し、暗号化することができます。
暗号化された電子メールが送信されるとどうなりますか。
Dynamics はサード パーティのアプリケーションであるため、電子メールにアクセスしようとすると、この電子メールは暗号化された状態でのみ取得されます。
トークンはDynamics 365に存在しないため、電子メールは暗号化解除されません。
- 一意の暗号は、電子メール メッセージを暗号化します。
- 電子メールは暗号テキストにエンコードされます。
- Emailが送受信されます。
- 受信者は、メッセージをデコードする暗号キーを入力します。
PEC と RFC6109 は REST または SOAP 経由で API を使用しません。たとえば、Server-Side 同期や Email ルーターでは同期にこの電子メールの種類がサポートされていません。
このメールをDynamics 365組織と同期するには、電子メールから暗号化を削除する必要があります。これは、電子メールを転送することで実現できます。