未払金管理で EFT 支払を処理するときに、0 ドルの送金が Batch Recovery に移動する

この記事では、Microsoft Dynamics GP の買掛金管理で EFT 支払を処理するときに、0 ドルの送金が転記されず、バッチ復旧に進まない問題の解決策について説明します。

適用対象: Microsoft Dynamics GP
元の KB 番号: 2506000

現象

Microsoft Dynamics GP の買掛金管理で電子資金移動 (EFT) のバッチチェックコンピューターを転記すると、有効な EFT がポストされます。 ただし、0 ドルの送金はポストされず、バッチ復旧に移動します。

原因

この動作は、次の条件に該当する場合に発生する可能性があります。

  • Checkbook セットアップで独自の EFT チェック番号を使用します
  • [次の EFT 支払番号] フィールドの値には、プレフィックス REMIT が含まれています
  • チェック ブックが [重複チェックを許可しない] にマークされている

転記の問題は、新しい REMIT 番号が過去に既に使用されている場合に発生する可能性があります。 EFT の次の番号は、小切手帳電子資金マスタ (CM00101) テーブルに格納されます。 ただし、チェック番号をゼロドル送金に割り当てるプロセスは、PM キー (PM00400) テーブルに移動し、最後に使用された最大 REMIT 番号を取得します。 この 2 つが重複し、重複が発生する可能性があります。これにより、そのチェックブックで重複チェックが許可されていないため、これらのトランザクションは Batch Recovery に移動します。

解決方法

バッチが Batch Recovery にある場合は、次の手順を使用して問題を解決します。 ただし、バッチを既に転記している場合は、手順 3 に進み、今後のチェックランで 0 ドルの送金が Batch Recovery に送信されないようにします。

  1. Batch Recovery でバッチを処理します。 これを行うには、Microsoft Dynamics GP メニューの [ツール] をポイントし、[ ルーチン] をポイントし、[ Batch Recovery] を選択します。 バッチを選択し、[ 続行] を選択します。

    注:

    バッチが Batch Recovery を終了しない場合は、次の記事の手順に従って、SQL Server Management Studioを使用してバッチを [使用可能] 状態に戻します。
    バッチは、Microsoft Dynamics GP の [転記]、[受信]、[ビジー]、[マーク済み]、[ロック済み]、または [編集済み] の状態で保持されます

  2. [買掛金バッチ入力] ウィンドウで、バッチを選択し、[転記] を選択 します

    注:

    0 ドルの送金が、チェック バッチ内の唯一のトランザクションである場合は、PM Keys テーブルで最後に使用された REMIT 番号を正しくインクリメントできるため、2 回目のトランザクションを転記する必要があります。

  3. 小切手帳の次の EFT 支払番号を、別のプレフィックスで開始するように変更します。 これを行うには、次の手順を実行します。

    1. [ カード] を選択し、[ 財務] をポイントし、[ 小切手] を選択します。
    2. [Checkbook ID] を選択します
    3. [ EFT Bank]\(EFT 銀行 \) ボタンを選択し、[ 買掛金][オプション] の順に選択します。
    4. [EFT 支払番号] セクションで、プレフィックスREMIT[NEXT EFT 支払番号] フィールドなどのEFT別のプレフィックスに置き換えます。
    5. [ OK] を選択 してウィンドウを閉じます。 もう一度 [OK] を 選択し、[保存] を選択 します