現象
10 の Windows ベースのコンピューターに更新プログラムをインストールした後は、リモート デスクトップ プロトコル (RDP) クライアントを使うことはできません。 さらに、以下のエラー メッセージが表示されます。
リモート デスクトップ接続 リモート デスクトップ サービス ActiveX コントロール (mstscax.dll) がクライアントのシェル.のバージョンと一致しません。
原因
Mstsc.exe と mstxcax.dll ファイルが置き換えされたコンピューターでこの問題が発生します。これらのファイルの以前のバージョンです。オペレーティング システムの以前のバージョンからのファイルを置き換えることはサポートされておらず、予期しない動作につながることができます。その結果、今後更新すると、KB4284835 がインストールされているなど、ファイルの不一致エラーが発生します。
例: 上の Windows 10 バージョン 1803 ベースのコンピューターは、Windows 10、1709 のバージョンからのファイルの mstsc.exe と mstscax.dll を交換したと言います。 KB 4284835 の更新プログラムをインストールした後は、KB 4284835 の更新は、mstsc.exe を更新し、mstscax.dll が更新されないために、問題が発生します。
解決方法
以前のバージョンのバイナリを置き換えることはサポートされていません。 この手順では、役立つ場合がありますが、mstsc.exe と mstscax.dll が古いバージョンに置き換えがあったクライアント コンピューターでのみ使用する必要があります。
Gは、この問題を解決するのには o が元のファイル バージョンでは、バックアップし、KB 4284835 をインストールします。これを行うには、以下の手順:
-
所有権を取得し、mstsc.exe と mstscax.dll のフル コントロール アクセス許可を付与します。
-
問題の原因となった更新プログラムをアンインストールします。
-
%Windir%\system32フォルダーに元の Windows 10 バージョン 1803 ファイル (mstsc.exe と mstscax.dll) を復元します。
-
コンピューターを再起動します。
-
更新プログラムを再インストールします。
-
コンピューターを再起動します。