Microsoft Dynamics CRM 2011 クイック 検索は、Web と CRM for Outlook クライアントによって異なります

この記事は、Microsoft Dynamics CRM 2011 Web クライアントまたは Microsoft Dynamics CRM 2011 for Outlook クライアントでクイック検索を実行するときに発生する問題を解決するのに役立ちます。

適用対象: Microsoft Dynamics CRM 2011、Microsoft Office Outlook 用 Microsoft CRM client
元の KB 番号: 2669792

現象

Microsoft Dynamics CRM 2011 Web クライアントまたは Microsoft Dynamics CRM 2011 for Outlook クライアントでクイック検索を実行すると、異なる結果が得られる場合があります。

たとえば、Account エンティティを開き、次のアカウント名を持つ 3 つのアカウントを作成します。

  • テスト サンプル 1
  • サンプル 1
  • 1 つのサンプル

このシナリオでは、ユーザーが検索文字列sampleを使用して CRM Web クライアントの取引先企業のクイック検索を検索する場合、クエリでは、 の検索と同様に、追加されたサフィックスワイルド カードで検索sample*され、1 つのレコードが返されます。

ただし、ユーザーが検索文字列sampleを使用してアカウントのクイック検索を使用して Outlook クライアントで検索した場合、クエリでは、検索と同様に、付加されたプレフィックスサフィックスワイルド カードで検索*sample*され、3 つのレコードすべてが返されます。

原因

Microsoft Dynamics CRM 4.0 では、検索は CRM サーバーによって処理されたため、検索機能によって Outlook クライアントと Web クライアントで同じ結果が生成されました。 ただし、Microsoft Dynamics CRM 2011 Outlook クライアントでは Outlook との統合が充実しているため、クライアントは Outlook の組み込み検索機能を利用できるため、検索範囲を拡大できます。

解決方法

Web クライアントは、サブ文字列、プレフィックス、サフィックスのワイルド カードを使用した同様の検索機能と、Advanced Find を使用した他の条件に対応しています。

Web クライアント内から Outlook クライアントの検索動作をエミュレートするには、検索文字列の先頭に文字を入力 * します。

Advanced Find を使用して、Contains、Equals、Begins With、Ends With、Not Contain Data などの追加の文字列条件を利用することもできます。これは、検索文字列に使用できます。

詳細

Dynamics CRM 2011 Update Rollup 12 以降では、この機能が変更され、同様のロジックを使用して CRM クライアント for Outlook と CRM Web クライアント検索でクイック検索が行われます。 更新プログラムロールアップ 12 以降では、現在のビューの結果内で検索するのではなく、クイック検索を実行するときに、定義されたクイック検索ビューを使用する OUTLOOK 用 CRM クライアントが作成されます。