Microsoft Dynamics 365 App for Outlook を使用しようとすると、特権エラーが発生する
この記事では、Microsoft Dynamics 365 App for Outlook を使用しようとすると、必要な特権 (prvReadOrganization) エラーが発生する可能性がある問題の解決策について説明します。
適用対象:Microsoft Dynamics 365 Customer Engagement Online
元の KB 番号: 4563997
現象
Microsoft Dynamics 365 App for Outlook を使用しようとすると、次のエラーなど、不足している特権を参照するエラーが発生します。
特定の機能を制限する必要な特権 (prvReadOrganization) がありません。 必要なアクセス権を取得するには、管理者に問い合わせてください。
原因
このエラーは、メールボックス レコードに関連付けられているユーザーが、Microsoft Dynamics 365 App for Outlook を使用するための十分な権限を持っていない場合に表示されます。
解決方法
オプション 1: Microsoft Dynamics 365 App for Outlook ユーザー セキュリティ ロールを割り当てる
標準ロールは、Microsoft Dynamics 365 App for Outlook を使用するために必要な特権を提供するために存在します。 このロールは、Microsoft Dynamics 365 App for Outlook User という名前で、Outlook 用アプリを使用する必要があるユーザーに割り当てることができます。 このロールの詳細については、「 セキュリティ ロールへのアクセスを提供する」を参照してください。
オプション 2: カスタム ロール
必要な特権を含むようにロールをカスタマイズする場合は、Microsoft Dynamics 365 App for Outlook を使用するために必要な権限の一覧については、「詳細情報」セクションを参照してください。
詳細
次の表に、Microsoft Dynamics 365 App for Outlook を使用するために必要な特権と、その権限が見つかるセキュリティ ロールのタブを示します。 システム管理者ロールを持つユーザーは、[設定] [セキュリティ セキュリティ ロール]> に移動することで、セキュリティ>ロールを見つけて変更できます。 特定のユーザーに割り当てられているロールを表示するには、[ 設定] に移動し、[ セキュリティ] を選択し、[ ユーザー] を選択し、特定のユーザー レコードを選択して、[ ロールの管理] を選択します。
特権名 | Entity | セキュリティ ロール内の場所 (タブ) |
---|---|---|
prvReadEmailServerProfile | EmailServerProfile | ビジネス管理 |
prvReadRole | セキュリティ ロール | ビジネス管理 |
prvReadUser | User | ビジネス管理 |
prvWriteMailbox | Mailbox | ビジネス管理 |
prvReadMailbox | Mailbox | ビジネス管理 |
prvReadOrganization | 組織 | ビジネス管理 |
prvSyncToOutlook (exchangesyncidmapping | Outlook との同期の設定 | ビジネス管理 --> プライバシー関連の特権 |
prvUseOfficeApps | Dynamics 365 App for Outlook を使用する | ビジネス管理 --> プライバシー関連の特権 |
prvAppendToAccount | アカウント | コア レコード |
prvReadAccount | アカウント | コア レコード |
prvDeleteActivity | アクティビティ | コア レコード |
prvAppendActivity | アクティビティ | コア レコード |
prvWriteActivity | アクティビティ | コア レコード |
prvCreateActivity | アクティビティ | コア レコード |
prvReadActivity | アクティビティ | コア レコード |
prvAppendToActivity | アクティビティ | コア レコード |
prvShareActivity | アクティビティ | コア レコード |
prvAppendToContact | Contact | コア レコード |
prvReadContact | Contact | コア レコード |
prvCreateContact | Contact | コア レコード |
prvReadUserQuery | 保存されたビュー | コア レコード |
prvReadAppModule | モデル駆動型アプリ | カスタマイズ |
prvReadAttribute | フィールド | カスタマイズ |
prvReadEntity | Entity | カスタマイズ |
prvReadRelationship | リレーションシップ | カスタマイズ |
prvReadSystemApplicationMetadata | システム アプリケーション メタデータ | カスタマイズ |
prvReadSystemForm | システム フォーム | カスタマイズ |
prvReadUserApplicationMetadata | ユーザー アプリケーション メタデータ | カスタマイズ |
prvReadQuery | View | カスタマイズ |
prvReadWebResource | Web リソース | カスタマイズ |
prvSearchAvailability | 検索の可用性 | サービス管理 --> その他の特権 |
次の表に、Microsoft Dynamics 365 App for Outlook フォーム内で使用される既定のビューの一部を表示するために必要な追加の特権を示します。 これらの特権がないと、ユーザーは、レコードの予期されるビュー (サブグリッド) ではなく、次のエラーが表示される場合があります。
これらのレコードにアクセスするためのアクセス許可がありません。 Microsoft Dynamics 365管理者に問い合わせてください。
特権名 | Entity | セキュリティ ロール内の場所 (タブ) |
---|---|---|
prvReadIncident | ケース | サービス |
prvReadOpportunity | Opportunity | コア レコード |
prvReadCompetitor | 競争 相手 | 営業 |
prvReadConnection | Connection | コア レコード |
フィードバック
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