現象
Microsoft Office Outlook 2007、Microsoft Office Outlook 2003 および Microsoft Outlook Express 6 で、特定の条件の HTML 形式のメールを受信すると文字化けが発生する場合があります。
文字化けが発生する特定の条件
受信したメッセージの charset が、テキスト パート (text/plain) と HTML パート (text/html) で別のエンコードが指定されている場合に文字化けが発生する場合があります。たとえば、テキスト パートで charset=iso-2022-jp、HTML パートで charset=utf-8 が設定されている場合にこの現象が発生します。
なお、Outlook 2007、Outlook 2003 および Outlook Express 6 では、特定の条件のような設定をするメッセージを作成することはできません。
原因
この現象は、Outlook 2007、Outlook 2003 および Outlook Express 6 が、MIME (Multipurpose Internet Mail Extension) の multipart/alternative 形式 のメッセージでパートごとに別の charset が指定されることを想定していないために発生します。
Outlook 2007、Outlook 2003 および Outlook Express 6 では、メッセージ全体のコード ページとして、MIME の multipart/alternative 形式の先頭のパートで指定されている charset を使用します。その結果、先頭のパートがテキスト パートであり、テキスト パートと HTML パートの charset が異なり、かつ HTML パートをテキスト パートの charset で正しく表示することができない場合に文字化けが発生します。
回避策
Outlook 2007 でこの問題を回避するには、以下の修正プログラム パッケージをインストールしてください。
978401 Office Outlook 2007 修正プログラム パッケージ (Outlook x none.msp): 2010 2 月 23日Outlook 2007、Outlook 2003 および Outlook Express 6 で文字化けしたメールを受信した場合は、以下の手順を実行して正しい文字が表示されるように適切なエンコードに変更してください。
Outlook 2007 の場合 :
-
文字化けしたメッセージの [メッセージ] タブをクリックします。
-
[その他のアクション] をクリックして、[エンコード] をポイントし、文字化けしている文字が正しく表示される適切なエンコードを指定します。(たとえば、[Unicode (UTF-8)] をクリックします。)
Outlook 2003 および Outlook Express 6 の場合 :
-
文字化けしたメッセージの [表示] メニューをクリックします。
-
[エンコード] をポイントし、文字化けしている文字が正しく表示される適切なエンコードを指定します。(たとえば、[日本語 (EUC)] をクリックします。)
状況
マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。
詳細
Outlook 2007 および Outlook 2003 では、以下の設定をしている場合でも、HTML パートをテキストに変換して表示するため、この現象が発生します。
Outlook 2007 の場合 :
[ツール] メニュー の [セキュリティ センター] をクリックして、[電子メールのセキュリティ] をクリックし、[テキスト形式で表示] 項目の [すべての標準メールをテキスト形式で表示する] チェック ボックスがオンに設定されている。
Outlook 2003 の場合 :
[ツール] メニュー の [オプション] をクリックして、[メール オプション] ボタンをクリックし、[メッセージの取り扱い] 項目の [すべての標準メールをテキスト形式で表示する] チェック ボックスがオンに設定されている。
また、Outlook Express 6 の場合は、[ツール] メニュー の [オプション] をクリックして、[読み取り] タブをクリックし、[メッセージはすべてテキスト形式で読み取る] チェック ボックスがオンに設定されている場合には、この現象が発生しません。