現象
シナリオ説明
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ユーザーは Microsoft Office 365 内にメールボックスを所有しています。
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当該メールボックスに対して、インプレース保持または訴訟ホールドが有効化されています。
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ユーザーが Microsoft Outlook Web App (OWA) または Microsoft Outlook から予定表アイテムの編集を試みます。
この場合、ユーザーには以下のエラー メッセージが表示されます。
“Couldn't update the following event:
<EventName>”
(以下のイベントを更新できませんでした。
<EventName>)
原因
この問題は、(回復可能なアイテム フォルダーの一部である) Versions フォルダーがいっぱいであるために生じます。
注: 回復可能なアイテム フォルダーの状態を確認するには、以下のコマンドを実行します。
Get-MailboxFolderStatistics -Identity cloudtest -FolderScope recoverableitems | ft name,*size*
解決方法
ユーザーのメールボックスにはホールドが適用されているため、Versions フォルダー内のアイテムが必要となります。この問題を解決するには、影響を受けたユーザーのアーカイブ メールボックスを有効化し、Versions フォルダー内のすべてのアイテムをアーカイブ メールボックスに移行する必要があります。以下の手順に従って、これを実行してください。
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以下のコマンドを実行し、アーカイブ メールボックスを有効化します。 Enable-Mailbox -Identity UserName -Archive
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以下のコマンドを実行し、アーカイブの自動拡張機能を有効化します。 Enable-Mailbox <UserMailbox> -AutoExpandingArchive
注:
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メールボックスに対してアーカイブの自動拡張を有効化することで、ユーザーのプライマリ メールボックス内にある回復可能なアイテム フォルダーのストレージ クォータを 10 GB (100 GB から 110 GB へ) 増加できます。また、本手順によりアーカイブ メールボックスのサイズは “Unlimited” (無制限) になります。
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アーカイブの自動拡張機能を有効化する前に、ユーザーのアーカイブ メールボックスを有効化する必要があります。当該アーカイブ メールボックスを有効化するには、Exchange Online Plan 2 のライセンスをユーザーに割り当てる必要があります。ユーザーに Exchange Online Plan 1 のライセンスが割り当てられている場合は、Exchange Online Archiving ライセンスを別途ユーザーに割り当てることで、当該ユーザーのアーカイブ メールボックスを有効化できます。
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ホールドが適用されたメールボックスに対し、カスタマイズした保持ポリシーを作成し、Versions フォルダーからアーカイブ メールボックスにアイテムを移行します。以下の資料の “手順 1: [回復可能なアイテム] フォルダーのカスタム保持タグを作成する” セクションに記載された手順に従って、これを実行します。
追加情報
ユーザーのメールボックスにインプレース保持または訴訟ホールドが適用されている場合、元のアイテムおよび変更されたアイテムは Versions フォルダーにコピーされます。Versions フォルダーがいっぱいの場合、元のアイテムをコピーして変更したアイテムをこのフォルダー内に格納することはできません。そのため、ユーザーは元のアイテムに対する変更内容を保存することはできません。