デスクトップ フローを作成、編集、保存、または表示できない

この記事では、Microsoft デスクトップ用 Power Automateでデスクトップ フローを作成、編集、または表示しようとしたときにエラー メッセージが表示される問題を解決します。

適用先:Power Automate
元の KB 番号: 5004096

現象

Microsoft デスクトップ用 Power Automateでは、次の問題が発生します。

  • 新しいデスクトップ フローを作成すると、次のエラー メッセージが表示されます。

    この環境でフローを表示または作成することはできません。 管理者に問い合わせるか、既定の環境、または十分なアクセス許可を持つ環境に切り替えます。

  • デスクトップ フローを編集すると、次のエラー メッセージが表示されます。

    フローの初期化に失敗しました。 アクティブなインターネット接続があることを確認し、管理者に問い合わせてください。

  • デスクトップ フローを保存すると、次のエラー メッセージが表示されます。

    フローの保存中にエラーが発生しました。 問題が解決しない場合は、管理者に問い合わせてください。

  • コンソールの [ マイ フロー ] リストにデスクトップ フローを表示することはできません。

問題の確認

該当する場合は、 Power Automate ポータル で同じ操作を実行してください。 想定どおりに動作する場合、問題は、デスクトップ用 Power Automateをホストするマシンのローカル ネットワーク構成に関連している必要があります。

原因

デスクトップ用 Power Automateをホストするマシンは、必要なドメインに接続できません。 この問題は、ドメインがネットワーク上でブロックされているか、認証が必要なプロキシ サーバーを使用しているために発生する可能性があります。

後者の場合、デスクトップ用 Power Automateはプロキシ サーバーで認証できないため、通信は失敗します。 プロキシ サーバーは、ユーザーの Active Directory アカウントで自動認証を使用している必要があることに注意してください。

ブロックされたドメインの問題の解決策

Power Automate が接続する 必要なサービス を承認します。 これらのサービスがネットワーク上でブロックされていないことを確認します。

デスクトップ フローの実行に対してローカル コンピューターからの接続を有効にするためにランタイムに必要なデスクトップ フロー サービスを承認します。

プロキシ認証の問題の解決策と回避策

この問題を解決するには、「デスクトップ用 Power Automateのプロキシ サーバー関連のエラー」で説明されている手順に従います。