SSL 経由で接続するとページを表示できない

現象

インターネット インフォメーション サービス (IIS) が動作しているコンピュータに SSL (Secure Socket Layer) を使用して接続すると、次のエラー メッセージが表示されることがあります。

ページを表示できません。
お探しのページは現在利用できません。 Web サイトに技術的な問題が発生しているか、ブラウザーの設定を調整する必要があります。


通常、この Web サイトはサーバー上の 2 番目の Web サイトです。 HTTP 経由で Web サイトに接続すると、正しく動作します。

原因

このエラー メッセージは、既定の Web サイトに設定されていた SSL の証明書を削除し、その証明書をセカンド Web サイトに設定しようとした場合に発生する可能性があります。

netstat -an コマンドを実行すると、サービスがポート 443 でリッスンしていることがわかりますが、接続できません。 これは、IIS バージョン 5.0 以降のソケット プーリングと呼ばれる新しい実装が原因で発生します。
ソケット プーリングおよびソケット プーリングを無効にする方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。

IIS が起動時にすべての使用可能な IP アドレスにバインドされる

解決方法

注: この資料では、既定の Web サイトと管理者 Web サイトの 2 つの Web サイトをインストールしています。 既定では、SSL は既定の Web サイトで有効です。

  1. 既定の Web サイトのセキュリティ プロパティを開き、[サーバー証明書] を選択します。

  2. ウィザードで [既存の証明書を使用] をクリックし、一覧から証明書を選択します。

  3. ウィザードを完了し、[Web サイト] タブをクリックし、[詳細] をクリックします。

  4. [この Web サイトの複数の SSL ID] ボックスの一覧に表示されているエントリをすべて削除し、[OK] をクリックします。

  5. [サーバー証明書] をもう一度クリックし、[現在の証明書を削除する] をクリックして、[OK] をクリックします。

  6. Microsoft 管理コンソール (MMC) でコンピューター名を右クリックし、[IIS の再起動] をクリックします。

これにより、SSL を使用してサーバーに接続できるようになります。

回避策

IIS サービスを再起動すると、エラー メッセージが解決する場合があります。 解決しない場合は、この資料の "解決方法" セクションに記載されている手順に従ってください。

詳細情報

IIS Web サーバーで SSL を有効にすると、IIS サービスはポート 80 および 443 で使用済みおよび未使用のすべての IP アドレスをリッスンし始めます。 マルチ IP アドレス サーバーの場合は、この機能を無効にすることができます。 この機能は、パフォーマンスを向上させるために製品を追加しました。

この問題は通常、管理 Web サイトで SSL をセットアップしようとした場合に発生します。 IIS は既定の Web サイトの SSL 設定を検出し、ポート 443 でリッスンします。 ただし、既定の Web サイトには、そのサイトに対応する証明書がありません。 したがって、接続を確立できないため、ポート 443 でリッスンしているサーバーは表示されますが、サイトに接続することはできません。

ヘルプを表示

スキルを磨く
トレーニングの探索
新機能を最初に入手
Microsoft Insider に参加する

この情報は役に立ちましたか?

フィードバックをお送りいただきありがとうございます!

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×