(WinRM クライアントは要求を処理できません) リモート Windows PowerShellを介してExchange Onlineに接続するとエラーが発生する
問題
リモート Windows PowerShellを使用して Microsoft 365 のExchange Onlineに接続すると、次のエラー メッセージが表示されます。
[outlook.office365.com]リモート サーバーへの接続が失敗し、次のエラー メッセージが表示されました。
WinRM クライアントは、サーバー名を解決できないため、要求を処理できません。 詳細については、「about_Remote_Troubleshooting ヘルプ」トピックを参照してください。+ CategoryInfo : OpenError:
(System.Manageme....RemoteRunspace:RemoteRunspace) []。
PSRemotingTransportException+ 完全修飾ErrorId : PSSessionOpenedFailed
原因
この問題は、次のいずれかの状況で発生します。
- ファイアウォールは、必要なトラフィックをブロックします。
- Windows リモート管理サービスが開始されていません。
- プロキシ サーバーが正しく動作しません。
解決方法
ファイアウォールが必要なトラフィックをブロックしていないことを確認します。
Windows リモート管理サービスがインストールされ、開始されているかどうかを確認します。
[実行] ダイアログ ボックスに「services.msc」と入力し、Enter キーを押します。
サービス MMC で、[ Windows リモート管理] をダブルクリックします。
スタートアップの種類を [手動] に設定し、[OK] をクリック します。
サービスを右クリックし、[開始] を選択 します。
サービスを開始します。
注:
サービスが既に開始されていても応答していない場合は、[ 再起動] をクリックする必要がある場合があります。
もう一度Exchange Onlineに接続してみてください。
プロキシ サーバーの設定を確認する
管理者特権のコマンド プロンプトを開きます。
次のコマンドを実行して、現在のプロキシ構成を確認します。
netsh winhttp show proxy
次のどちらかの手順を実行します。
WinHTTP プロキシをリセットするには、次のコマンドを実行します。
netsh winhttp reset proxy
新しいプロキシ サーバーを構成するには、次のコマンドを実行します。
netsh winhttp set proxy <proxy>:<port>
たとえば、 を実行
netsh winhttp set proxy 10.0.0.6:8080
します。
詳細
Microsoft 365 エンドポイントの詳細については、「 Microsoft 365 URL と IP アドレス範囲」を参照してください。
リモート PowerShell を使用して Exchange Online に接続する方法の詳細については、「リモート PowerShell を使用して Exchange Online に接続する」を参照してください。
さらにヘルプが必要ですか? Microsoft コミュニティを参照してください。
フィードバック
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