Windows XP または Windows Server 2003 での "STOP 0xC000021A" エラーのトラブルシューティング方法

この資料では、STOP 0xC000021A エラーの高度なトラブルシューティング手順について説明します。

ホーム ユーザー: この記事は、サポート担当者や IT プロフェッショナルによる利用を想定しています。 コンピューター使用中のブルー スクリーン エラー コードの詳細については、「ブルー スクリーン エラーのトラブルシューティング」を参照してください。

適用対象: Windows 10 - すべてのエディション、Windows Server 2012 R2
元の KB 番号: 156669

この資料は、上級レベルのコンピューター ユーザーを対象にしています。 高度なトラブルシューティングに自信がない場合は、他の人の支援を求めるか、テクニカル サポートにお問い合わせください。

"適用対象" セクションに記載されているオペレーティング システムを実行しているサーバーまたはワークステーションを使用している場合、次のエラー メッセージが表示されることがあります。

STOP: c000021a {致命的なシステム エラー}
Windows Logon Process のシステム プロセスが、0xc0000034 (0x00000000 0x0000000) のステータスで異常終了しました。
The system has been shut down.

注:

かっこ内のパラメーターは、使用しているコンピューターの構成に固有のものであり、発生するたびに異なる可能性があります。

原因

STOP 0xC000021A エラーは、Winlogon.exe または Csrss.exe が失敗したときに発生します。 これらのプロセスのどちらかが停止したことを Windows NT カーネルが検出すると、システムが停止し、STOP 0xC000021A エラーを発生します。 このエラーにはいくつかの原因が考えられます。

  • インストールされているシステム ファイルのバージョンが一致していません。
  • Service Pack のインストールが失敗しました。
  • ハード ディスクの復元に使用されるバックアップ プログラムで、使用中だった可能性のあるファイルが正しく復元されませんでした。
  • 互換性のないサードパーティのプログラムがインストールされています。

解決方法

この問題のトラブルシューティングを行うには、失敗したプロセスとその原因を特定する必要があります。

失敗したプロセスを特定するには、ワトソン博士を既定のシステム デバッガーとして登録します (まだ既定のデバッガーではない場合)。 Windows NT 用のワトソン博士は、プロセスの失敗に関する診断情報をログ ファイル (Drwtsn32.log) に記録します。 また、このプログラムを構成して、失敗したプロセスのメモリ ダンプ ファイルを生成することもできます。 次に、デバッガー内のファイルを分析して、プロセスが失敗する理由を特定できます。

ワトソン博士を設定してユーザー モードのプログラム エラーをトラップするには、次の手順を実行します。

  1. コマンド プロンプトで「System Root\System32\Drwtsn32.exe -I」と入力し、Enter キーを押します。

    このコマンドにより、既定のシステム デバッガーとしてワトソン博士が構成されます。

  2. コマンド プロンプトで「System Root\System32\Drwtsn32.exe」と入力し、次のオプションを選択します。

    • 既存のログ ファイルに追加
    • クラッシュ ダンプ ファイルを作成
    • 視覚的な通知
  3. STOP 0xC000021A エラーの発生後にコンピューターを再起動し、ワトソン博士 (Drwtsn32.exe) を実行します。

  4. ワトソン博士のログを表示して、どのユーザー モードのプロセスが問題を引き起こしている可能性のあるか特定します。

  5. ワトソン博士のログに、問題の原因を特定するための情報が十分に含まれていない場合は、User.dmp ファイルを分析して STOP 0xC000021A エラーの原因を特定します。

    ワトソン博士によって Winlogon.exe または Csrss.exe の User.dmp ファイルが作成されなかった場合は、別のツールを使用して、失敗したプロセスのメモリ ダンプ ファイルを生成することが必要な場合があります。 詳細については、以下の記事をご覧ください。

    241215 Userdump.exe を使用してダンプ ファイルを確認する方法

    注:

    例外によりシャットダウンしたプロセスのトラブルシューティングを行うには、サポート技術情報の手順に従います。 これらの手順を実行するとき、以下のプロセスを監視して STOP 0xC000021A エラーのトラブルシューティングを行います。

    • Winlogon.exe
    • Csrss.exe

    ほとんどの場合、STOP 0xC000021A エラーは Winlogon.exe の失敗が原因で発生します。 これは、通常、サード パーティの Graphical Identification and Authentication (GINA) DLL に不具合があることが原因で発生します。 GINA は、Winlogon.exe が読み込む置換可能な DLL コンポーネントです。 GINA により、対話型ログイン モデルの認証ポリシーが実装されます。 GINA は、すべての識別および認証ユーザー対話を実行します。

特定のタイプのリモート制御ソフトウェアが既定の Windows GINA DLL (Msgina.dll) を置換することはよくあることです。 最初の手順は、まずシステムを調べてサード パーティの GINA DLL があるかどうかを確認することです。 これを行うには、次のレジストリ キーを確認します。

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WinlogonValue = GinaDLL REG_SZ

  • Gina DLL の値が存在し、Msgina.dll 以外である場合は、サードパーティの製品がこの値を変更した可能性があります。
  • この値が存在しない場合は、システムは既定の GINA DLL として Msgina.dll を使用しています。 このエラーが、新規または更新したデバイス ドライバー、システム サービス、またはサードパーティのプログラムのインストール後に初めて発生した場合は、新しいソフトウェアを削除するか無効にします。 その後、ソフトウェアの製造元に、更新プログラムを入手できるかどうか問い合わせてください。

前回正常起動時の構成

この資料の前述の手順で問題が解決されない場合は、前回正常起動時の構成を使用してコンピューターを起動します。 前回正常起動時の構成を使用してコンピューターを起動するには、次の手順に従います。

注:

Microsoft Windows には複数のバージョンが存在するため、使用中のコンピューターによっては以下の手順が異なる場合があります。 この場合、製品のマニュアルを参照のうえ、手順を実行するようにしてください。

  1. シャットダウン>の開始を選択します。

  2. 再起動>OKを選択します。

  3. 以下に示すタイミングで F8 キーを押します。

    • x86 ベースのコンピューターの場合: テキストの画面が表示され、それが表示されなくなったときに F8 キーを押します。 (テキストの画面には、メモリ テスト、BIOS に関する行、およびその他の行が含まれる場合があります。) F8 キーを押すタイミングを示すプロンプトが表示される場合もあります。
    • Itanium アーキテクチャ ベースのコンピューターの場合: ブート メニューから適切なオプションを選択し、F8 キーを押します。 F8 キーをいつ押すかを示すプロンプトが表示される場合があります。
  4. 矢印キーを使用して [前回正常起動時の構成] を選択し、Enter キーを押します。

    テンキー上の矢印キーを機能させるには、NumLock キーをオフにする必要があります。

  5. 矢印キーを使用してオペレーティング システムを選択し、Enter キーを押します。

注:

  • [前回正常起動時の構成] スタートアップ オプションを選択することにより、ハードウェアに対して適切ではない可能性がある新たに追加したドライバーなどの問題から回復できます。 ただし、ドライバーやファイルの破損または不足が原因で発生した問題は解決されません。
  • [前回正常起動時の構成] オプションを選択すると、レジストリ キー HKLM\System\CurrentControlSet の情報のみが復元されます。 他のレジストリ キーで行った変更はそのまま残ります。

回復コンソールを使用して互換性のないソフトウェアを削除する

この資料の前述の手順で問題が解決されない場合は、回復コンソールを使用して互換性のないソフトウェアを削除します。 これを行う方法の完全な手順については、この資料の対象範囲外ですので割愛します。 ただし、ガイドラインとして以下の資料を使用できます。

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