Windows XP 또는 Windows Server 2003에서 0xC000021A 중지 오류를 해결하는 방법

이 문서에서는 STOP 0xC000021A 오류에 대한 고급 문제 해결 단계를 제공합니다.

개인 사용자: 이 문서는 지원 상담원과 IT 전문가를 위한 것입니다. 컴퓨터를 사용하는 동안 블루스크린 오류 코드에 대한 자세한 내용을 보려면 블루 스크린 오류 문제 해결을 참조하세요.

적용 대상: Windows 10 - 모든 버전, Windows Server 2012 R2
원본 KB 번호: 156669

이 문서는 고급 컴퓨터 사용자를 대상으로 합니다. 고급 문제 해결이 어려울 경우 다른 사람에게 도움을 요청하거나 지원 담당자에게 문의하십시오.

"적용 대상" 섹션에 안내된 운영 체제 중 하나를 실행하는 서버 또는 워크스테이션을 사용하는 경우 다음과 유사한 내용의 오류 메시지가 나타날 수 있습니다

중지: c000021a {심각한 시스템 오류}
Windows 로그온 프로세스 시스템 프로세스가 0xc0000034(0x00000000 0x0000000) 상태로 예기치 않게 종료되었습니다.
시스템이 종료되었습니다.

참고

괄호 안의 매개 변수는 컴퓨터 구성에 따라 다르며 각 항목마다 다를 수 있습니다.

원인

STOP 0xC000021A 오류는 Winlogon.exe 또는 Csrss.exe가 실패할 때 발생합니다. Windows NT 커널이 이러한 프로세스 중 하나가 중지되었음을 감지하면 시스템을 중지하고 STOP 0xC000021A 오류가 발생합니다. 이 오류에는 다음을 비롯한 몇 가지 원인이 있을 수 있습니다.

  • 일치하지 않는 시스템 파일이 설치된 경우
  • 서비스 팩 설치에 실패한 경우
  • 하드 디스크를 복원하는 데 사용되는 백업 프로그램이 사용 중일 수 있는 파일을 올바르게 복원하지 못했습니다.
  • 호환되지 않는 타사 프로그램이 설치되었습니다.

해결 방법

이 문제를 해결하려면 이러한 프로세스 중 실패한 프로세스와 그 이유를 확인해야 합니다.

어떤 프로세스가 실패했는지 확인하려면 Dr. Watson이 기본 디버거가 아닌 경우 기본 시스템 디버거로 등록하십시오. Windows NT용 Dr. Watson은 프로세스 오류에 대한 진단 정보를 로그 파일 Drwtsn32.log에 기록합니다. 또한 실패한 프로세스의 메모리 덤프 파일을 생성하도록 이 프로그램을 구성할 수 있습니다. 그런 다음 디버거의 파일을 분석하여 프로세스가 실패하는 이유를 확인할 수 있습니다.

Dr. Watson을 설정하여 사용자 모드 프로그램 오류를 잡으려면 다음 단계를 수행하세요.

  1. 명령 프롬프트에 System Root\System32\Drwtsn32.exe -I를 입력한 다음 Enter 키를 누릅니다.

    이 명령은 Dr. Watson을 기본 시스템 디버거로 구성합니다.

  2. 명령 프롬프트에 System Root\System32\Drwtsn32.exe를 입력한 다음, 다음 옵션을 선택합니다.

    • 기존 파일에 추가
    • 크래시 덤프 생성
    • 시각적 알림
  3. STOP 0xC000021A 오류에서 컴퓨터가 다시 시작되면 Dr. Watson(Drwtsn32.exe)을 실행합니다.

  4. Dr. Watson 로그를 확인하여 문제를 일으킬 수 있는 사용자 모드 프로세스를 확인합니다.

  5. Dr. Watson 로그에 문제의 원인을 확인할 수 있는 충분한 정보가 포함되어 있지 않은 경우 User.dmp 파일을 분석하여 STOP 0xC000021A 오류의 원인을 확인합니다.

    Dr. Watson이 Winlogon.exe 또는 Csrss.exe에 대한 User.dmp 파일을 만들지 않은 경우 다른 도구를 사용하여 실패한 프로세스의 메모리 덤프 파일을 생성해야 할 수 있습니다. 자세한 내용은 다음 문서를 참조하세요.

    241215 Userdump.exe 도구를 사용하여 덤프 파일을 생성하는 방법

    참고

    기술 자료 문서의 지침에 따라 예외적으로 종료되는 프로세스의 문제를 해결합니다. 이러한 지침을 따르는 동안 다음 프로세스를 모니터링하여 STOP 0xC000021A 오류 문제를 해결합니다.

    • Winlogon.exe
    • Csrss.exe

    대부분의 STOP 0xC000021A 오류는 Winlogon.exe가 실패하기 때문에 발생합니다. 이는 일반적으로 결함이 있는 타사 GINA(Graphical Identification and Authentication) DLL 때문에 발생합니다. GINA는 Winlogon.exe가 로드하는 교체 가능한 DLL 구성 요소입니다. GINA는 대화형 로그온 모델의 인증 정책을 구현합니다. GINA는 모든 식별 및 인증 사용자 상호 작용을 수행합니다.

특정 유형의 원격 제어 소프트웨어가 기본 Windows GINA DLL(Msgina.dll)을 대체하는 것은 매우 일반적입니다. 첫 번째 단계로 시스템을 검사하여 타사 GINA DLL이 있는지 확인하는 것이 좋습니다. 이렇게 하려면 다음 레지스트리 키를 찾습니다.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WinlogonValue = GinaDLL REG_SZ

  • Gina DLL 값이 있고 Msgina.dll이 아닌 경우 타사 제품이 이 값을 변경했음을 의미합니다.
  • 이 값이 없으면 시스템은 Msgina.dll을 기본 GINA DLL로 사용합니다. 새롭거나 업데이트된 디바이스 드라이버, 시스템 서비스 또는 타사 프로그램을 설치한 후 이 오류가 처음 발생한 경우 새 소프트웨어를 제거하거나 비활성화해야 합니다. 업데이트를 사용할 수 있는지 확인하려면 소프트웨어 제조업체에 문의하세요.

마지막으로 성공한 구성

이 문서의 이전 단계로 문제가 해결되지 않으면 마지막으로 성공한 구성을 사용하여 컴퓨터를 시작합니다. 마지막으로 성공한 구성을 사용하여 컴퓨터를 시작하려면 다음 단계를 수행합니다.

참고

Microsoft Windows의 버전이 다양하므로 사용하는 컴퓨터에 따라 아래 단계가 다를 수도 있습니다. 이러한 경우에는 제품 설명서를 참조하여 다음 단계를 완료하세요.

  1. 시작>종료를 선택합니다.

  2. 다시 시작>확인을 선택합니다.

  3. 지정된 시간에 F8 키를 누릅니다.

    • x86 기반 컴퓨터의 경우: 텍스트 화면이 나타났다가 사라지면 F8 키를 누릅니다. (텍스트 화면에는 메모리 테스트, BIOS에 대한 행 및 기타 행이 포함될 수 있습니다.) F8을 눌러야 할 때를 알려주는 프롬프트가 있을 수도 있습니다.
    • Itanium 아키텍처 기반 컴퓨터의 경우: 부팅 메뉴에서 선택한 후 F8 키를 누릅니다. F8 키를 눌러야 할 때를 알려주는 프롬프트가 표시될 수 있습니다.
  4. 화살표 키를 사용하여 마지막으로 성공한 구성을 선택한 다음 Enter 키를 누릅니다.

    숫자 키패드의 화살표 키가 작동하려면 NUM LOCK이 꺼져 있어야 합니다.

  5. 화살표 키를 사용하여 운영 체제를 강조 표시한 다음 Enter 키를 누릅니다.

참고

  • 마지막으로 성공한 구성 시작 옵션을 선택하면 하드웨어에 올바르지 않을 수 있는 새로 추가된 드라이버와 같은 문제를 복구할 수 있습니다. 그러나 손상되거나 누락된 드라이버나 파일로 인해 발생하는 문제는 해결되지 않습니다.
  • 마지막으로 성공한 구성 옵션을 선택하면 레지스트리 키 HKLM\System\CurrentControlSet의 정보만 복원됩니다. 다른 레지스트리 키에서 변경한 사항은 그대로 유지됩니다.

복구 콘솔을 사용하여 호환되지 않는 소프트웨어 제거

이 문서의 이전 단계로 문제가 해결되지 않으면 복구 콘솔을 사용하여 호환되지 않는 소프트웨어를 제거합니다. 이 문서의 범위를 벗어나는 방법을 설명하는 단계를 완료합니다. 그러나 다음 문서를 참고할 수도 있습니다.

816104 Windows Server 2003에서 복구 콘솔을 사용하여 드라이버를 교체하는 방법
326215 시작되지 않는 Windows Server 2003 기반 컴퓨터에서 복구 콘솔을 사용하는 방법
307654 Windows XP에서 복구 콘솔을 설치하고 사용하는 방법