No ocurre nada al hacer clic en un vínculo en Internet Explorer

Advertencia

Se ha programado la deshabilitación permanente de la aplicación de escritorio retirada y sin soporte de Internet Explorer 11 a través de una actualización de Microsoft Edge en ciertas versiones de Windows 10. Para obtener más información, consulte Preguntas frecuentes sobre la retirada de la aplicación de escritorio de Internet Explorer 11.

Este artículo le ayuda a resolver el problema de que la página web no se puede abrir al hacer clic en un hipervínculo en Internet Explorer.

Versión del producto original: Internet Explorer 9
Número KB original: 175775

Síntomas

Al hacer clic en un hipervínculo en una página web o en un mensaje de correo electrónico, no ocurre nada. Internet Explorer no abre la página web.

Nota:

Esta información se aplica a Internet Explorer 9, Internet Explorer 8 e Internet Explorer 7.

Causa

Esto puede pasar por una o varias de las razones siguientes:

  • La configuración en la que elige qué explorador web desea usar está dañada. Esto puede hacer que Windows interprete erróneamente qué explorador está establecido como predeterminado en el equipo.
  • Después de instalar el software, se cambió la configuración, lo que puede hacer que los vínculos a las páginas web funcionen incorrectamente.
  • Es posible que un explorador o un complemento instalados anteriormente interfieran con otro software del equipo.
  • Las claves del Registro se cambiaron o se dañaron.

Solución

Esta sección está destinada a los usuarios de ordenadores principiantes o de nivel medio. Si estos métodos no resuelven el problema, puede probar los de la sección Solución de problemas avanzada. Para resolver este problema, emplee los métodos siguientes en el orden en que aparecen.

Método 1: Comprobar la configuración predeterminada del explorador web

En Microsoft Windows, puede seleccionar el explorador web que desea usar. Para convertir Internet Explorer en el explorador web predeterminado, siga estos pasos:

  1. Para abrir Internet Explorer, haga clic en Inicio y en Internet Explorer.
  2. Si se le pide que confirme que quiere que Internet Explorer sea el explorador predeterminado, haga clic en .
  3. En el menú Herramientas, haga clic en Opciones de Internet.
  4. Haga clic en el Programas>Establecer como predeterminado>Aceptar y, después, cierre Internet Explorer.

Nota:

Estos cambios surtirán efecto la próxima vez que inicie Internet Explorer.

Compruebe si se ha resuelto el problema. Si se ha solucionado, ya ha terminado con este artículo. Si no, pruebe el método siguiente.

Método 2: Cambiar los tipos de archivo que abre Internet Explorer de forma predeterminada

En Windows 7 y Windows Vista.

  1. Cierre todas las ventanas de Internet Explorer.
  2. Haga clic en Inicio y en Panel de control.
  3. Haga clic en Programas y en Establecer programas predeterminados.
  4. En el menú Programas, haga clic en Internet Explorer y en Elegir opciones predeterminadas para este programa.
  5. Asegúrese de que las casillas de .htm, .html y urls están seleccionadas. después, haga clic en Guardar.
  6. Haga clic en Aceptar.

Nota:

Estos cambios surtirán efecto la próxima vez que inicie Internet Explorer.

En Windows XP

  1. Para abrir el Explorador de Windows, haga clic con el botón derecho en Inicio y en Mi PC.

  2. En el menú Herramientas, haga clic en Opciones de carpeta y luego en la pestaña Tipos de archivo.

  3. Busque y seleccione el tipo de archivo HTM.

  4. Asegúrese de que Internet Explorer está seleccionado como el programa de Se abre con. Si Internet Explorer no está seleccionado, haga clic en Cambiar, seleccione Internet Explorer como programa recomendado y, luego, haga clic en Aceptar.

  5. Repita los pasos 3 y 4 para los siguientes tipos de archivo:

    • HTML
    • ITS
    • MHT
    • MTHML
    • XML
    • XSL

Compruebe si se ha resuelto el problema. Si se ha solucionado, ya ha terminado con este artículo. Si el problema persiste, vaya al método siguiente.

Método 3: Usar el modo Sin complementos de Internet Explorer

Aunque los complementos del explorador pueden mejorar la experiencia en línea, a veces pueden interferir con otro software del ordenador o tener conflictos con este. Sin embargo, tenga en cuenta que es posible que algunas páginas web, o el propio Internet Explorer, no se muestren correctamente si un complemento está deshabilitado. En primer lugar, inicie Internet Explorer con los complementos deshabilitados de forma temporal para ver si el problema se resuelve. (Los complementos solo se deshabilitarán hasta que reinicie Internet Explorer de la manera habitual). Para ello, siga estos pasos:

  • Haga clic en Inicio, escriba Internet Explorer en el cuadro Buscar y, después, haga clic en Internet Explorer (Sin complementos).

    Nota:

    Para Windows XP, haga clic en Inicio, haga clic con el botón derecho en el icono de Internet Explorer y, luego, en Explorar sin complementos.

Si el modo Sin complementos de Internet Explorer resuelve el problema, siga estos pasos para identificar el complemento del explorador que provoca el problema:

  1. Para iniciar Internet Explorer, haga clic en Inicio y luego en Internet Explorer.
  2. Haga clic en la pestaña Herramientas y, después, en Administrar complementos.
  3. Haga clic en un complemento en la lista Nombre y luego en Deshabilitar. Pruebe Internet Explorer.
  4. Repita el paso 3 hasta que identifique el complemento que está causando el problema.

Compruebe si se ha resuelto el problema. Si se ha solucionado, ya ha terminado con este artículo. Si no, pruebe el método siguiente.

Método 4: Restablecer la configuración de Internet Explorer

Si el problema se debe a configuraciones o complementos de Internet Explorer dañados o incompatibles, normalmente puede resolver el problema restableciendo la configuración de Internet Explorer a la predeterminada.

Al restablecer la configuración de Internet Explorer, se pierden todas las opciones anteriores y no se pueden recuperar. Al restaurar la configuración predeterminada de Internet Explorer, es posible que algunas páginas web que se basan en cookies almacenadas, datos de formulario, contraseñas o complementos de explorador instalados anteriormente no funcionen de forma correcta. Sin embargo, restablecer Internet Explorer a su configuración predeterminada no elimina sus favoritos, fuentes y algunas otras configuraciones personalizadas.

Para restablecer la configuración de Internet Explorer, haga lo siguiente:

  1. Cierre todas las ventanas de Internet Explorer.

  2. Haga clic en Inicio, escriba inetcpl.cpl en el cuadro Buscar y, después, haga clic en inetcpl.cpl en la lista Programas. Aparecerá el cuadro de diálogo Opciones de Internet.

    Nota:

    Para Windows XP, haga clic en Inicio y en Ejecutar. En el cuadro Abrir, escriba inetcpl.cpl y luego haga clic en Aceptar.

  3. Haga clic en la pestaña Opciones avanzadas.

  4. En Restablecer la configuración de Internet Explorer, haga clic en Restablecer. Después, haga clic en Restablecer de nuevo.

  5. Cuando Internet Explorer termine de restablecer la configuración, haga clic en Cerrar en el cuadro de diálogo Restablecer configuración de Internet Explorer.

  6. Inicie Internet Explorer de nuevo. Estos cambios surtirán efecto la próxima vez que abra Internet Explorer.

Método 5: Volver a registrar los archivos DLL de Internet Explorer necesarios

Nota:

Esta información se aplica a Windows XP

Para volver a registrar los archivos DLL, siga estos pasos:

  1. Haga clic en Inicio, Todos los programas y Accesorios, haga clic con el botón derecho en cmd y luego seleccione Ejecutar como administrador. Si se le pide una contraseña o confirmación de administrador, escriba la contraseña o proporcione la confirmación.

  2. Escriba regsvr32 urlmon.dll en el cuadro Abrir y, después, haga clic en Aceptar.

  3. Haga clic en Aceptar cuando reciba la confirmación.

  4. Repita los pasos 2 y 3 para los siguientes comandos:

    • regsvr32 mshtml.dll
    • regsvr32 shdocvw.dll
    • regsvr32 browseui.dll
    • regsvr32 msjava.dll

Compruebe si se ha resuelto el problema. Si se ha solucionado, ya ha terminado con este artículo. Si el problema persiste, vaya a la sección siguiente.

Solución de problemas avanzada

Esta sección está destinada a los usuarios del equipo más avanzados.

Paso 1: Crear una nueva cuenta de usuario

Para obtener más información sobre los perfiles de usuario, consulte Acerca de los perfiles de usuario.

Para conocer los detalles del método, visite los siguientes sitios web de Microsoft:

Método 2: Usar Restaurar sistema

Restaurar sistema usa puntos de restauración para devolver los archivos y la configuración del sistema a un momento dado anterior sin afectar a los archivos personales. Los puntos de restauración se crean automáticamente cada semana y justo antes de eventos significativos del sistema, como la instalación de un programa, un dispositivo o un controlador.

Antes de iniciar Restaurar sistema, guarde los archivos abiertos y cierre todos los programas. Después de confirmar el punto de restauración, Restaurar sistema reinicia el equipo. Para llevar a cabo una restauración del sistema, siga estos pasos:

Para Windows 7 y Windows Vista

  1. Haga clic en Inicio, Todos los programas, Accesorios, Herramientas del sistema y Restaurar sistema. Si se le pide una contraseña o confirmación de administrador, escriba la contraseña o proporcione la confirmación.

  2. Haga clic en Siguiente en la página Restaurar sistema.

  3. Seleccione la fecha o descripción de restauración del sistema que desee.

    Nota:

    Si no ve la fecha específica que está buscando, seleccione Mostrar más fechas y, después, seleccione la que desee.

  4. En la ventana de confirmación, haga clic en Finalizar. El equipo se reiniciará. Una vez completado el proceso, recibirá un mensaje de confirmación.

En Windows XP

  1. Inicie sesión en Windows con una cuenta que tenga permisos de administrador.
  2. Haga clic en Inicio, Todos los programas, Accesorios, Herramientas del sistema y Restaurar sistema.
  3. En la página Le damos la bienvenida a Restaurar sistema, seleccione la opción Restaurar el equipo a un estado anterior y luego haga clic en Siguiente.
  4. En la página Seleccionar un punto de restauración, haga clic en el punto de restauración del sistema más reciente en la lista, haga clic en una lista de puntos de restauración y, luego, en Siguiente.
  5. En la página Confirmar selección del punto de restauración, haga clic en Siguiente. Restaurar sistema restablece la configuración anterior de Windows XP y luego reinicia el equipo.
  6. Inicie sesión en el equipo como administrador. Después, haga clic en Aceptar en la página Restauración del sistema completa. El equipo se reiniciará. Una vez completado el proceso, recibirá un mensaje de confirmación.

Si usa Restaurar sistema, pero el problema se sigue produciendo u ocurren otros, puede deshacer la operación de restauración. Después de deshacer la operación, puede intentar usar un punto de restauración diferente. Para deshacer una operación de restauración del sistema, siga estos pasos:

  1. Haga clic en Inicio, Todos los programas, Accesorios, Herramientas del sistema y Restaurar sistema.
  2. Haga clic en Deshacer Restaurar sistema y luego en Siguiente.
  3. Revise las elecciones y luego haga clic en Finalizar.

El equipo se reiniciará. Una vez completado el proceso, recibirá una confirmación.

Recursos adicionales

Compruebe si se ha resuelto el problema. Si se ha solucionado, ya ha terminado con este artículo. Si no se resuelve el problema, también puede utilizar el sitio web de los servicios de soporte al cliente de Microsoft para buscar otras soluciones. Los servicios del Soporte técnico de Microsoft incluyen los métodos siguientes:

  • Busque en Microsoft Knowledge Base: encuentre información de soporte técnico y herramientas de autoayuda para productos de Microsoft.
  • Centros de soluciones: consulte las preguntas más frecuentes sobre los productos específicos y los elementos más destacados de soporte.
  • Comunidad Microsoft: consulte con sus homólogos, colegas y los Profesionales más valiosos de Microsoft (MVP).
  • Otras opciones de soporte: utilice el sitio web para hacer una pregunta, ponerse en contacto con los servicios de soporte al cliente de Microsoft o enviar comentarios.