Wanneer u de toegang in de Microsoft Dynamics CRM e-mailrouter test, ontvangt u de fout ((401) Niet-geautoriseerd

Dit artikel biedt een oplossing voor een fout die optreedt wanneer u de toegang in de Microsoft Dynamics CRM E-mailrouter test.

Van toepassing op: Microsoft Dynamics CRM
Origineel KB-nummer: 2003033

Symptomen

Wanneer u Toegang testen selecteert in het configuratieprogramma voor e-mailrouters voor Microsoft Dynamics CRM, ontvangt u het volgende foutbericht voor binnenkomende e-mailberichten:

'Binnenkomende status: fout: de externe e-mailserver van Microsoft Exchange heeft de fout '(401) Niet geautoriseerd' geretourneerd. Controleer of u bent gemachtigd om verbinding te maken met het postvak. De externe server heeft een fout geretourneerd: (401) Niet gemachtigd.

Oorzaak

Dit probleem kan worden veroorzaakt door een of meer van de volgende voorwaarden:

  • Het account dat is opgegeven in het binnenkomende profiel heeft geen volledige toegang tot de postvakken van gebruikers.
  • Er ontbreken SPN's (Service Principal Names) wanneer een alias wordt gebruikt voor Microsoft Office Outlook Web Access.
  • Het meest recente updatepakket voor Microsoft Dynamics CRM wordt niet toegepast.
  • Verificatie voor de virtuele mappen Exadmin en Exchange is onjuist.
  • De URL van Outlook Web Access ontbreekt in de zone Lokaal intranet in Windows Internet Explorer op de server waarop de e-mailrouter is geïnstalleerd.

Oplossing 1

Controleer of het account dat is opgegeven in het binnenkomende profiel volledige toegang heeft tot de postvakken van gebruikers. Controleer ook of het lokale systeemaccount de Microsoft CRM Email Router-service start.

Als u wilt controleren welk account de Microsoft CRM Email Router start, volgt u deze stappen op de server waarop de e-mailrouter is geïnstalleerd:

  1. Selecteer Start, selecteer Uitvoeren, typ Services.msc en selecteer vervolgens OK.
  2. Zoek de Microsoft CRM Email Router-service.

    Opmerking

    Het account dat wordt vermeld in de kolom Aanmelden als en controleer vervolgens of het is ingesteld op LocalSystem.

Voer de volgende stappen uit op de computer waarop de Microsoft CRM Email Router is geïnstalleerd om het account te controleren dat is opgegeven voor toegang tot binnenkomende profielen:

  1. Selecteer Start, selecteer Alle programma's, selecteer Microsoft Dynamics CRM E-mailrouter en selecteer vervolgens Microsoft CRM Email Router Configuration Manager.

  2. Selecteer het tabblad Configuratieprofielen , dubbelklik op Binnenkomende profiel en noteer het account dat is opgegeven in het veld Toegangsreferenties . Controleer of dit account volledige toegang heeft tot het postvak van de gebruiker.

    1. Als u de optie Postvak doorsturen gebruikt voor al uw gebruikers en wachtrijen, raden we u aan de referenties van het doorstuurpostvak in dit veld te gebruiken.
    2. Als u de optie Router gebruikt voor uw gebruikers en wachtrijen, moet u ervoor zorgen dat het account dat is opgegeven in het veld Toegangsreferenties volledige toegang heeft tot de postvakken van al deze gebruikers.

Zie de volgende artikelen voor meer informatie over het toevoegen van extra machtigingen voor postvak IN van gebruikers:

Oplossing 2

Als u gebruikt http://mail.domain.com voor toegang tot Outlook Web Access, maar uw Microsoft Exchange Server naam Exchange01 is, moet u meer SPN's toevoegen aan het account waarop de groep toepassingen voor uw Exchange-website wordt uitgevoerd.

Voer de volgende stappen uit om te bepalen welk account de exchange-toepassingsgroep start:

  1. Meld u aan bij de Microsoft Exchange Server.
  2. Selecteer Start, selecteer Uitvoeren, typ Inetmgr en selecteer vervolgens OK.
  3. Vouw uw server uit in IIS en selecteer vervolgens Toepassingsgroepen.
  4. Het account waarop de Exchange-toepassingsgroep wordt uitgevoerd, wordt weergegeven in het voorbeeldvenster.

Voeg de volgende SPN's toe aan het account dat u in stap 4 hebt geïdentificeerd:

  • HTTP/Mail
  • HTTP/Mail.yourdomainname.com

Opmerking

U moet deze SPN's wijzigen zodat deze overeenkomen met de alias-URL die uw gebruikers gebruiken om toegang te krijgen tot Outlook Web Access.

Ga naar de volgende Microsoft-websites voor meer informatie over het toevoegen van SPN's:

Oplossing 3

Opmerking

Deze resolutie is alleen van toepassing op Microsoft Dynamics CRM 4.0.

Controleer of er minimaal updatepakket 3 voor Microsoft Dynamics CRM 4.0 is geïnstalleerd voor de Microsoft Dynamics CRM Server en voor de Microsoft Dynamics CRM e-mailrouter. Het meest recente updatepakket wordt ten zeerste aanbevolen.

Zie [Microsoft Dynamics CRM 4.0-updates en hotfixes] voor meer informatie en om het meest recente updatepakket voor Microsoft Dynamics CRM te downloaden.

Oplossing 4

Controleer de volgende verificatie voor de /Exchange virtuele mappen en /Exadmin :

  • Controleer of basisverificatie en Windows-verificatie zijn ingeschakeld voor de /Exadmin virtuele map.
  • Controleer of Basisverificatie is ingeschakeld voor de /Exchange virtuele map.

Als u de verificatie voor de virtuele mappen wilt controleren, volgt u deze stappen op de Microsoft Exchange Server die van toepassing zijn op het besturingssysteem dat u uitvoert:

  • Op Windows Server 2008:

    1. Selecteer Start, selecteer Uitvoeren, typ Inetmgr en selecteer vervolgens OK.
    2. Vouw de servernaam uit, vouw Sites uit en vouw vervolgens de Exchange-website uit.
    3. Selecteer de virtuele map /Exadmin , open Verificatie in het deelvenster Preview en controleer of Basisverificatie en Windows-verificatie zijn ingeschakeld.
    4. Selecteer de virtuele map /Exchange , open Verificatie in het deelvenster Voorbeeld en controleer of Basisverificatie is ingeschakeld.
  • Op Windows Server 2003:

    1. Selecteer Start, selecteer Uitvoeren, typ Inetmgr en selecteer vervolgens OK.
    2. Vouw de servernaam uit, vouw Sites uit en vouw vervolgens de Exchange-website uit.
    3. Klik met de rechtermuisknop op de virtuele map /Exadmin en selecteer vervolgens Eigenschappen.
    4. Selecteer het tabblad Adreslijstbeveiliging , selecteer Bewerken onder Verificatie en toegangsbeheer en controleer vervolgens of Basisverificatie en Windows-verificatie zijn ingeschakeld.
    5. Klik met de rechtermuisknop op de virtuele map /Exchange en selecteer vervolgens Eigenschappen.
    6. Selecteer het tabblad Adreslijstbeveiliging , selecteer Bewerken onder Verificatie en toegangsbeheer en controleer vervolgens of Basisverificatie en Windows-verificatie zijn ingeschakeld.

Oplossing 5

Voeg de URL voor Outlook Web Access toe aan de zone Lokaal intranet en controleer of Automatisch aanmelden is ingeschakeld op de server waarop de Microsoft Dynamics CRM e-mailrouter is geïnstalleerd. Volg deze stappen om dit te doen:

  1. Meld u aan bij de computer waarop de CRM-e-mailrouter is geïnstalleerd met behulp van het account dat is opgegeven in het inkomende profiel.

  2. Open Internet Explorer.

  3. Selecteer Extra en selecteer vervolgens Internetopties.

  4. Selecteer het tabblad Beveiliging , selecteer Lokaal intranet en selecteer vervolgens Sites.

  5. Selecteer Geavanceerd, voeg de URL toe die u gebruikt voor toegang tot Outlook Web Access en voeg vervolgens de URL toe voor de Exchange Server.

  6. Selecteer Sluiten en klik vervolgens op OK.

  7. Zorg ervoor dat Lokaal intranet is geselecteerd, selecteer Aangepast niveau en selecteer vervolgens Automatisch aanmelden alleen in intranetzone.

  8. Selecteer twee keer OK en selecteer vervolgens Toepassen.

  9. Sluit alle Internet Explorer-sessies.

Opmerking

Internet Explorer kan worden uitgevoerd in de context van een specifiek gebruikersaccount terwijl u bent aangemeld bij Windows als een ander gebruikersaccount. Ir kan worden bereikt door op Shift te drukken en vervolgens met de rechtermuisknop op het uitvoerbare bestand van Internet Explorer te klikken , waarmee de optie wordt weergegeven om Internet Explorer als een andere gebruiker uit te voeren. Als Internet Explorer wordt uitgevoerd onder de context van het binnenkomende profielaccount op de computer waarop de e-mailrouter is geïnstalleerd, kan deze worden gebruikt om stap 1 en 2 hierboven te omzeilen.