Microsoft Dynamics CRM E-posta Yönlendiricisi'nde erişimi test ettiğinizde "(401) Yetkisiz" hatası alıyorsunuz

Bu makale, Microsoft Dynamics CRM E-posta Yönlendiricisi'nde erişimi test ettiğinizde oluşan bir hataya çözüm sağlar.

Şunlar için geçerlidir: Microsoft Dynamics CRM
Özgün KB numarası: 2003033

Belirtiler

Microsoft Dynamics CRM için E-posta Yönlendirici Yapılandırma Aracı'nda Erişimi Test Et'i seçtiğinizde, gelen e-posta iletileri için aşağıdaki hatayı alırsınız:

"Gelen Durum: Hata - Uzak Microsoft Exchange e-posta sunucusu "(401) Yetkisiz" hatasını döndürdü. Posta kutusuna bağlanma izniniz olduğunu doğrulayın. Uzak sunucu bir hata döndürdü: (401) Yetkisiz."

Neden

Aşağıdaki koşullardan biri veya daha fazlası bu soruna neden olabilir:

  • Gelen Profilinde belirtilen hesabın kullanıcıların posta kutularına tam erişimi yoktur.
  • Microsoft Office Outlook Web Access için bir diğer ad kullanıldığında eksik Hizmet Asıl Adları (SPN) vardır.
  • Microsoft Dynamics CRM için en son güncelleştirme paketi uygulanmaz.
  • Exadmin ve Exchange sanal dizinlerinde kimlik doğrulaması yanlış.
  • E-posta Yönlendiricisi'nin yüklü olduğu sunucudaki Windows Internet Explorer'daki Yerel Intranet Bölgesinde Outlook Web Erişimi URL'si eksik.

Çözüm 1

Gelen Profilinde belirtilen hesabın kullanıcıların posta kutularına Tam erişime sahip olduğunu doğrulayın. Ayrıca Yerel Sistem hesabının Microsoft CRM Email Yönlendirici Hizmeti'ni başlatdığını doğrulayın.

Microsoft CRM Email Yönlendiricisi'ni başlatan hesabı doğrulamak için, E-posta Yönlendiricisi'nin yüklü olduğu sunucuda şu adımları izleyin:

  1. Başlat'ı seçin, Çalıştır'ı seçin, Services.msc yazın ve ardından Tamam'ı seçin.
  2. Microsoft CRM Email Yönlendirici hizmetini bulun.

    Not

    Farklı Oturum Aç sütununda listelenen hesap ve ardından LocalSystem olarak ayarlandığını doğrulayın.

Gelen Profil erişimi için belirtilen hesabı doğrulamak için, Microsoft CRM Email Yönlendiricisi'nin yüklü olduğu bilgisayarda şu adımları izleyin:

  1. Başlat'ı seçin, Tüm programlar'ı seçin, Microsoft Dynamics CRM E-posta Yönlendiricisi'ni ve ardından Yönlendirici Configuration Manager Microsoft CRM Email'ı seçin.

  2. Yapılandırma Profilleri sekmesini seçin, Gelen Profil'e çift tıklayın ve Erişim Kimlik Bilgileri alanında belirtilen hesabı not edin. Bu hesabın kullanıcının posta kutusuna tam erişimi olduğunu doğrulayın.

    1. Tüm kullanıcılarınız ve kuyruklarınız için Posta Kutusunu İlet seçeneğini kullanıyorsanız, bu alanda posta kutusu kimlik bilgilerini iletmenizi öneririz.
    2. Kullanıcılarınız ve kuyruklarınız için Yönlendirici seçeneğini kullanıyorsanız, Erişim Kimlik Bilgileri alanında belirtilen hesabın tüm bu kullanıcıların gelen kutularına tam erişimi olduğundan emin olmanız gerekir.

Kullanıcıların gelen kutularına ek izinler ekleme hakkında daha fazla bilgi için aşağıdaki makalelere bakın:

Çözünürlük 2

Outlook Web Access'e erişmek için kullanıyorsanız http://mail.domain.com ancak Microsoft Exchange Server adınız Exchange01 ise, Exchange web siteniz için Uygulama Havuzu'nu çalıştıran hesaba daha fazla SPN eklemeniz gerekir.

Exchange Uygulama Havuzunu başlatan hesabı belirlemek için şu adımları izleyin:

  1. Microsoft Exchange Server oturum açın.
  2. Başlat'ı seçin, Çalıştır'ı seçin, Inetmgr yazın ve tamam'ı seçin.
  3. IIS'de sunucunuzu genişletin ve ardından Uygulama Havuzları'nu seçin.
  4. Exchange Uygulama Havuzunu çalıştıran hesap önizleme bölmesinde listelenir.

4. adımda tanımladığınız hesaba aşağıdaki SPN'leri ekleyin:

  • HTTP/Mail
  • HTTP/Mail.yourdomainname.com

Not

Bu SPN'leri, kullanıcılarınızın Outlook Web Access'e erişmek için kullandığı diğer ad URL'si ile eşleşecek şekilde değiştirmeniz gerekir.

SPN ekleme hakkında daha fazla bilgi için aşağıdaki Microsoft web sitelerini ziyaret edin:

Çözüm 3

Not

Bu çözüm yalnızca Microsoft Dynamics CRM 4.0 için geçerlidir.

Microsoft Dynamics CRM Sunucusu ve Microsoft Dynamics CRM E-posta Yönlendiricisi için Microsoft Dynamics CRM 4.0 için en az Güncelleştirme Paketi 3'ün yüklü olduğunu doğrulayın. En son güncelleştirme paketi kesinlikle önerilir.

Daha fazla bilgi edinmek ve Microsoft Dynamics CRM için en son güncelleştirme paketini indirmek için bkz. [Microsoft Dynamics CRM 4.0 güncelleştirmeleri ve düzeltmeleri].

Çözünürlük 4

ve /Exadmin sanal dizinlerinde aşağıdaki kimlik doğrulamasını /Exchange denetleyin:

  • Sanal dizinde Temel Kimlik Doğrulaması ve Windows Kimlik Doğrulaması'nın /Exadmin etkinleştirildiğini doğrulayın.
  • Sanal dizinde Temel Kimlik Doğrulaması'nın /Exchange etkinleştirildiğini doğrulayın.

Sanal dizinlerde kimlik doğrulamasını denetlemek için, çalıştırdığınız işletim sistemine uygun şekilde Microsoft Exchange Server aşağıdaki adımları izleyin:

  • Windows Server 2008'de:

    1. Başlat'ı seçin, Çalıştır'ı seçin, Inetmgr yazın ve tamam'ı seçin.
    2. Sunucu adını genişletin, Siteler'i genişletin ve ardından Exchange Web Sitesini genişletin.
    3. /Exadmin sanal dizinini seçin, Önizleme bölmesinde Kimlik Doğrulaması'nı açın ve Temel Kimlik Doğrulaması ile Windows Kimlik Doğrulaması'nın etkinleştirildiğini doğrulayın.
    4. /Exchange sanal dizinini seçin, Önizleme bölmesinde Kimlik Doğrulaması'nı açın ve Temel Kimlik Doğrulaması'nın etkinleştirildiğini doğrulayın.
  • Windows Server 2003'te:

    1. Başlat'ı seçin, Çalıştır'ı seçin, Inetmgr yazın ve tamam'ı seçin.
    2. Sunucu adını genişletin, Siteler'i genişletin ve ardından Exchange Web Sitesini genişletin.
    3. /Exadmin sanal dizinine sağ tıklayın ve özellikler'i seçin.
    4. Dizin Güvenliği sekmesini seçin, Kimlik doğrulaması ve erişim denetimi altında Düzenle'yi seçin ve ardından Temel Kimlik Doğrulaması ve Windows Kimlik Doğrulaması'nın etkinleştirildiğini doğrulayın.
    5. /Exchange sanal dizinine sağ tıklayın ve özellikler'i seçin.
    6. Dizin Güvenliği sekmesini seçin, Kimlik doğrulaması ve erişim denetimi altında Düzenle'yi seçin ve ardından Temel Kimlik Doğrulaması ve Windows Kimlik Doğrulaması'nın etkinleştirildiğini doğrulayın.

Çözünürlük 5

Outlook Web Access URL'sini Yerel İntranet Bölgesine ekleyin ve Microsoft Dynamics CRM E-posta Yönlendiricisi'nin yüklü olduğu sunucuda Otomatik Oturum Açma'nın etkinleştirildiğini doğrulayın. Bunu yapmak için şu adımları uygulayın:

  1. Gelen Profilinde belirtilen hesabı kullanarak CRM E-posta Yönlendiricisi'nin yüklü olduğu bilgisayarda oturum açın.

  2. Internet Explorer'ı açın.

  3. Araçlar'ı ve ardından İnternet Seçenekleri'ni seçin.

  4. Güvenlik sekmesini seçin, Yerel İntranet'i ve ardından Siteler'i seçin.

  5. Gelişmiş'i seçin, Outlook Web Access'e erişmek için kullandığınız URL'yi ekleyin ve ardından Exchange Server URL'sini ekleyin.

  6. Kapat'ı ve ardından Tamam'ı seçin.

  7. Yerel İntranet'in seçili olduğundan emin olun, Özel Düzey'i seçin ve ardından Yalnızca Intranet bölgesinde otomatik olarak oturum aç'ı seçin.

  8. İki kez Tamam'ı ve ardından Uygula'yı seçin.

  9. Tüm Internet Explorer oturumlarını kapatın.

Not

Internet Explorer, Windows'ta farklı bir kullanıcı hesabı olarak oturum açmışken belirli bir kullanıcı hesabının bağlamı altında değiştirilebilir. Ir, shift tuşuna basarak ve ardından Internet Explorer yürütülebilir dosyasını sağ tıklatarak gerçekleştirilebilir. Bu işlem, Internet Explorer'ı farklı bir kullanıcı olarak çalıştırma seçeneğini görüntüler. Internet Explorer, e-posta yönlendiricisinin yüklü olduğu bilgisayardaki gelen profil hesabının bağlamı altında çalıştırılırsa, yukarıdaki 1. ve 2. adımları atlamak için kullanılabilir.