"The account does not have permissions to impersonate the requested user" error occurs when you connect the Microsoft Dynamics E-mail Router to Microsoft Exchange 2010

This article provides a solution to an error that occurs when you connect the Microsoft Dynamics E-mail Router to Microsoft Exchange 2010.

Applies to:   Microsoft Dynamics CRM
Original KB number:   2015567

Symptoms

When you select Test Access in the Microsoft Dynamics CRM E-mail Router, you receive the following error if you're using Microsoft Exchange 2010:

The account does not have permissions to impersonate the requested user.

Cause

Impersonation isn't set up on the account that you specified on the Incoming E-mail Profile or for the user who is set up to use the Router for incoming email.

Resolution

You can specify Setup Exchange Impersonation for the account that is specified on the incoming profile if you're using a forward mailbox and for individual user accounts if the E-mail access type-Incoming is set to Router on the user record. To do it, follow these steps:

  1. Open the Microsoft Dynamics CRM E-mail Router Configuration Manager.
  2. Select the Configuration Profiles tab.
  3. Open the profile that has Incoming set for the direction, and then note the account that is specified in the Access Credentials field.
  4. Set up Exchange Impersonation for the account that is specified in step 3. To do it, follow the steps in Configuring Exchange Impersonation in Exchange 2010.
  5. Open Microsoft Dynamics CRM.
  6. Select Settings, and then select Users.
  7. Double-click a user record, and then note the value in the E-mail access type-Incoming field.
  8. If E-mail access type-Incoming is set to Router, you must use the information in the following article to set up Exchange Impersonation for the account that is listed in the Domain Name field in Configuring Exchange Impersonation in Exchange 2010.
  9. Complete steps 7 through 8 for all users who receive this error.

More information

If you have specific questions or concerns while you're setting up impersonation, contact your Exchange Administrator, or contact the Microsoft Exchange Support Team.