Mensaje de error: "Clase no registrada" al actualizar datos de PowerPivot

Síntomas

Verá los siguientes errores al intentar actualizar los datos de un libro PowerPivot creado en otro equipo:

El nombre> del proveedor <no está registrado.
Error del sistema siguiente: Clase no registrada No se pudo realizar una conexión al origen de datos con el DataSourceID del identificador> del origen de <datos, Nombre del origen> de <datos. Error al procesar el nombre> de la <tabla. El nombre> del proveedor <no está registrado.
La operación se ha cancelado.

Nota:

El error se puede repetir para cada conexión que produce un error.

Causa

Este problema suele producirse en los siguientes escenarios:

  • Intente actualizar los datos con los datos más actuales del servidor back-end mediante la opción Actualizar todo en el menú Actualizar .
  • Intente importar datos mediante una de las conexiones de la opción Conexión existente en la pestaña Diseño .

Este comportamiento es una característica del diseño de la aplicación. Se produce cuando el proveedor definido para la conexión de datos para los datos de PowerPivot no existe en el sistema.

Solución

Para resolver el problema, use uno de los procedimientos siguientes.

Procedimiento 1: Configurar la conexión con errores para usar un proveedor diferente y compatible que existe en el sistema

Para ello, siga estos pasos:

  1. En la ventana Power Pivot, seleccione la pestaña Diseño en el menú de la cinta de opciones.
  2. Seleccione Connections existente.
  3. En la lista de conexiones disponibles, seleccione la conexión que produce un error y, a continuación, seleccione Editar.
  4. En la ventana Editar conexión , seleccione Opciones avanzadas.
  5. En el área Establecer propiedades avanzadas , cambie el valor proveedor a un proveedor diferente y compatible y, a continuación, actualice los datos.

Por ejemplo, si la conexión está configurada para usar SQLNCLI10 (proveedor de SQL Native Client 10) y si SQL Native Client no está instalado en el sistema, cambie el proveedor a SQLOLEDB y, a continuación, actualice los datos del libro.

Procedimiento 2: Instalación del proveedor

  1. Identifique el proveedor que se usa para la conexión con errores. Para ello, use la información del mensaje de error o los pasos que se documentan en el procedimiento 1 para identificar al proveedor.
  2. Instale ese proveedor en el sistema mediante el medio de instalación o descargando el proveedor de Internet.

Más información

También puede ver un mensaje de error similar cuando se usa un sistema de 32 bits para trabajar con un libro desarrollado en un sistema de 64 bits. Además, no hay ningún proveedor de 32 bits disponible para una o varias de las conexiones definidas en el libro, o bien el proveedor de 32 bits no está instalado en el sistema o viceversa.

¿Aún necesita ayuda? Visite Comunidad Microsoft.