Message d’erreur : « Classe non inscrite » lorsque vous mettez à jour des données PowerPivot

Symptômes

Les erreurs suivantes s’affichent lorsque vous essayez de mettre à jour des données dans un classeur PowerPivot créé sur un autre ordinateur :

Le nom> du fournisseur <n’est pas inscrit.
L’erreur système suivante s’est produite : Classe non inscrite Une connexion n’a pas pu être établie à la source de données avec le DataSourceID de l’ID> de <source de données', nom de la source> de <données. Une erreur s’est produite lors du traitement du nom> de la <table. Le nom> du fournisseur <n’est pas inscrit.
L’opération a été annulée.

Remarque

L’erreur peut être répétée pour chaque connexion qui échoue.

Cause

Ce problème se produit généralement dans les scénarios suivants :

  • Vous essayez de mettre à jour les données avec les données les plus actuelles du serveur principal à l’aide de l’option Actualiser tout dans le menu Actualiser .
  • Vous essayez d’importer des données à l’aide de l’une des connexions sous l’option Connexion existante sous l’onglet Création .

Ce comportement est inhérent au produit. Elle se produit lorsque le fournisseur défini pour la connexion de données pour les données PowerPivot n’existe pas sur votre système.

Résolution

Pour résoudre le problème, utilisez l’une des procédures suivantes.

Procédure 1 : Configurer la connexion défaillante pour utiliser un fournisseur différent et compatible qui existe sur votre système

Pour cela, procédez comme suit :

  1. Dans la fenêtre Power Pivot, sélectionnez l’onglet Création dans le menu du ruban.
  2. Sélectionnez Connections existant.
  3. Dans la liste des connexions disponibles, sélectionnez la connexion qui échoue, puis sélectionnez Modifier.
  4. Dans la fenêtre Modifier la connexion , sélectionnez Avancé.
  5. Dans la zone Définir les propriétés avancées, remplacez la valeur Fournisseur par un autre fournisseur compatible, puis mettez à jour les données.

Par exemple, si la connexion est configurée pour utiliser SQLNCLI10 (fournisseur SQL Native Client 10) et si SQL Native Client n’est pas installé sur votre système, remplacez le fournisseur par SQLOLEDB, puis mettez à jour les données dans le classeur.

Procédure 2 : Installer le fournisseur

  1. Identifiez le fournisseur utilisé pour la connexion défaillante. Pour ce faire, utilisez les informations contenues dans le message d’erreur ou les étapes décrites dans la procédure 1 pour identifier le fournisseur.
  2. Installez ce fournisseur sur votre système à l’aide du support d’installation ou en téléchargeant le fournisseur à partir d’Internet.

Informations supplémentaires

Vous pouvez également voir un message d’erreur similaire lorsque vous utilisez un système 32 bits pour travailler avec un classeur qui a été développé sur un système 64 bits. De plus, il n’existe aucun fournisseur 32 bits disponible pour une ou plusieurs des connexions définies dans votre classeur, ou le fournisseur 32 bits n’est pas installé sur votre système, ou inversement.

Encore besoin d’aide ? Accédez à Microsoft Community.